Some native filenames are garbled in attachment panel

VERIFIED DUPLICATE of bug 229872

Status

MailNews Core
Internationalization
VERIFIED DUPLICATE of bug 229872
15 years ago
10 years ago

People

(Reporter: Isaac Hwak Han, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({intl})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ko-KR; rv:1.7a) Gecko/20040108
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ko-KR; rv:1.7a) Gecko/20040108

It seems that certain native filenames are not displayed right in attachment panel.

Reproducible: Always

Steps to Reproduce:
1. Prepare some files with non-ASCII native names (in my case, "가을.jpg", "겨
울.jpg" and "석양.jpg")
2. File => New => Message
3. View => Character Coding => Korean (EUC-KR) or Unicode (UTF-8)
3. Click attachment panel to add attachment file.
4. In dialog, select "겨울.jpg".
5. Click OK.
6. Repeat 4-5, and attach another files, "가을.jpg" and "석양.jpg"
7. 

Actual Results:  
Attachment:
* 겨울.jpg
* 가??jpg
* <nothing>


Expected Results:  
Attachment:
* 겨울.jpg
* 가을.jpg
* 석양.jpg


This behavior doesn't depend on the order of files attached.

When I sent and received the mail, the attachment list shows like this:

* 겨울.jpg
* ¼®¾ç.jpg
* ¼ö·Ã.jpg

Similar bug is already filed as bug 191502, but it's Mac-only, and way too old.
(Reporter)

Updated

15 years ago
Component: Attachments → Internationalization
Keywords: intl
(Reporter)

Comment 2

15 years ago
Yes. it's a dup.

*** This bug has been marked as a duplicate of 229872 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.