:root - overflow property is not applied to the viewport

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: annevk, Assigned: dbaron)

Tracking

({css2, testcase})

Trunk
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031219

HTML and XHTML test cases coming up.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
According to CSS21 <http://www.w3.org/TR/CSS21/visufx.html#overflow>:

> HTML UAs may apply the overflow property from the BODY or HTML elements to the
> viewport.

Mozilla fixed a bug about this for the BODY element, but now (?) there is a
problem with the HTML element.

 <http://annevankesteren.nl/test/css/p/overflow/root-overflow-auto.htm>
  'text/html' test case for 'overflow:auto;'

 <http://annevankesteren.nl/test/css/p/overflow/root-overflow-auto.xhtml>
  'application/xhtml+xml' test case for 'overflow:auto;'

 <http://annevankesteren.nl/test/css/p/overflow/root-overflow-scroll.htm>
  'text/html' test case for 'overflow:scroll;'

 <http://annevankesteren.nl/test/css/p/overflow/root-overflow-scroll.xhtml>
  'application/xhtml+xml' test case for 'overflow:scroll;'

Now I'm not sure if Mozilla should behave the same for XHTML (XML) documents,
but according to the CSS21 specification we may support it for HTML and I think
we should.
Keywords: css2, testcase
We apply overflow:hidden on both <body> and <html> to the viewport in HTML
documents (or at least should).  That's as far as we need to go, imo....
In the CSS spec, HTML != XHTML. It says HTML, not XHTML. Thus it doesn't apply
to XHTML. Does that make this bug INVALID?
(Reporter)

Comment 4

14 years ago
No, only partly. Because we don't do it correct for HTML elements. See the 2
text/html test cases.

(I wonder, how would you have to do this for XML? With something like ::viewport?)
(Reporter)

Updated

13 years ago
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Comment 5

13 years ago
*** Bug 11224 has been marked as a duplicate of this bug. ***
Depends on: 234851
The fix in bug 234851 makes the viewport overflow:auto in the first two cases
and overflow:scroll in the latter two cases, which is I think what Anne wants.

As per Hixie, in XHTML we probably should not propagate from HTML or BODY.
Currently we do. Turning off propagation from BODY would be quite easy. Turning
off propagation from the root for XHTML is quite hard because it requires fixing
some difficult bugs about reconstruction of the root frame with scrollbars. And,
we'd have to make the viewport explicitly stylable, possibly in advance of any
standard for that.
(Reporter)

Comment 7

13 years ago
For HTML issues, this bug is fixed. The XML issues should probably be moved to
another bug. These issues are:

 - 'overflow' is placed from xhtml|body, xhtml|html or *|*:root to the viewport
 - implementing '@-moz-viewport'

Shall I file them?
Keywords: qawanted
I don't want to implement these until the viewport rule has been standardized.
Feel free to file the bugs though.
(Reporter)

Comment 9

13 years ago
Filed bug 242646 and bug 242645.

Marking this bug as fixed, since all the (still) existing issues have been moved
to other bugs and main issue has been fixed by bug 234851.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: qawanted
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.