If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save As dialog switches Save and Cancel buttons

RESOLVED INVALID

Status

()

Firefox
General
--
trivial
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Matt Eaton, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20040109 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b) Gecko/20040109 Firebird/0.7+

The "Save As" dialog from File, Save Page or right clicking on a link and saving:

Shows the Cancel button on the left and the Save button on the right. This is a
major change from previous versions.

Reproducible: Always

Steps to Reproduce:
1.File, Save Page or right clicking on a link to save
2.Hit Cancel instead of Save accident out of habit


Actual Results:  
Dialog performs the correct action but the user is unaware since they clicked
the button on the left without reading it.

Expected Results:  
Kept the same button ordering for those of us that use Firebird and are used to
the ordering.

Comment 1

14 years ago
Confirming

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040113 Firebird/0.8.0+

Comment 2

14 years ago
It seems to me that this change was made to bring Firebird in line with the
Gnome UI standard, which places the default/ok button to the right and the
cancel button to the left.

If that was indeed the case, then this is probably a WONTFIX bug.

(Reporter)

Comment 3

14 years ago
Yes, I'm noticing it everywhere in my Gnome Apps now..

I'm not sure if there is a "Windows UI" standard, but for the windows most apps
are OK on left and Cancel on right. Is the Firebird for windows going to sport
the Gnome UI convention?

Comment 4

14 years ago
Created attachment 141084 [details]
Buttons from Firebird 0.7

Buttons from Firebird 0.7. Note the order:

[SAVE]	 [CANCEL]

Buttons' order in Firefox 0.8 are:

[CANCEL] [SAVE]

I don't know if they have been swapped intentionally, but it's quite annoying,
I tend to CANCEL everything :-(

Comment 5

14 years ago
Comment on attachment 141084 [details]
Buttons from Firebird 0.7

Buttons from Firebird 0.7. Note the order:

[SAVE]	 [CANCEL]

Buttons' order in Firefox 0.8 are:

[CANCEL] [SAVE]

I don't know if they have been swapped intentionally, but it's quite annoying,
I tend to CANCEL everything :-(

Comment 6

14 years ago
Created attachment 141085 [details]
Buttons from Firefox 0.8

Comment 7

14 years ago
Note the buttons' order from Firebird 0.7:

[SAVE]   [CANCEL]

Buttons' order in Firefox 0.8 are:

[CANCEL] [SAVE]

I don't know if they have been swapped intentionally, but it's quite annoying, I
tend to CANCEL everything :-(

Created attachment 141088 [details]
Firefox 0.8: Basic auth dialog (linux)

The first choice is definitely not "cancel", if user wants to log in.
Created attachment 141089 [details]
Firefox 0.8: "Open File..." dialog (linux)

Updated

14 years ago
Attachment #141088 - Attachment description: Navigating with TAB, at first focuses [ Cancel ] → Firefox 0.8: Basic auth dialog
Created attachment 141092 [details]
Firefox 0.8: Remember password confirmation (linux)

The placement of buttons was in 0.7:

[ Yes ] [ Never for this site ] [ No ]

My suggestion is:

[ Yes ] [ No ] [ Never for this site ]

Updated

14 years ago
Attachment #141088 - Attachment description: Firefox 0.8: Basic auth dialog → Firefox 0.8: Basic auth dialog (linux)

Updated

14 years ago
Attachment #141089 - Attachment description: Firefox 0.8: "Open File..." dialog → Firefox 0.8: "Open File..." dialog (linux)

Updated

14 years ago
Attachment #141092 - Attachment description: Firefox 0.8: Remember password confirmation. → Firefox 0.8: Remember password confirmation (linux)
I suggest Severity: Minor
Btw - in Windows build the buttons are as before.

I suggest clearify summary to reflect that it concerns (only?) Linux build and
not only "Save As..." dialog.

Comment 13

14 years ago
Mi suggestion is that we should be able to modify this "feature" as a new
option. Not everyone uses Gnome (I don't use it), and it's really annoying to
get used to the new layout of the buttons. I always tend to cancel, and I'm not
even able to notice if I have saved the file or cancelled it, as we get the same
results (no action).

If Gnome people want to have things upside down because it's their standard, I
don't mind at all, but I want to be able to tweak that behaviour because I don't
use Gnome and I'm used to the other layout of the buttons.
yes, this is a result of better GNOME compliance.  Being Windows-centric, it 
drives me nuts on my linux GTK2 builds, but that's the way the toolkit dictates 
it.  Its not a bug, we're honouring the toolkit defaults.  If you want this to 
change, try arguing the point with the GNOME project.  (as a note, OS X does it 
this way too)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: mconnor
Resolution: --- → INVALID
RESOLVED INVALID?

You just ignore your users, who give you valuable feedback about usability?
Unbelievable...
If every other app is Cancel/OK on GTK2, we'd be screwing up usability by NOT 
following the correct convention.  Like I said, we're following the rules of 
the platform here, bug the people building the platform if you want to argue 
the point.

Cancel/OK is standard on GTK2 and Mac OS X
OK/Cancel is standard on GTK1/QT and Win32

There is a bug somewhere about incorrectly switching for GTK1.2 builds, that is 
an issue we need to fix, but that's not what this bug is about.
*** Bug 239309 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
*** Bug 254110 has been marked as a duplicate of this bug. ***

Comment 19

13 years ago
*** Bug 264500 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.