Select does not fire onChange event when changed with keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 126379
14 years ago
14 years ago

People

(Reporter: Graham Lea, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

I am using onChange on a SELECT input (i.e. <select onChange="doSomething()">)
to change the visibility of two DIVs.
Using a mouse to change the selected OPTION of the SELECT works fine, and the
DIVs appear and disappear as expected.
However, if I use the keyboard to change the SELECT (up/down arrows), it appears
no onChange event is being fired, as the DIVs do not change.

Reproducible: Always

Steps to Reproduce:
1. Save the attached HTML file and open in Mozilla.
2. Change the SELECT option using a mouse.
3. Change the SELECT option using the keyboard (up and down arrows).

Actual Results:  
At step 2, when using the mouse, the alert appears, indicating that an onChange
event was fired.
At step 3, using the keyboard, no alert appears, indicating that NO onChange
event is fired.

Expected Results:  
onChange events should be fired whenever the selected option is changed,
regardless of input device or whether the drop-down list of the select appeared
or not.

Using the Modern theme.
(Reporter)

Comment 1

14 years ago
Created attachment 138828 [details]
HTML file demostrating the problem.
See bug 229424 comment 1 and bug 126379 comment 3

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.