Last Comment Bug 230866 - The name of "Republic of Macedonia" appears as "Macedonia, Former Yugoslav Republic of"
: The name of "Republic of Macedonia" appears as "Macedonia, Former Yugoslav Re...
Status: RESOLVED FIXED
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Simon Montagu :smontagu
:
Mentors:
http://lxr.mozilla.org/mozilla/search...
: 230867 (view as bug list)
Depends on: 1203171
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-14 01:08 PST by Ivan Stojmirov
Modified: 2015-10-05 12:45 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ivan Stojmirov 2004-01-14 01:08:31 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

It seems that there are no problems with the name of the language "Macedonian".
Yet, the name of the country appears as "Macedonia, Former Yugoslav Republic of"
instead of "Republic of Macedonia" or simply "Macedonia".



Reproducible: Always

Steps to Reproduce:
The name "Macedonia, F.Y.R. Of" appears in:

/xpfe/global/resources/locale/en-US/regionNames.properties, line 64
/toolkit/locale/regionNames.properties, line 64
/l10n/nscp/en-GB/chome/en-GB/locale/en-GB/global/regionNames.properties, line 63
/l10n/nscp/en-CA/chome/en-CA/locale/en-CA/global/regionNames.properties, line 63




Expected Results:  
The name of the country to apear as "Macedonia, Republic of"
Comment 1 Gilles Durys 2004-01-14 01:13:54 PST
*** Bug 230867 has been marked as a duplicate of this bug. ***
Comment 2 Oleg Sidletskiy 2004-01-14 01:32:01 PST
well, the CIA calls it "Macedonia, The Former Yugoslav Republic of"
http://www.cia.gov/cia/publications/factbook/geos/mk.html

but here's an official page (I think), which uses "the Republic of Macedonia"
http://www.gov.mk/English/
Comment 3 Ivan Stojmirov 2004-01-14 01:59:57 PST
The oficial (constitutional) name that the government uses is "Republic of
Macedonia".

Diferences with the naming in other countries (institutions) is their own
(political) issue. 

Google for example (and dmoz.org), calls it Macedonia:
http://directory.google.com/Top/Regional/Europe/Macedonia/Government/
Comment 4 Malcolm Rowe 2004-01-14 04:15:28 PST
We adhere to ISO 3166, which has the official country name as 'MACEDONIA, THE 
FORMER YUGOSLAV REPUBLIC OF'. See
http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-code-
lists/index.html

See also bug 153104, which is about updating regionNames.properties to the 
current ISO 3166 definitions.

-> INVALID, as ISO 3166 is the definitive source.
Comment 5 Jungshik Shin 2004-01-14 16:07:25 PST
This is not invalid. There's no reason to follow ISO 3166 in every case
(Country/region  codes should come from ISO 3166, but names for the _UI_ don't
have to). See my comment in bug 153104. Perhaps, 'Macedonia, Republic of' would
be about right. 
Comment 6 Novica Nakov 2004-01-14 16:27:06 PST
Don't you think that we, the people from Macedonia, know what is the name of our
country? There are unreasonable political reasons why the name appears as
Macedonia, Former Yugoslav Republic of in ISO 3166. If you like an explanation,
I'll gladly provide one.
Comment 7 Katsuhiko Momoi 2004-01-14 18:00:50 PST
I should provide the historcal reason for why this is so. Originally this entry
was simply [mk],
Macedonian. But we received strong complaints from Greek users about it. They
claimed that there 
is no such language as Macedonian. We explained at length that this is just a
language name and I cited many reasons why it could stay as simply [mk]. But
after much argumentation, there was no resolution. I spare you the details. If
you're familiar with the history of Macedonia, Macedonian, Bulgaria and Greece,
you know that there is no easy resolution. 

So we struck a compromise. Greek users opposed the use of the language name
Macedonian. We disagreed with this position and argued to retained the language
name but compromised by specifying 
the region name -[mk], which stands for the Former Yugoslav Republic of
Macedonia. It is also the name officially recognized in ISO 3166. I don't think
we want use Republic of Macedonia because some people believe in its existence.

My advice on this issue: Don't change the current designation. 

Issues have been extensively debated and there is no winning side on this
question. Mozilla is a piece of software and should not get involved in
political disputes. The UN in 1993 admitted the republic under a temporary name
of "Former Yugoslav Republic of Macedonia". Unless this name has changed, I
advise against making a change.
Comment 8 Katsuhiko Momoi 2004-01-14 18:19:24 PST
A note to: Novica Nakov:

Please understand that this is a very difficult issue for computer software to
resolve. Greek users
don't like the use of language name "Macedonian". FYOR users don't like the use
of -mk (FYOR) name for the region. mk-mk is a designation which contains a part
that neither side likes, but it also contain a part that both side are Ok with.
The language name for Macedonian people, and the region name for Greek/Bulgarian
people.
We are at least using the names officially approved by ISO 3166 and the UN. That
is the best a piece of software like Mozilla can do. If you want to make this
change, please get at least the ISO 3166 name changed first.
One more plea, please DO NOT provide historical or linguistic reasons for your
position. I understand them but there will be different view on them and we will
have no end to differing views. Bugzilla is not a place to argue about them.
Comment 9 Malcolm Rowe 2004-01-15 00:08:50 PST
re: comment 5. You're right, INVALID is the wrong resolution, since this is a
valid request. Perhaps WONTFIX would have been a better choice.
Re: comment 6. I was aware of some of the political controversy behind the name;
sorry if I didn't make that clear originally.

We don't follow ISO3166 slavishly, but when there is contention (as there *is*
in this case), we look to ISO3166 for the answer we'll choose. momoi is right:
we can't please all the people all the time.

Mozilla doesn't want to get involved in political arguments; by delegating to
the standard we can at least avoid being accused of supporting one side over the
other. Please lobby to get the country name designated in ISO3166 changed - it
would affect a lot more software than just Mozilla.

Followups to n.p.m.i18n, please.
Comment 10 Damjan Georgievski 2004-01-15 09:04:02 PST
> I should provide the historcal reason for why this is so. Originally this  
> entry was simply [mk], Macedonian. But we received strong complaints from  
> Greek users about it. They claimed that there is no such language as  
> Macedonian. 
 
How is that?  
Do the Greek users have knowledge about every other people in the world?!? 
... and about their languages? 
 
> but when there is contention (as there *is* in this case), we look to 
> ISO3166 for the answer we'll choose 
 
This is not a question of contention, it's a question of (human) rights. Read 
the UN charter. The name of our country is Republic of Macedonia, we know that 
this is our name. There's no reason why anyone would care about our name. 
I hope you'll understand this and fix the bug. 
 
When you do, drop us a message. Until then we will just tell everyone here in 
the Republic of Macedonia to continue to use IE or to switch back to it.  
Yes, it may require some patches from time to time, and we'll miss the  
tabbed browsing, but hey, MS knows the name of our country. 
 
Thank you for your efforts, and sorry if I wasted your time. 
 
Damjan Georgievski 
Free Software Macedonia 
Comment 11 Oleg Sidletskiy 2004-01-15 16:32:18 PST
> When you do, drop us a message. Until then we will just tell everyone here in 
> the Republic of Macedonia to continue to use IE or to switch back to it.

If you think you can influence anyone or anything with that attitude, you are
greatly mistaken.

> ...MS knows the name of our country.

Actually I just checked Win XP's "Reginonal and Language Options" window, and it
lists the coutry's name as "Macedonia, Former Yugoslav Republic of".
Comment 12 Katsuhiko Momoi 2004-01-15 21:52:56 PST
There is also a Microsoft Developer page that lists countrycode names:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/mpn30m/html/mpn30devtablescountryregionentityids.asp

This page lists the formal name as: The Former Yugoslav Republic of Macedonia
and the friendly name as: F.Y.R.O. Macedonia

In comment #11, Oleg says:


>> ...MS knows the name of our country.

> Actually I just checked Win XP's "Reginonal and Language Options" window, 
> and it lists the coutry's name as "Macedonia, Former Yugoslav Republic of".

There is a possibility of a compromise. We should not change the English 
UI name of the country [mk] but I believe it is up to the localizer to 
decide what corresponds to "F.Y.R.O. Macedonia" in Macedonian. The 
Macedonian L10n is targetd to Macedonians and just like you need to
translate English UI names like F.Y.R.O. Macedonia into Chinese, French and 
other languages, the mk-mk localizer should translate the name into mk 
and maybe call it "Република Македонија" (view this under UTF-8 encoding,
please) and I don't see why anyone would object to that.
Comment 13 Ivan Stojmirov 2004-01-16 02:23:58 PST
Microsoft recently signed a strategic partnership agreement with our government.
With that agreement they obligated to use our constitutional name in their
future products.

When lobbying against that agreement, one of the arguments we (Free Software
Macedonia) used was the use of the name FYROM in their products and oposite of
that we cheered on Free Software (KDE, GNOME) because it uses our real name.

Thats why we started localizing this software with the idea that localized
software + the name Macedonia in it was a great weapon against proprietary
software that doenst respect our language and name. 

Maybe Damjan over-reacted a bit, but there is a lot of truth in what he said.
People here are getting dissapointed because their work on the localization is
not properly aprecieated. 

Do what you must, but think reasonably. Who in the world can tell you that your
name is not John but JohnWithTheBigNose? Who can tell you that you cant call
yourself John because his dog is also named John?


Sorry for the bad spelling.




Ivan Stojmirov,
Free Software Macedonia
Comment 14 Katsuhiko Momoi 2004-01-16 03:02:58 PST
> Thats why we started localizing this software with the idea that localized
> software + the name Macedonia in it was a great weapon against proprietary
> software that doenst respect our language and name. 

Ivan,
Is it not sufficient that you can change the localized UI name to the 
equivalent of "Republic of Macedonia" in Macedonian as I suggested 
in comment #12? I don't think anyone will object to that. 
Comment 15 Ivan Stojmirov 2004-01-16 04:00:08 PST
Ofcourse, we can do that. We could even make a fork of Mozilla and name it
MacedoniaZilla if we want to. Right?

But then, why dont you suggest the Greek users to put FYROM in their
localization, and leave all the other localizations (including the default
(english) one) with our country's real name?


I realy dont want it to be like this. But if you search on the net, you will see
that this discussion (Macedonia <> Greece) is a standard, whenever the name
Macedonia is mentioned. Write "Macedonia" on a paper, and a Greek will come with
a pencil and correct it to FYRO Macedonia.
 
It might seem stupid to you, but if we left it to the Greeks, we would have been
called NoNamedonia by now.
Comment 16 Misa Popovic 2004-01-17 07:41:10 PST
I would like to point out that the freedom (and right) of states to be
recognized with their constitutional names, is guaranteed with the UN Charter.
It was aditionally confirmed with a resolution (i will provide the resolution
number soon) of the UN General Assembly. Because of the widespread affirmation
by all (exept one - Greece) members of the UN, it is considered not only as a
multilateral agreement but as international custom law, which means that
everyone is obligated to it, exept the "permanent objector" (Greece).

I am asking the Mozilla developers to recognize the problem as being made
political. Since the legal situation is clear, although being ignored by both
sides and the international community, the right thing to do, if Mozilla doesn't
want to get involved and take sides, is to folow the law and address Macedonia
as "Republic of Macedonia". It will be a small contribution of Mozilla to the
practice of the fragile international law.

Regarding ISO, I am convinced that similar actions will be asked from them.
Comment 17 Simon Montagu :smontagu 2004-01-17 10:41:31 PST
It is not accurate to state that we follow ISO 3166 in disputed cases. If so, we
would use "Taiwan, province of China" for tw.

http://www.iso.org/iso/en/prods-services/iso3166ma/10faq/frequently-asked-questions.html#QS03
gives ISO's reason for this term, which closely correspond to the reasons given
earlier in this bug for using the provisional UN name for Macedonia: "By
adhering to UN sources the ISO 3166/MA stays politically neutral."

Why do we not follow ISO in the case of Taiwan, and why do the same reasons not
apply to Macedonia?
Comment 18 Jungshik Shin 2004-01-17 11:10:01 PST
When I wrote comment #5 (I momentarily forgot that there's a dispute between
'Republic of Macedonia' and Greece), one of cases I had in mind was 'Taiwan'
(another was 'Hong Kong'). However, I think two cases (Taiwan and Macedonia) are
different. In case of Taiwan, PRC insists that Taiwan is a province of PRC and
would be very much infuriated at any company using Taiwan's constitutional name
'Republic of China'. That is, 'Taiwan' is a 'user-friendly' shorthand name  for
'Taiwan, province of China' acceptable to _both_ parties [1] because what PRC
opposes is not the name 'Taiwan' but the name 'Republic of _China_' and 'RoC'
constitution's territorial claim to the mainland China. In other words, 'Taiwan'
is politically neutral enough. 

BTW, PRC would be as much infuriated if Taiwan declared itself an independent
'Republic of _Taiwan_' 

[1] Chinese people on both sides of the channel are very practical and I have
yet to see a single person from Taiwan insisting that their country name should
be 'Republic of China' (the constitutional name) instead of just 'Taiwan'. 
Comment 19 Damjan Georgievski 2004-01-19 15:27:29 PST
Ok, I see that this issue is not going to be resolved today. 
Therefore I call all my compatriots to cease the discussion here... seems that
people cann't use their own name.

Since we don't have a trademark on the name Macedonia (like Mozilla has for its
name and can choose how one can use it), I can just plead the Mozilla team, to
stop using the offensive name "Macedonia, The Former Yugoslav Republic of" and
change it to a "Former Klingon Empire South part".

Damjan Georgievski
Free Software Macedonia
Comment 20 Simon Montagu :smontagu 2015-10-05 12:45:09 PDT
Fixed by using GENC data (bug 1203171)

Note You need to log in before you can comment on or make changes to this bug.