Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED DUPLICATE of bug 12513
19 years ago
19 years ago

People

(Reporter: Richard Zach, Assigned: vidur (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I don't know much about JavaScript; so my apologies for not being able to narrow
this down more.

Found this on a rudimentary shopping site (URL above). I will include a
testcase.

To reproduce:
1. Open the testcase html page
2. Click on the "Qty" pulldown and change the value

Actual result: nothing
Expected result: The "Price" should change as Qty * 13.75

Linux build 2000.01.02.09
(Reporter)

Comment 1

19 years ago
Created attachment 3970 [details]
Testcase JS
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
Thanks for the reduced test case. The problem is because
HTMLSelectElement.options.selectedIndex is not correctly implemented. DUP of bug
12513.

*** This bug has been marked as a duplicate of 12513 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Dup. Verified.
You need to log in before you can comment on or make changes to this bug.