Closed Bug 231028 Opened 19 years ago Closed 19 years ago

click on address bar autocomplete drop-down opens URI in new tab if enter was previously pressed on address bar

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 232617

People

(Reporter: smolin, Assigned: hewitt)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+

If you enter a url in the location bar and go there by hitting enter, forever
after Firebird will do the following:  Typing in the location bar which starts
autocomplete and selecting with mouse any item from the pull-down list will open
the new url in a new tab instead of in the current tab.

Reproducible: Always

Steps to Reproduce:
1.click on location bar, hit enter (loads currently selected url)
2.click on location bar, type a letter
3.select from the list using the mouse and let go of mouse button

Actual Results:  
The selected url opens in a new tab.  Before ever having hit enter in the
location bar selected urls open in the current tab.

Expected Results:  
Either the new url should always open in a new tab, or never.  I think never is
the correct behavior, though ideally this would be a configurable option.
See bug 68890. This is intended behaviour for SeaMonkey, and I'm guessing it's
not going to be changed on Firebird. But I'm not going to mark this invalid;
I'll wait for someone higher up on the food chain to decide.

Changing OS and Hardware to All, clarifying summary.
OS: Linux → All
Hardware: PC → All
Summary: autcomplete in location bar incorrectly opens new tab → click on address bar autocomplete drop-down should not open URI in current tab
You have misunderstood, this is NOT the same bug.  68890 is about whether or not
selecting an item from the autocomplete drop down should immediately open the
new url (by the way, I believe it should).  THIS bug is about where the new URL
is opened.  Sometimes it opens in a new tap, sometimes in the current tab.  The
behavior changes after you have once hit enter in the location bar for any
reason.  It can't be intended to switch behaviors like this.
Oh, I see what you're saying... Also, the behaviour sticks for the entire session.

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: click on address bar autocomplete drop-down should not open URI in current tab → click on address bar autocomplete drop-down opens URI in new tab if enter was previously pressed on address bar
Bug 232617 is newer, but has more information.

*** This bug has been marked as a duplicate of 232617 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.