option+home keyboard shortcut is inconsistent with Safari

RESOLVED WONTFIX

Status

()

P4
normal
RESOLVED WONTFIX
15 years ago
a year ago

People

(Reporter: allah42, Unassigned)

Tracking

({helpwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031202 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031202 Firebird/0.7+

Keyboard shortcuts to change tabs and go to the home page seem to be missing
from this build.
Including camino's shift-command-[ to shift one tab right and shift-command-[ to
shift one tab left would allow me to use firebird as my main browser.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
copy(command + c),past(command + v), Create New Tab(command + t),These shortcut
does not work, either.
But it is working in combination with the control key.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7a) Gecko/20040117
Firebird/0.8.0+

Comment 2

15 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040117
Firebird/0.8.0+

I'm noticing that very few keyboard shortcuts work and then only intermittantly.

For instance command-w for close tab, command-v for paste, and so on...

Comment 3

15 years ago
See Bug 220588 for commands to switch tabs. Do you have a proposal for a key
command to go home? 
As for the comments about cutting and pasting, everything mentioned WFM
(Reporter)

Comment 4

15 years ago
I personally like the home shortcut to match the finder's home shortcut
(command-shift-h).

Comment 5

15 years ago
fyi, right now home is option-home, related to windows shortcut.
control-pgup and control-pgdn for switching tabs, also related to windows.

if anything, we should emulate safari.  shift-command-left and
shift-command-right for switching tabs, and shift-command-h for home.

tabs shortcuts is bug 220588.  copy, paste, new tab, close tab all wfm. 
changing summary likewise.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Keyboard shortcuts missing → add home keyboard shortcut
alas, command+shift+H currently opens the History sidebar in mac firefox. :-\
command+shift+H is also used in camino to go to the Home page. should we change
the shortcut for History sidebar (but to what?)?
Assignee: firefox → aaronleventhal
Component: General → Keyboard Navigation
Flags: blocking-aviary1.0mac?
QA Contact: bugzilla

Comment 7

14 years ago
I'm currently marking Mac keyboard bugs helpwanted since I don't know who to
assign them to.
Keywords: helpwanted

Comment 8

14 years ago
Does History need a shortcut?  Which is more important:  Home or History?

Aaron--Are you working on Firefox?  I would think that this is just a XUL/XBL
change and not require much Mac-specific expertise (other than the expectations
/ behaviors of the platform).  What logical key combinations are available for
Home / History?

Personally I don't use History or Home enough to warrant a shortcut key.  I'm
fine with being consistent with Safari and Camino if that is what others want.
Summary: add home keyboard shortcut → add home keyboard shortcut (Command-Shift-H?)

Updated

14 years ago
Flags: blocking-aviary1.0mac?
*** Bug 279774 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Since my own bug has been marked a dup of this I'll post this here.  The most
correct "home" shortcut is command-home.  Current FF 1.0 has it mapped to
Alt-Home ( same as under windows and linux ) the problem is that all other
common shortcuts have the accelerator command and not alt.

It should be consistant.

Comment 11

14 years ago
Thumbs down to "Home", "Page Up" and "Page Down" -- they're not convenient keys
on PowerBook and iBook keyboards.

Coming from Safari, I want consistency with Safari, so I want Command-Shift-H
for Home, and I went to System Preferences and made that change for Firefox
(although after opening a new window Command-Shift-H still opens and closes the
History sidebar, until I click in the menubar, at which point Command-Shift-H
goes Home again like I want it to).

Note that in Safari 1.3 the default keyboard shortcuts for next and previous tab
changed from Command-Shift-Left- and Right-Arrow to Command-Shift-[ and -],
although I and some other people liked the old shortcuts better, and use System
Preferences to set them back:

http://www.macosxhints.com/article.php?story=20050419144454926

Comment 12

14 years ago
i don't think consistency with safari is what firefox should strive for.

Cmd-Home seems like the most appropriate way to get the home page to me, and i
have an iBook and have no trouble with the Home/pgUp/pgDown/End keys.  i think
this is what we should stick with, leave Cmd-Shift-H for history where the vast
majority of firefox users are used to it (i use it quite a bit, actually).  in
attempting to assign this bug, it seems it would be most useful to find someone
who has perhaps set up other key-bindings for mac that differ from windows.

(also, not sure how default-key-bindings for tab-navigation in safari have crept
into a firefox feature-request/bug for keyboard-shortcut for home ...)

Comment 13

13 years ago
(In reply to comment #12)
> i don't think consistency with safari is what firefox should strive for.
> 
> Cmd-Home seems like the most appropriate way to get the home page to me, and i
> have an iBook and have no trouble with the Home/pgUp/pgDown/End keys.  i think
> this is what we should stick with, leave Cmd-Shift-H for history where the vast
> majority of firefox users are used to it (i use it quite a bit, actually).  in
> attempting to assign this bug, it seems it would be most useful to find someone
> who has perhaps set up other key-bindings for mac that differ from windows.
> []

What is wrong with alt-HOME???  It works and [unlike many shortcuts] is actually CONSISTENT WITH MOZILLA.  Moz consistency seems tremendously more critical, IMO, than safari [or IE, etc.].  

Comment 14

13 years ago
"Alt" is usually called "Option" on the Macintosh, and much like the Shift and Control keys, the Option key alone is pretty much never used for executing commands on the Macintosh. (It can be used to execute commands when paired with the Command key. Alone or with the Shift key, it is used to generate different characters -- Option-G for example produces the copyright symbol, and Option-Shift-2 produces the Euro currency symbol.) Consistency with other Macintosh applications and conformance with Apple human interface guidelines is imperative for the continued cohesiveness of the Macintosh user experience.

Comment 15

13 years ago
(In reply to comment #14)
> "Alt" is usually called "Option" on the Macintosh, and much like the Shift and
> Control keys, the Option key alone is pretty much never used for executing
> commands on the Macintosh. (It can be used to execute commands when paired with
> the Command key. Alone or with the Shift key, it is used to generate different
> characters -- Option-G for example produces the copyright symbol, and
> Option-Shift-2 produces the Euro currency symbol.) Consistency with other
> Macintosh applications and conformance with Apple human interface guidelines is
> imperative for the continued cohesiveness of the Macintosh user experience.
> 


Fine, what is used in the moz suite?  Be consistent and I'd wager you'll get more moz users accepting FF, whatever the platform.  

Comment 16

13 years ago
(In reply to comment #15)
> Fine, what is used in the moz suite?  Be consistent and I'd wager you'll get
> more moz users accepting FF, whatever the platform.  

then probably the RightThing™ to do w.r.t. mac-UI guidelines would be Cmd-Home.

it is simply not common-UI usage on mac to use option (a.k.a alt to those outside the mac world) for key-bindings when Cmd for the same key is still available and wouldn't appropriately apply to some editing suite if otherwise properly bound.

if the moz suite is also wrong w.r.t. the use of option-Home rather than Cmd-Home, then it should be changed as well.

(... although, as stated in another previous comment, option-Home does workforme as a workaround for the time being ... so at least there's *some* keybinding.)
QA Contact: bugzilla → keyboard.navigation

Comment 17

11 years ago
I know this is a Firefox bug, but the problem affects SeaMonkey, too.  The real issue with this bug is on MacBooks.  The only way to get Home is to press the "fn <-", because there is no separate key for Home.  Unfortunately, while you're holding down fn, the alt/option key does nothing.  The end result is that there's no keyboard shortcut for Home on a MacBook.

Comment 18

10 years ago
just correct the bug in FF3 that does not allow for the custom keyboard settings.

i set my HOME to be command+G (for google) before with FF2
however, since firefox 3, i havent been able to do that, and it is very, VERY, annoying.

please fix this issue!
-james
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody

Comment 20

3 years ago
Hello, is this bug being verified by anyone? Is not can this be assigned to me? I am new to the community and trying to figure out how to help out by taking ownership of bugs
Flags: needinfo?(allah42)
I don't know the history of option+home and whether command+home would be a feasible option. Markus, any idea?
Flags: needinfo?(allah42) → needinfo?(mstange)
Priority: -- → P4
Hardware: PowerPC → All
Summary: add home keyboard shortcut (Command-Shift-H?) → option+home keyboard shortcut is inconsistent with Safari
I don't have an opinion on shortcut keys, and I don't even have a keyboard with a home key as far as I can tell.

Forwarding to UX for a decision.
Flags: needinfo?(mstange) → needinfo?(philipp)
I also can't find a (Mac) keyboard with a home button. Reading the history of that bug (which dates back OMG 13 years!) it is note really clear what is being asked for.
I'm setting this to wontfix for now -- if there's a strong desire to look further into this, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(philipp)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.