Search plugins bundled with Mozilla Installer are mainly for technical users.

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
15 years ago
8 years ago

People

(Reporter: BramleyAJ, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Bundled (or pre-installed) search plugins supplied with the Mozilla installer are
of more use to Mozilla developers rather than the average end-user. The Mycroft
Project keeps details of the most popular search plugins so bundling these would
be better.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
sorry
1. there's already a bug for this
2. half the search plugins i see aren't developer specific
3. your bug is useless;

a useful bug would suggest plugins to package

i personally collected 400 or so search plugins, while mycroft might not have
that many, i'm sure it has more than anyone here wants to sift through.

*** This bug has been marked as a duplicate of 213822 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Hi Timeless, My entry here seems to have irritated you but to answer your points...

True, the bug existed but is marked as resolved. Yet the only extra plugin added
for rv:1.6 was AskJeeves and that was incorrectly written (see Bug 231217).

If half of the Mozilla End Users are also Mozilla Developers then you are right
and the current mix of bundled plugins can't be faulted.

I don't think the bug is useless. Anything which improves the usefulness of the
product will help it succeed in the marketplace.

I didn't suggest any plugins to package because the suggestion was to find out
what the most popular ones from the people who know.

You need to check Mycoft's page where's there's close to 800 plugins (I know
because I've written a good number of them). As you say, nobody would want to
sift through them but there isn't any need to, the information is already
available.

I realise that a tremendous effort goes into producing Mozilla and it's often a
thankless task, so perhaps my suggestion seems trivial. However, it should be an easy thing to fix and I think the bug should be re-opened.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
I agree the pre-installed search-plugins should be focused more on what
seach-plugins users want and Mycroft's top ten is a good indicator of that.

The current top ten is:

   1. dictionary
   2. google
   3. yahoo
   4. imdb
   5. astalavista
   6. ebay
   7. amazon
   8. altavista
   9. alltheweb
  10. leo

Comment 4

15 years ago
Re: comment #3:

Most of these search engines are available for different languages/countries,
which make them very well suitable for localizations. Leo (German-English
dictionary) would rather be a "replacement" for dictionary.com in the german
localization.

But anyways, the plugins we are talking about are going to be added to the
default English locale, or am I wrong?

Comment 5

15 years ago
Yeah, I don't know what ships with other locales.  I think the default English
locale could include some of these popular search-plugins.

Comment 6

15 years ago
My suggested search plugins would be:

Amazon and Ebay (shopping)
Blogdex and Daypop (blogs)
Dictionary.com (reference)
IMDB (movies)
Google (search engine)
Mozilla, Mozillazine and Bugzilla (mozilla)
(Assignee)

Comment 7

15 years ago
Working on this for 1.7. See also bug 180866 and bug 234046
Assignee: search → asa
(Assignee)

Comment 8

15 years ago
I'm morphing this bug slightly. 

For 1.7 (if I don't run into any problems) I plan to remove LXR, Bugzilla, and
mozilla.org and to add yahoo and google groups. 


Comment 9

15 years ago
Just in case you were wondering what is popular today.  Last weeks Mycroft
Statistics:

Top 10 for Website
  1.  dictionary.com             .
  2.  google                     .
  3.  yahoo                      .
  4.  imdb                       .
  5.  ebay                       .
  6.  astalavista               +1
  7.  wikipedia                 -1
  8.  amazon                     .
  9.  altavista                  .
  N.  leo                        N 

Comment 10

11 years ago
is there a good reason to keep open a bug that has but 3 votes, no comments, no activity, and no dupes in 3 years?
OS: Windows 2000 → All
QA Contact: search
Hardware: PC → All
Product: Core → SeaMonkey

Comment 11

8 years ago
The currently shipping search plugins in SeaMonkey 2.1b2 are:
Creative Commons
Google
Wikipedia
Yahoo.

None of these are specifically for "technical users".

Closing as WORKSFORME.

For any changes to the current list please file a NEW bug with clear specifics as well as the rational for adding or removing search engines.
Status: NEW → RESOLVED
Last Resolved: 15 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.