Last Comment Bug 231395 - Wrong MIME type for XSLT transformations
: Wrong MIME type for XSLT transformations
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XSLT (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla7
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.w3.org/TR/xslt20/#media-ty...
Depends on: 655238
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 14:49 PST by Gustaf Liljegren
Modified: 2011-05-30 13:17 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Gustaf Liljegren 2004-01-18 14:49:27 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I noticed that Firebird supports on-the-fly XSLT transformations of XML
documents, using the xml-stylesheet PI. That's good, but you ought to change the
MIME type. There is no MIME type text/xsl! The right one is application/xslt+xml
according to RFC 3023:

  http://www.ietf.org/rfc/rfc3023.txt

So, if you have an XML document and wants to make it transform on-the-fly while
loading in Firebird, you should have this PI before the root element:

  <?xml-stylesheet type="application/xslt+xml" href="test.xsl"?>

This should not even work:

  <?xml-stylesheet type="text/xsl" href="test.xsl"?>

Reproducible: Always

Steps to Reproduce:
Comment 1 PikeUK 2004-01-22 05:31:03 PST
I don't know anything about XSL but Bug 85708 comment 1 (and those that follow)
seem to imply this is correct (or at least deliberate) behaviour.
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2004-01-23 17:21:44 PST
is application/xslt+xml a registered mimetype? If so then we might want to add
support for it.

We can't however drop support for text/xsl since that would make it impossible
to make xslt pages that work in both IE and mozilla. (text/xsl is the only value
IE supports).

Note that we also support text/xml and application/xml
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2004-01-23 17:24:35 PST
moving to right component.
Comment 4 Jonas Sicking (:sicking) No longer reading bugmail consistently 2004-01-23 17:27:22 PST
actually, that rfc explicitly says that the mimetype isn't registered yet so it
should be used. Marking invalid for now. Please reopen if such a mimetype gets
registered.
Comment 5 Alex Vincent [:WeirdAl] 2004-01-23 17:32:45 PST
Bug 61839 is filed for a similar issue on application/rdf+xml.  I did a quick search on 
ietf.org, and app/xslt+xml is not currently registered, so sicking is right.  However, if the 
content-type is registered, a similar procedure to the one in bug 61839 would be required for 
now. 
Comment 6 Frank Wein [:mcsmurf] 2005-03-15 09:29:44 PST
Did some bug get fixed to accept application/xslt+xml as a mime-type now? I
noticed http://www.mcsmurf.de/testcase5/exampleDoc.xml doesn't work in FF
1.0(.x), but in Mozilla CVS trunk it works. I didn't find any bug so which would
have fixed this issue, someone can point me to it?
Comment 7 Frank Wein [:mcsmurf] 2005-03-15 12:21:05 PST
Ok my issue seeems to be a real bug, i filed Bug 286267 for that.
Comment 8 Scott A. Colcord 2007-02-16 14:32:57 PST
The XSLT 2.0 spec notes at http://www.w3.org/TR/xslt20/#media-type-registration that the registration of this MIME type is being submitted to IANA.  Re-opening to put this back on the radar.
Comment 9 Peter Van der Beken [:peterv] 2007-02-17 03:19:49 PST
Submitted is not the same as registered. We are not supporting that MIME type until it has been accepted by IANA and we are not going to remove text/xsl.
Comment 10 Patrick Dark 2010-07-31 16:57:33 PDT
Bug 535827 - "Content-type : application/xslt+xml not viewed in browser as XML" appears to be a duplicate of this one.

@Comment 9: The IANA appears to have since accepted the registration since there's a link to the XSLT 2.0 spec on the IANA's Web site now at <http://www.iana.org/assignments/media-types/application/>. Unfortunately, the XSLT 2.0 spec hasn't been updated to reflect this and I don't see it in the errata either.

Testing of Firefox 3.6, Chrome 6 beta, Opera 10.5, Safari 5, IE8, and IE9 Platform Preview 3 seem to indicate that no one supports this yet either. (IE8/IE9PP3 still don't even support application/xml as far as I can tell.)
Comment 11 Julian Reschke 2011-05-06 05:52:05 PDT
(In reply to comment #10)
> Testing of Firefox 3.6, Chrome 6 beta, Opera 10.5, Safari 5, IE8, and IE9
> Platform Preview 3 seem to indicate that no one supports this yet either.
> (IE8/IE9PP3 still don't even support application/xml as far as I can tell.)

As far as I can tell, IE9 does the right thing.
Comment 12 j.j. 2011-05-28 10:33:51 PDT
fixed with bug 655238 ?
Comment 13 Julian Reschke 2011-05-29 08:44:22 PDT
Yes.
Comment 14 Julian Reschke 2011-05-30 12:49:55 PDT
(In reply to comment #13)
> Yes.

Test resource: http://greenbytes.de/tech/webdav/xslt-test-new.xml

Note You need to log in before you can comment on or make changes to this bug.