Browser crash when adding bookmark and bookmark toolbar folder has been deleted

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Sebastian Brocks, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040115 Firebird/0.8.0+

Whenever you delete the Bookmark Toolbar Folder from the Bookmarks, and 
subsequently try to add any Bookmark, Firebird crashes

Reproducible: Always

Steps to Reproduce:
1.Start Firebird
2.Delete Bookmark Toolbar Folder from Bookmarks
3.Click Bookmarks - Add Bookmark

Actual Results:  
Firebird crashes

Expected Results:  
Window to select where to add the bookmark pops up.

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows NT 5.0; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040120
Firebird/0.8.0+

Sebastian can you create a new profile for a test and repeat your steps there?
Also try the current nightly. 
(Reporter)

Comment 3

14 years ago
I just tried again with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040120 Firebird/0.7+, the branch nightly from January 20th, and a fresh
profile. I still get Firebird to crash, though it does not always happen after
deleting the Bookmark Toolbar Folder. A sure way to crash Firebird is to delete
all the folders in the bookmark menu and then try to add a new bookmark.
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040115 Firebird/0.8.0+

Seams to be a Win XP bug only. When I delete all folders inside the Bookmarks
Manager, close it and press "Bookmarks | Add Bookmarks" Firebird tries to load
something and 4 seconds later it crashes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040120 Firebird/0.8.0+

Crash only occurs when no Bookmarks Toolbar inside the Bookmarks Manager is
available or was deleted. Depends on following bug 231824.
Depends on: 231824
OS: Windows XP → All
Because of fix (bug 231824) it's not possible to delete the "Bookmarks Toolbar
Folder". Problem should be solved.

WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040124
Firebird/0.8.0+ (scragz)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.