Bookmarks Toolbar can be deleted

VERIFIED FIXED

Status

()

--
minor
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: whimboo, Assigned: p_ch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Tested with a new profile and build Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+

When I delete the bookmarks folder within the bookmarks manager the toolbar
isn't updated. Instead of an empty toolbar I always see all deleted entries.
I've seen this in Linux and WinXP, so -->All/All.  Also not really a big 
problem, so changing to Minor.

This is probably a duplicate as this behavior is so old, but I haven't seen a 
bug for this anywhere.  What exactly should happen for this, anyways?  Should 
the toolbar for it just be made empty, or should it disappear as well?
Severity: normal → minor
OS: Windows 2000 → All
Hardware: PC → All
It seams to appear in a fresh profile only. Within my current one I can't delete
this "Bookmarks Toolbar Folder". So something is wrong with new profiles. Jeff
how old is yours?

Because of your behavior question: I think it's the best when the delete button
is disabled and this folder can't be deleted. It's the same like in Seamonkey.
If you agree we have to change the summary into a better fitting text.
(Assignee)

Comment 3

15 years ago
uh... you're not supposed to be able to delete the bookmarks toolbar folder...
patch in a sec.
(Assignee)

Comment 4

15 years ago
fixed on branch and trunk.
Thanks !!!
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 5

15 years ago
Dont suppose anyone wants to explain the reasoning behind this EXTREMELY poor
usability issue with forcing people to have this silly folder in their bookmarks
menu which they may never ever use and cannot delete (could delete it before but
it just comes back anyway)?  personally i know for a fact i will never, ever,
ever be using it, yet im stuck with this **** because you cannot remove
it....WHY?  there were loads of complains about it when this thing first
appeared and im not surprised.

I mean this is EXACTLY the sort of thing I expect from microsoft, NOT mozilla or
firebird.
From comment 5:

"I mean this is EXACTLY the sort of thing I expect from microsoft, NOT mozilla or
firebird."

The Links folder, anyone?  (It does happen to be disableable, tho, with an
obscure registry hack.)

Also, in response to comment 2, I've never reused a profile in all the time I've
run Mozilla Firebird.  I always figured it was the easiest way to avoid
conflicts with certainty.
(Assignee)

Comment 7

15 years ago
ewok: there's no need to be rude to make your point.
You can hide the bookmarks toolbar folder in the browser toolbar via the
customize dialog. You can also rename the bookmarks toolbar folder and use it as
any regular folder.
Changing Summary to better fit the problem.
Summary: Bookmarks Toolbar not updated when deleting folder inside bookmarks manager → Bookmarks Toolbar can be deleted
Blocks: 231604
WFM with build Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040124 Firebird/0.8.0+ (scragz)

-> Verified
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
Reopening. You can still delete the Bookmarks Toolbar Folder using control-x.
See bug 234089. I hope this is the correct way to handle this. Should I have
opened a new bug instead?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 11

15 years ago
*** Bug 234089 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

15 years ago
Wayne: please open a new bug for that special case.

Comment 13

15 years ago
Apologies. I'll reclose this bug, un-dupe bug 234089 and restate its summary to
reflect the problem.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.