bringing page into composer w/o sidebar brings it in w/ sidebar

VERIFIED INVALID

Status

()

Core
Editor
P3
normal
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using 12/5 build of mozilla 2000010508

1) launch mozilla
2) jump to site http://www.abcnews.com
3) close sidebar by clicking on the bar
4) File | Edit page

notice after the page comes into the composer, you still see the sidebar
in the open state...shouldn't it be closed? we should remember the state
of the sidebar in the composer.

all platforms.

Updated

19 years ago
Assignee: beppe → cmanske
Target Milestone: M15

Comment 1

19 years ago
Reassigning bug to cmanske@netscape.com. Cc'ing brade@netscape.com.
(Assignee)

Comment 2

19 years ago
*** Bug 22787 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
Ignore last "duplicate bug" comment - it was a mistake.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

19 years ago
After playing with this awhile, I don't think there's a bug.
We currently store the sidebar visible/hidden and collapse/expanded states
separately for Browser and Composer windows, and I think that's the behavior
most users will want. Many will probably want it open in the Browser, but
closed in Composer, for example.
Thus the state of the sidebar when "File | Edit page" is used from the
Browser should not influence the state when that page is opened in Composer.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
If many will want the state closed in Composer, should I file a separate
bug on this issue? Because currently sidebar show up in open state when
you get into the editor.

verified in 12/6 build.
(Assignee)

Comment 6

19 years ago
There may be some problems with the "persistance" mechanism for storing the
states, as I described above. You should be able to hide/show via the view
menu (that seems to be working OK.) I haven't played much with the collapse/
expand (by clicking on the border), so test that and file a bug if necessary.
You need to log in before you can comment on or make changes to this bug.