Mozilla 1.6 and 1.6b will not install CRL's which do not have a value for "Next Update:" set

RESOLVED DUPLICATE of bug 261496

Status

NSS
Libraries
RESOLVED DUPLICATE of bug 261496
15 years ago
14 years ago

People

(Reporter: Michael Guenzel, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.79 [en]C-CCK-MCD monwin/025  (Windows NT 5.0; U)
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6b) Gecko/20031210

Mozilla 1.6 and 1.6b will not install CRL's which do not have a value for "Next 
Update:" set. Our current CRL (self signed CA) details are:
--------------------------
Monash University CA

URL:https://leek.its.monash.edu.au:1025/getCRL?op=importCRL&issuepoint=MasterCRL
Last Update:Thu Jan 15, 2004
Next Update: 
Signed by:

     Monash University CA
     Monash University
     AU
----------------------------
The CRL can be imported via the web link for Netscape 4.7x and Mozillia 1.5 
browsers but attempts to import the CRL with Mozilla 1.6 (Windows XP) and 
Mozilla 1.6b (Suse Linux Suse 9.0) result in following error message:

The Browser cannot import the Certificate Revocation List (CRL).
New CRL has an invalid format
Please ask your system administrator for assistance.
--------------------------------

NOTE: These blank fields are intentally left blank.

Problem demonstrated on:
Windows XP using Mozilla 1.6
and
Suse 9.0 Linux using Mozilla 1.6b

Reproducible: Always

Steps to Reproduce:
1. Goto 
https://leek.its.monash.edu.au:1025/getCRL?op=importCRL&issuepoint=MasterCRL
2.
3.

Actual Results:  
The Browser cannot import the Certificate Revocation List (CRL).
New CRL has an invalid format
Please ask your system administrator for assistance.

Expected Results:  
Sucessful install message

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 261496 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: Security: CAPS → Libraries
Product: Browser → NSS
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.