Closed Bug 232003 Opened 18 years ago Closed 17 years ago

ActiveState Perl does not work with GNU make 3.80 ("No rule to make target `Makefile.in'" in xpcom\MoreFiles)

Categories

(SeaMonkey :: Build Config, defect, P1)

x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.8beta1

People

(Reporter: ali, Assigned: benjamin)

References

Details

Attachments

(1 file, 1 obsolete file)

ActiveState Perl 5.8.0 does not work with Cygwin GNU make 3.80 when building
Mozilla, because there has (apparently) been a change in make 3.80 where make
handles paths more strictly than make 3.79.

When I build with the combination of ActiveState Perl 5.8.0 and Cygwin GNU make
3.80 I get the following error (it works fine with Cygwin GNU make 3.79):

/cygdrive/d/cvs-1.11.5/mozilla/build/cygwin-wrapper /cygdrive/d/perl/bin/perl /c
ygdrive/d/cvs-1.11.5/mozilla/build/autoconf/make-makefile -t /cygdrive/d/cvs-1.1
1.5/mozilla -d .. MoreFiles/Makefile
creating xpcom/MoreFiles/Makefile
make[4]: Entering directory `/cygdrive/d/cvs-1.11.5/nightly/xpcom/MoreFiles'
make[4]: *** No rule to make target `Makefile.in', needed by `Makefile'.  Stop.
I've upgraded my ActiveState Perl install to version 5.8.2.808 but I'm still
getting the same error.
Summary: ActiveState Perl 5.8.0 does not work with GNU make 3.80 → ActiveState Perl 5.8.2.808 does not work with GNU make 3.80
I should also note that the combination of Cygwin Perl 5.8.2 and Cygin GNU make
3.80 works fine.
Mine. I need to semi-unwrap calls to make-makefile for the AS perl case; I'm
trying to figure out an easy way to do that.
Assignee: nobody → bsmedberg
Priority: -- → P1
updating summary, maybe the next person will have an easier time discovering the
problem :-)
Summary: ActiveState Perl 5.8.2.808 does not work with GNU make 3.80 → ActiveState Perl 5.8.2.808 does not work with GNU make 3.80 ("No rule to make target `Makefile.in'")
Interestingly, I'm using ActiveState Perl 5.8.3 [809] (and 5.8.0 before) and GNU
make 3.80 to build Firefox *fine*. I guess I should check what I've hacked with
the build system...
I still get the same error with AS Perl 5.8.3.809. Updating summary.
Summary: ActiveState Perl 5.8.2.808 does not work with GNU make 3.80 ("No rule to make target `Makefile.in'") → ActiveState Perl 5.8.3.809 does not work with GNU make 3.80 ("No rule to make target `Makefile.in'")
Product: Browser → Seamonkey
I only see this problem when i set MOZ_OBJDIR

If i don't then I can compile ok.

-dave
I can reproduce this using ActiveState Perl 5.6.1 build 638 as well.
Summary: ActiveState Perl 5.8.3.809 does not work with GNU make 3.80 ("No rule to make target `Makefile.in'") → ActiveState Perl does not work with GNU make 3.80 ("No rule to make target `Makefile.in'")
Summary: ActiveState Perl does not work with GNU make 3.80 ("No rule to make target `Makefile.in'") → ActiveState Perl does not work with GNU make 3.80 ("No rule to make target `Makefile.in'" in xpcom\MoreFiles)
Attachment #172626 - Flags: review?(cls)
Attachment #172626 - Flags: review?(cls) → review+
This is what was actually checked in, I had to add quotes around the "mkdir"
call in make-makefile so that browser/app/profile/extensions/{stupidGUID} would
build properly.
Attachment #172626 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta
*** Bug 273366 has been marked as a duplicate of this bug. ***
OK, I'm actually having problems still.  The EXE is created OK, but when I try
to run it, I get the following error:
--------------------
Error
126: Could not load C:\WINDOWS\TEMP\ns_temp\xpcom.ns\bin\xpistub.dll
--------------------
Can anybody else reproduce?
OK, I'm getting the same error with Cygwin Perl, so it must be another issue
unrelated to ActivePerl. I'll search to see if the bug has been filed and file a
new one if it hasn't.
You need to log in before you can comment on or make changes to this bug.