Message rules with multiple actions only execute the move and ignore other actions

VERIFIED DUPLICATE of bug 254589

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 254589
14 years ago
10 years ago

People

(Reporter: Ben, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5a (20040120)

I have various message rules with more than one action, typically they:

- Move the message to another folder
- Label the message and/or mark the message as read

However, in all these cases, the message is only moved to the other folder and
the other action (labeling or marking) is never executed.

Reproducible: Always
Steps to Reproduce:




There is another bug about the label being lost when moving a message: bug
189016 . It might be related.
What is you mail type - POP3 or IMAP?
What filter log says? 
If log says marked but mail is not marked, this is not filter problem, is
marking problem such as bug 189016.
If log does not say marked, it is filtering problem, usualy another rule was
already applied.
Try clear log first, then "Run Filter on Folder".

Comment 2

14 years ago
No response from reporter, duping to a later but confirmed bug that matches the 
summary.
Reporter (Ben) -- if this duplication is in error, feel free to reopen the bug 
but explain why; in particular, respond to comment 1.

*** This bug has been marked as a duplicate of 254589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.