Page Info should display EXIF information for images

RESOLVED WONTFIX

Status

()

Firefox
Page Info Window
--
enhancement
RESOLVED WONTFIX
14 years ago
6 years ago

People

(Reporter: Jürgen Weber, Unassigned)

Tracking

(Blocks: 1 bug, {student-project})

Trunk
student-project
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workaround in comment #6, URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Right-Click Image -> Properties should display EXIF information if there is any
in a JPG image
(http://www.dpreview.com/learn/?/Glossary/Camera_System/EXIF_01.htm). 
In an age of ubiquitous digital camera made images this would be a nice feature.
Or it could be displayed in a hover over the image.
Maybe libexif (http://sourceforge.net/projects/libexif/) could be used for this,
license allowing.
Mozilla would be the first browser to support displaying EXIF information, AFAIK.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
-> Browser/Imagelib

Confirming since this is not a dupe and quite similar to bug 106068, which is
about another JPEG metadata-standard and is also marked NEW.
Assignee: general → jdunn
Status: UNCONFIRMED → NEW
Component: Browser-General → ImageLib
Depends on: 167303
Ever confirmed: true

Comment 2

14 years ago
perhaps the image properties window should contain a button named "EXIF Data" or
something like that, clicking on it would show a window with the EXIT data.
Since there's quite a lot of it, there's a risk of cloging up the image
properties window.

Comment 3

14 years ago
*** Bug 257919 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Not sure that the UI for this really belongs in the core product. Its possible
to store _lots_ of information in the EXIF metadata section (see link to the
standard), and we'd never want to present all this.

Not sure I dare say this after recent controversy, but perhaps this bit of UI
would be better proved as an extension?

Comment 5

14 years ago
IMHO an extension for that would be a good idea, especially if we look at EXIF
and IPTC data.

I thought about trying to developing something for my personal use but got stuck
very soon: how do I get access to the image data in the browser cache??
Just FYI, I wrote an extension to display EXIF data:
http://ted.mielczarek.org/code/mozilla/fxif/

Comment 7

13 years ago
I think this should be "wontfix"
since this is now available as an extension:

http://ted.mielczarek.org/code/mozilla/fxif/

Comment 8

13 years ago
In line with that thinking, tabs should have been left out since we already had
MultiZilla...

With the growing use of digital cameras, this functionality should be in the
core browser. It's not something that should be used only by those in the know.
 Moreover, can Ted guarantee that he will update this (very nice) extension
indefinitely, with every new version of the browser? Can we count on u.m.o to
have a tested version available immediately after every new release?

Prog.
Whiteboard: Workaround in comment #6

Updated

13 years ago
Blocks: 24126

Comment 9

13 years ago
It's already been established that an extension existing is NEVER a reason to
wontfix a bug. Other developers have stated so clearly numerous times before.
Extensions are in many ways considered a 'testing ground' for ideas that are
often integrated into the browser core. Examples include dragging tabs and
bookmark backup, to name a few.

This is something that people who aren't interested in it won't notice, and
doesn't get in the way, but people who are interested in it will really, really
like. It's not a vital thing to add, but is a worthwhile enhancement that will
increase the usability of Firefox for a small but important number of people,
and definitely a selling point/thing that will get people to recommend Firefox
to others.

Ted, is there any chance of porting your extension into a patch for Firefox?

Comment 10

12 years ago
*** Bug 318080 has been marked as a duplicate of this bug. ***
Assignee: jdunn → nobody
QA Contact: general → imagelib

Updated

10 years ago
Alias: exif

Comment 11

10 years ago
Any chances to have this in the future? Like Ian asked (3 years ago): is there any chance of porting this extension into a patch for Firefox?
Ideally this would be integrated right into imagelib, not a js-only extension. (Having it as part of imagelib would make it possible to do other things with EXIF data.)

Also, along with bug 298619, this would be a good student project.
Keywords: student-project
Assignee: nobody → shirishreddy89
Status: NEW → ASSIGNED
You can find the FxIF code here:
http://code.google.com/p/fxif/source/browse/#svn/trunk/content
(it's written entirely in JavaScript)
The properties dialog is gone now with bug 513147, so this bug no longer makes sense. Resolving INVALID.

I can see an argument for exposing EXIF data within imagelib, but that should be a separate bug. If anybody's interested, please file a new bug with an explanation of what data you need and what you want to do with it, and link to it from this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(In reply to comment #14)
This data would still show in Page Info -- not invalid.
looks like we already have a bug for exposing this data on the imagelib side:
bug 167303

Anything else is a frontend bug - please file it in the appropriate place.
Except that would lose all the votes for this bug. Can't this one just be changed from Properties to Page Info? (Besides, per the discussion in bug 513147, it looks like Properties may stick around as a pointer to Page Info anyway.)
fair enough. re-opening, re-titling, and re-assigning to firefox for frontend people to look at.
Assignee: shirishreddy89 → nobody
Status: RESOLVED → REOPENED
Component: ImageLib → General
Product: Core → Firefox
QA Contact: imagelib → general
Resolution: INVALID → ---
Summary: Image properties should display EXIF information → Page Info should display EXIF information for images
Component: General → Page Info
QA Contact: general → page.info
In response to comment 7 and 13, it should be noted that FxIF adds an extra context menu item, instead of integrating into Page Info. It also shows even if there is no EXIF info.
I don't think we want to add this feature by default - fxif (or some improved variant) seems like it can serve this purpose adequately for those who desire it!
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago6 years ago
Resolution: --- → WONTFIX
I think this would be a good and helpful idea: first, the community that is helped most by "View Image Info" are photographers, web developers, and anyone trying to access basic image properties.  At the moment FxIF duplicates a lot of the functionality of View Image Info and is somewhat buggy in when it appears and it adds an extra context menu item for its users.  If we integrate this with View Image Info, we fix two problems, first the UX issues with FxIF and then we can start improving how Page Info gets image data and fix this, Bug 717784, Bug 715075, and several others that are caused by Page Info's dependance on Component.classes it probably shouldn't be using.

Using this as an opportunity to greatly improve and update (if not totally rework) parts of Page Info's backend will reduce future bugs and resolve otherwise unresolvable current bugs.  Now if worst came to worst, we could make these changes independent of integration of FxIF, but as we would be copying so much of it's code and someone would have to then update it to be an extension of Page Info (which can be its own challenge), we probably should go all the way towards implementing this as it wouldn't add any new UI for general users, wouldn't slow down Page Info in any appreciable way, and would only help the users who are already using Page Info and "View Image Info."
Alias: exif
Duplicate of this bug: 747432
You need to log in before you can comment on or make changes to this bug.