Closed Bug 233164 Opened 17 years ago Closed 17 years ago

Mouse left click is lost when the viewport is panned

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: isaachh, Assigned: dbaron)

References

Details

Attachments

(1 file)

Regression between 040131 and 040205 (probably from fix of bug 20022).

Reproducing Steps:
1. Open the testcase
2. Click the link

Actual Result:
Left click is lost. No page transition.

This only happens when clicking a link pans the viewport to fit the focus
rectangle surrounding A element.

Middle and right click works fine.
Attached file testcase
Left click the link
Depends on: 20022
It's worth noting that nsEventStateManager::CheckForAndDispatchClick isn't even
called.
The pres shell isn't even getting the mouse up event.
Blocks: 20022
No longer depends on: 20022
... nor is the view manager, and the problem seems to be that a drag is being
initiated.
I just relanded bug 20022 with this bug fixed.
Assignee: events → dbaron
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Bug 288945 might have been caused by the fix for this bug (it was about the
time, when I first saw that bug). I have no idea what the fix for this bug is,
but David Baron refers to it in bug 50511 comment 64. There he mentions that the
right fix for this bug would be not to scroll when focusing due to a click.
Not scrolling when click-focusing would fix bug 105894 (Clicking a partially
off-screen link shouldn't scroll the page) and bug 288945 (clicking links in
client-side image maps scrolls the page).
Sorry for the spam. Just ignore my last comment, please. Bug 288945 might as
well have been caused by anything else, but not scrolling when click-focusing
sounds like a good idea.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.