Ability to assoicate any messages as a thread

RESOLVED DUPLICATE of bug 36024

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 36024
15 years ago
10 years ago

People

(Reporter: Andrew Serff, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

It would be nice to be able to associate any messages as a thread so they are
grouped together even if they don't have the same subject title.  Something like
selecting the 2+ messages and then right clicking on them and say something like
"associate messages" or "group as thread".  I often have message that come
across that are related but with different subjects so they don't get linked as
a thread. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

15 years ago
Blocks: 236849

Comment 1

14 years ago
Duplicate of bug 36024.

Comment 2

13 years ago
  The traditional argument is that this is something that it is incumbent upon
MUAs and users to make happen; context must be defined by the message author and
tagged appropriately by his or her software.  I can certainly understand that.

  That being said, I've always wished for something like this too.  Maybe
something like an X-inferred-in-reply-to: header could be inserted, and the
thread code could be configured to run twice or something, once for the regular
In-reply-to: and once for the the inferred (i.e. specified by reader, not
author), with inferred in-reply-to being preferred over the regular in-reply-to.

Should this request be seen as meritorious and worked on, they could make a
"nothing" value an option for the inferred in-reply-to, so that erroneously
threaded messages could be detached from their bogus parent.

Has anyone seen or even used a mail or news client where threading is changeable
by the reader?  The more I think about it, the more I wonder why no MUA has
caved in to this recurring request over the years.

Comment 3

13 years ago
(In reply to comment #2)

Actually, "In-Reply-To:" and "References:" headers are already used by some
services; in fact, I've seen messages with different subjects threaded together
because of this.

There's actually a pretty big problem trying to figure all of this out because
some people change the subject but the message still belongs in the thread while
others reply to the thread but change subject and topic (thinking that it should
come up as a new message) but TB still groups those messages together in the thread.
A possible algorithm to work around this would be something like this:

1. Does message have References:/In-Reply-To: header? If so, go to 2; otherwise,
go to 4.
2. Does the subject match the earlier message? If so, go to 3. If not, compare
contents of the messages: if the new message has some significant part (i.e. a
quote) from the original, go to 3. Otherwise, go to 4.
3. New message is a reply to an older message. Thread them together.
4. New message is a new topic. Do not thread it to the old messages.

This is of course very simplistic and abstract. The devil is usually in the
details :)

Comment 4

13 years ago
(In reply to comment #2)
> Has anyone seen or even used a mail or news client where threading is
> changeable by the reader?

I believe Mutt supports this

Comment 5

13 years ago
Agreed on dupe.

*** This bug has been marked as a duplicate of 36024 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.