Download manager not closeable with escape key

RESOLVED DUPLICATE of bug 228699

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 228699
15 years ago
10 years ago

People

(Reporter: Tibor Csögör, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

The download manager window is not cloesable by pressing the escape key (ESC).
As other dialogs such as Page Info have this behaviour, this should be the case
for the download manager, too.

Reproducible: Always
Steps to Reproduce:
1. press CTRL+E
2. press ESC


Actual Results:  
nothin'

Expected Results:  
The download manager window should be closed.
(Reporter)

Comment 1

15 years ago
Created attachment 140964 [details] [diff] [review]
adds keycode for ESC to close downloads window

Updated

15 years ago
Assignee: firefox → bugs
Status: UNCONFIRMED → NEW
Component: General → Downloading
Ever confirmed: true

Comment 2

14 years ago
taking qa
QA Contact: aebrahim

Updated

14 years ago
Flags: blocking1.0?

Updated

14 years ago
Flags: blocking1.0? → blocking1.0-

Comment 3

14 years ago
*** Bug 249553 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Calling window.close() is wrong. Look a few lines up, at key id="key_close"
oncommand="closeWindow(true);".
http://lxr.mozilla.org/aviarybranch/source/toolkit/content/globalOverlay.js#1

I'll add ESC to my patch in bug 228699.

*** This bug has been marked as a duplicate of 228699 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.