Closed Bug 233702 Opened 16 years ago Closed 15 years ago

Partial hang when opening page with flash in a new tab

Categories

(Firefox :: General, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 106397

People

(Reporter: phoenix, Assigned: bugzilla)

References

()

Details

(Keywords: dataloss, hang, shockwave)

User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

On a forum, I opened a link to http://www.shadowbane.com/ in a new tab and
firefox would hang requiring a force quit. I browsed directly to the url and the
site loaded normally and was viewable. Another test of opening the page in a tab
and the browser hung again. Stragely, the animation on the webpage will play if
I hold down the mouse button - so something is still running. However, the
ability to close the tab or click links is totally broken after following the
recipe.

Reproducible: Always
Steps to Reproduce:
1. Create a webpage with a link to http://www.shadowbane.com
2. Open the newly created page in firefix
3. Context-click on the link and open it in a new tab

Actual Results:  
The browser would no longer respond to mouse clicks, attempts to change tabs,
etc. Any information entered on any other tab is lost forever.

Expected Results:  
It should have viewed the page normally, much like when browsing directly to the
site.
well, it's not all pages with flash, that's for sure.

confirmed, though, had to force quit to get out.  lame.  Mozilla/5.0 (Macintosh;
U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040308 Firefox/0.8.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Here's another page that appears to have a similar problem:
http://www.canadianmuseumforhumanrights.com/index.cfm?pageID=2

It brings mozilla 1.7rc1 and firefox 0.8 to their respective knees; recent
nightly builds for camino also suffer, but perhaps not quite as much.
Maybe has something to do with bug 106397.

http://www.fox.com/24/ is a great website to test this bug, when it doesnt
complete freezes my firefox on phanter, you can notice performance gain on the
animation if you keep the mouse button pressed.
IMHO I think this bug is a 1.0 blocker, I got problems and even dataloss almost
every week caused by 
flash websites that hang my browser.

Last time, I was browsing http://www.eyetoy.com, and when the browser froze i
simply lost one email that i was writing on another tab, cause in an attempt to
close the eyetoy flash site that was hanging my firefox I clicked on the "x"
circle of the corner once, nothing happens, then i clicked again, and again and
again... until it started closing all of my tabs, including the important ones.
Keywords: dataloss, hang, shockwave
Get the same behaviour when opening (window.open) a page that contains a java 
applet (Firefox 0.8/0.9.1 on Win NT).
When trying to close the new window the opener freezes. Pure HTML pages open 
and close correctly.
Strange enough, this does not always happen if I open the new page with the 
applet, then click the opener and go back to the new window.
This must, however, be done manually. Programmatically focussing back to the 
opener and then return to the new window does not help.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040803
Firefox/0.9.3
Mac OS X 10.3.5
iBook 500MHZ G3, 640MB RAM

I've been experiencing this every day for about a month now using the url
http://relevantmagazine.com . Sometimes if I browse the site quickly it won't
crash. Otherwise I have to do a force quit and use Safari. Once or twice I have
been able to hold down the mouse key and keep it from locking up, but that is
not always the case.

Safari does not have any problems with this page, in fact the page is very quick
to browse.
this seems like a dupe of bug 244987.

i've experienced this since may, also with mozilla & camino :(

safari performs well though, so use that if you need to surf a flash site...
http://www.macosrumors.com/ pages with smileys banners cause me lot of problems.
I have to Force Quit Mozilla quite often after loading pages.

*** This bug has been marked as a duplicate of 106397 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.