[PP] Mac - Can't move windows

VERIFIED FIXED in M18

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: cpratt, Assigned: danm.moz)

Tracking

({platform-parity})

Trunk
PowerPC
Mac System 8.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Build ID: 2000010713
Platform: Mac OS 9 (OK on other platforms)

To reproduce:
- Launch Mozilla
- Try to move the application window around

Result: At some point (2-3 moves), you can no longer move the window as you
desire. When you move it, and release the mouse button after the move, the
window snaps back to some other previous position (not necessarily where it was
immediately before the attempted move).

Expected result: You should be able to move the window as you wish.
Assigning Mac-savvy QA Contact.
QA Contact: nobody → claudius
Keywords: pp
Quick note: There may in fact be problems in this area on other platforms. A 
personal E-mail was sent to me in which a Net contributor described problems 
with moving windows on a dual-monitor Windows 98 setup. elig et al: you may 
wish to investigate this. thanks!
D'oh! Not Win98, but Mac OS 9, sorry. That teaches me to go through proper
procedure. I'm the one emailed Christopher Pratt; what I sent him follows:
     I have two monitors, the secondary one to the left of the main one. All
windows snap back to the left edge of the main display (the right one), however
I can move them anywhere _to_the_left_ (including straddling -- half  a window
on the left display, the other half on the right ).
     So in short, no distance further right but anywhere left.
sfraser suggested Dan would be the right dude for this.
Assignee: nobody → danm
*** Bug 25344 has been marked as a duplicate of this bug. ***
Blocks: 24525
I'm finding it really really difficult to understand exactly how the window is 
behaving from the description; I gather that the window position isn't right on 
multiple monitor systems. This is expected and well-known, though we didn't seem 
to already have a bug filed. Well now we do. I'm adjusting the summary line as if 
I understood the problem. (I'm also clearing the PP flag: we don't handle 
multiple monitors well on any platform).

Note this is really the same as bug 24525, and as (Windows) bug 19347.
Status: NEW → ASSIGNED
Summary: [PP] Mac - can't move browser window → window (mis)placement on multiple monitor systems
Target Milestone: M18
Actually, this bug shouldn't have anything to do with multiple monitor systems, 
at least not as originally filed. This bug should be Mac only (this problem 
hasn't been seen on Windows 98). The bug is simple, and was reproduced on the 
beige G3 in the smoke testers' area. To reproduce:

- Launch Mozilla
- Try to move the window.

Result: You can't after just a few tries. When you try to move the window, it 
snaps to an unpredictable location.

Disclaimer: I haven't tried this lately, and I no longer have access to a Mac 
to try it again. Perhaps elig can help out here?
Summary: window (mis)placement on multiple monitor systems → [PP] Mac - Can't move windows
Ah. There was a Mac-specific window positioning problem at about the time this 
bug was originally filed. That was fixed about a week ago: see bug 24326. I know 
of no remaining window positioning problems except the ancient and venerable 
multiple-monitor one. Eli? Claudius? Are we done with this one then?
comment
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I'd say this is fixed. When I say that I'm referring only to te specific issue for which this bug was created. I can't comment yet on 
the multiple monitor situation - but I will look into it. Marking VERIFIED with 2000013111 build (mac).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.