stafflist page is antiquated

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: justdave, Assigned: fantasai)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 4 obsolete attachments)

Bart seems to do a lot of Marketing stuff for Mozilla, and has an @mozilla.org
email address.  Seems he would be at least listed in Associate Staff...

Comment 1

14 years ago
Bart isn't the only one - also ben, mscott, jst, dbaron, possibly others... I
pointed this out in
http://groups.google.com/groups?threadm=bogc48%241d7er8%242%40ID-106624.news.uni-berlin.de

see also bug 226321 - the staff page isn't actually linked from anywhere anyway.

Comment 2

14 years ago
Updating fields, adding some of those not mentioned in page to CC list.
Summary: Bart Decrem is not listed on the staff page → Bart Decrem and others are not listed on the staff page
reassigning endico's bugs to default owner
Assignee: endico → mozilla.webmaster

Comment 4

13 years ago
*** Bug 259735 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
I just structured the source code and made it validate, if any updates are done,
please keep it that way.

Updated

13 years ago
Summary: Bart Decrem and others are not listed on the staff page → stafflist page is antiquated

Comment 6

13 years ago
more changes which aren't yet reflected -
http://weblogs.mozillazine.org/mitchell/archives/2004/11/people_on_the_m_1.html

If this page is going to be linked to (bug 226321), then it should be updated at
the same time...
Blocks: 226321
(Assignee)

Updated

13 years ago
Assignee: mozilla.webmaster → fantasai.bugs
(In reply to comment #1)
> see also bug 226321 - the staff page isn't actually linked from anywhere anyway.

This isn't true.  It's linked to from several places on
http://www.mozilla.org/about/roles.html which is linked to from
http://www.mozilla.org/hacking/ which is linked to from the sidebar on almost
all of the pages.

Comment 8

13 years ago
There's also some dead links (like the people.netscape.com ones for Dawn and
Brendan).
(Assignee)

Comment 9

13 years ago
I think this page is as up-to-date as it can get at this point.

Comment 10

13 years ago
is peterb still on staff? oeone has morphed...
(Assignee)

Comment 11

13 years ago
Ok, I was told the staff@ list hasn't really changed, but chase says he's been
added...

Whatever the state of staff@ is as a whole, and whether or not it includes
everyone who ought to be included, I think that keeping the staff list in sync
with the mailing list subscribers should be pretty uncontroversial. (Of course
Mitchell can correct me if I'm wrong about that.) But I can't keep it up to date
if I don't know who's missing. If someone from staff would step up and give me
at least the list of current subscribers, only then can I take care of updating
the list.
stafflist.html is about who has authority at mozilla.org, not about who is
subscribed to a mailing list, so syncing it with a subscription list probably is
a bit controversial.  A bunch of Mozilla Foundation employees are on
staff@mozilla.org but it's not clear whether they should be in stafflist.html.

Comment 13

13 years ago
dbaron has summarized briefly what it took me a lot longer to describe: 
http://weblogs.mozillazine.org/mitchell/archives/2005/02/email_addresses_1.html

So the mailing list is not a good proxy.

The staff page is antiquated because of the reasons desribed in that blog post.
 Perhaps the best thing to do is to note that the page is not up to date and
point to that post?

mitchell

Comment 14

13 years ago
"Perhaps the best thing to do is to note that the page is not up to date and
point to that post?"

I don't think that would look good (much like the note on the roadmap, which
looks lame).  If it's good enough (and it probably is), then leave it as is.  If
it's out of date enough that people can't rely on it, just nuke the page. 
Saying (or appearing to say) that you don't know who the staff are and aren't
likely to know any time soon doesn't give a great impression.
(Assignee)

Comment 15

12 years ago
Can we resolve this bug as FIXED yet or are we still waiting for further
developments?

Comment 16

12 years ago
the bug as originally described is, I would think, pretty much done with. 
However, the distinctions and relationships between mozilla.org staff, Mozilla
Foundation employees and Mozilla Corporation employees are still not at all
clear from the web pages (which is not to say that they are clear anywhere else...)
QA Contact: danielwang → www-mozilla-org
Product: mozilla.org → Websites

Comment 17

9 years ago
Now that the www-archive.mozilla.org site is up, I'd recommend archiving this staff list page and then updating the about/roles.html page to either remove reference to staff or point people to the archive site.  Any objections?

Comment 18

9 years ago
Created attachment 340244 [details] [diff] [review]
Patch for Roles and Responsibilities page

If we're going to archive the obsolete staff page then we need to update the roles.html page that currently links to it.  This patch updates the roles.html page to remove the link to staff as well as other obsolete content (such as  the link to the drivers page which hasn't been updated since 2006) and content that is located elsewhere on the site (such as the projects and companies using Mozilla code).

fantasai, could you review this patch?  Can you also post thoughts about what to do with the links to staff.html and other obsolete pages?  We could redirect them to somewhere or leave them alone and they would automatically point to the archive site.
Attachment #340244 - Flags: review?(fantasai.bugs)

Comment 19

9 years ago
Created attachment 340414 [details] [diff] [review]
Patch for Roles and Responsibilities page

Posting a new patch that cleans up some of the text in the original patch.
Attachment #340244 - Attachment is obsolete: true
Attachment #340414 - Flags: review?(fantasai.bugs)
Attachment #340244 - Flags: review?(fantasai.bugs)

Comment 20

9 years ago
Created attachment 341539 [details] [diff] [review]
Patch for Roles and Responsibilities page

This patch adds a link back to the drivers page.  Even though the drivers page is a bit out of date, this patch should be ready for review for the main Roles page.
Attachment #340414 - Attachment is obsolete: true
Attachment #341539 - Flags: review?
Attachment #340414 - Flags: review?(fantasai.bugs)

Updated

9 years ago
Attachment #341539 - Flags: review? → review?(fantasai.bugs)
(Assignee)

Comment 21

9 years ago
Comment on attachment 341539 [details] [diff] [review]
Patch for Roles and Responsibilities page

-<title>Mozilla Roles and Responsibilities</title>
+<title>Roles and Leadership</title>

Please leave Mozilla in the title.

-  <dd>The Mozilla community includes all those who 
-    contribute to Mozilla: writing code, testing software, writing documentation, 
-    developing web pages and applications, advocating on behalf of Mozilla, 
-    or doing any of the multitude of other things that help make Mozilla useful 
-    and successful. Some participate as individual volunteers, some through 
-    their educational institution, and others work at commercial companies. 
-    These actions ultimately determine the direction of the Mozilla project, 
-    through the contributions made and through participation in the Mozilla 
-    discussion groups and mailing lists and Internet Relay Chat channels where 
-    the day-to-day activity takes place.</dd>

This paragraph should be kept. Although I'd replace Internet Relay Chat with IRC. Or maybe replace "and mailing lists and Internet Relay Chat channels" with "and other forums".

+including the Mozilla Corporation, IBM and Red Hat

I'd remove this phrase.

+ This meritocracy is a resilient and effective way to guide our global
+ community and create remarkable products.

"create remarkable products" sounds too marketing-speak-y. The main target audience here is people who are already committed to being part of the community: we don't need to convince them that what we do is "create remarkable products". Maybe "to guide the efforts of our global community"?

-     <dd>A module owner is someone to whom 
-     mozilla.org staff delegates leadership of the development of a module 
-     of code. This includes a range of responsibilities relevant to the daily 
+     <dd>A module owner is someone who is responsible for the leadership of
+     the development of a module of code. This role requires a range of
+     activities relevant to the daily 
      management of the module.

This sentence is awkward (three 'of' phrases chained together) and excludes non-code modules.

-    <dd>Drivers act as the day-to-day project managers 
-    on behalf of mozilla.org, focusing in particular on coordinating
-    milestone releases.</dd>
+    <dd>Drivers provide project management for mozilla.org milestone
+    releases. The drivers provide guidance to developers as to
+    which bug fixes are important for a given mozilla.org release. Drivers
+    also make a range of tree management decisions. The drivers are
+    particularly active after the trunk is frozen for a milestone release,
+    and in managing the milestone branch until a milestone is released.</dd>

Too much detail. The existing text is fine here, we have a whole separate page to describe the role in detail.

Please use spaces instead of tabs for indentation.
Attachment #341539 - Flags: review?(fantasai.bugs) → review-

Comment 22

9 years ago
Created attachment 344319 [details] [diff] [review]
Patch for Roles and Responsibilities page

Attached is a new patch that incorporates feedback from comment #21.

Below are some replies to some of the comments:

- I don't think the paragraph about the Mozilla Community fits on this page since we're just talking about leadership roles.  That Community content is certainly worthwhile though, but I think it fits in the Community section.

- I agree that the amount of text in the Drivers section was a bit much, so I reduced it.  Some of the other sections seemed a little wordy too, so I reduced some of the other text as well.
Attachment #341539 - Attachment is obsolete: true
Attachment #344319 - Flags: review?(fantasai.bugs)

Comment 23

9 years ago
I think the current patch is certainly better than what's on the site now, although it might need some tweaking still.  Since no one has objected, I'm thinking of checking in this patch and then making changes to it as needed in place.

Comment 24

9 years ago
I checked the latest patch in since no one had objected.  We can leave the bug open for a while to see if there are any additional changes we'd like to make to this page.

Updated

9 years ago
Duplicate of this bug: 470948

Comment 26

9 years ago
Now that the roles.html page is updated and no longer links to the staff list, does anyone object to archiving the page at

http://www.mozilla.org/about/staff

Comment 27

9 years ago
Here's an edit on the Roles page.  Current text is "The Mozilla community is governed by a virtual management team made up of unpaid experts and employees from a range of companies."

This makes it sound like not everyone is an expert, and that somehow campanies are involved in module ownership.  

Can we change this to same something like "virtual management team made up of  experts.  Module ownership is distinct from employment status; some module owners are employed to work on Mozilla, some are not.  "  Or something like that.

And as for the staff page, there are 2 things I care about:  
1.  finding it easily.  I use this page to think about th governance module, which is still new and needs tending.  

2.  Keeping this close enough that we don't forget there is ongoing work to do on our governance structure.  The staff page is an important and relevant reference material for both our history and our ongoing governance.

will archiving allow both of these?

Comment 28

9 years ago
Here's one other topic.

The staff document, though outdated, contains one aspect that isn't clear elsewhere.  The staff doc made it clear that if there was a technical decision we couldn't resolve any other way, Brendan would decide.  And if there is a non-technical decision that needs a final decision-maker, that's me.  

I don't think this has changed.  We've reflected it somewhat in the new Governance Module (https://wiki.mozilla.org/Module_Owners_Activities_Modules#Governance_Module) but it still needs work.  

Somehow it seems this should be reflected on this page as well.  Otherwise a basic aspect seems missing.  One could find it by going to the module owners pages and finding the right module and reading to the end of it, but that's a long way for something basic. 

Am looking to see if others agree; it's a bit odd to have these discussions about oneself :-)

Comment 29

9 years ago
To address the edit mentioned in comment #27 here is some new text we can consider:

The Mozilla project is governed by a virtual management team made up of experts from various parts of the community.  Some people with leadership roles are employed to work on Mozilla and others are not.  Leadership roles are granted based on how active an individual is within the community as well as the quality and nature of his or her contributions. This meritocracy is a resilient and effective way to guide our global community.

For the comments about the staff page in #27 and #28, I think there are a couple of ways to address this.  If the staff page is still relevant, we can update it and keep it.  Another option is to take the parts that are relevant and create a new page and archive the old staff page.

If we archive the staff page it will still be easy to find.  Soon the link to any archived page will automatically take you to that page on the archive site (unless we've intentionally redirected the link somewhere else).  For now, there is a link to an archived page on the 404 message that comes up for missing pages.  Whatever we end up doing with the staff page now, there is already an archived version of it at

http://www-archive.mozilla.org/about/staff

For the relevant parts of the staff page, I'd suggest creating a new page since AIUI there is no staff role today.  One option would be to create a page called 'Benevolent Dictators' and describe how open source communities usually have someone with ultimate authority over decision making and how right now in the Mozilla community Mitchell and Brendan have this role.

If this suggestion sounds reasonable, I can mock up a new page and we can link to it as one of the roles on roles.html.  If we'd prefer to keep the staff page and clean it up, I'll take a pass at removing the out of date parts and posting an updated version for review.

Comment 30

9 years ago
FYI, I was looking at some old pages on the archive site recently and noticed that there was a Benevolent Dictator section on the old mission.html page (scroll down to the bottom):

http://www-archive.mozilla.org/mission.html

We can borrow some of that text if we want to set up a new page.
(Assignee)

Comment 31

9 years ago
I think you're being too aggressive with your archiving. I firmly believe that nobody should be digging around in the archive site unless they're doing e.g. layout engine archeology. The mission statement and the staff page are not archeology, they're important parts of our history and have had a major role in shaping this organization and its culture. Whether in a historical section or not, they belong on the main site.

The same goes for anything linked from the historical bookmarks page; I expressly put them on the Do Not Archive list, and I'm disappointed to find that they were nonetheless removed. In an ideal world, where information was kept up-to-date or removed, the archive site would not exist. Therefore if *we* are linking to something on the archive site, something's not right.

Comment 32

9 years ago
I think I'm in the middle here.  We have tons of outdated material, we probably always will.  We probably should create a history section talking about staff and our past.  But I think it's fine to go to an archive to find the material.


I would like to see a history section, and maybe I'll try to write something soon -- of course, others are welcome to do this.  That page would have links, certainly to the staff list.  And then the staff page would be relevant -- as history-- and part of a site.  But it seems odd to me to leave it as is.   Moving the staff page may be the impetus.

Comment 33

9 years ago
The bigger question about archiving is worth continuing to talk about, but probably not in this bug.  As far as the staff page is concerned, if that page no longer reflects reality, it shouldn't be easily accessible on the www.mozilla.org site where people will naturally assume that it is current information about the community.  If we want to keep the staff page for reference for people who want it, I'd prefer to link to the archive site where there's a big disclaimer about the content being out of date.  Of course, if the staff page does reflect current reality, we should update it and keep it.

Comment 34

9 years ago
Re comment #32, there is currently a History area in the About section.  The link to the staff page may fit on the Mozilla Bookmarks page:

http://www.mozilla.org/about/bookmarks.html

This page is linked to from the History page at

http://www.mozilla.org/about/history.html

Comment 35

9 years ago
Or maybe adding a paragraph or two about project governance in the history document itself, with links.

Comment 36

9 years ago
I just went back through this bug to see what remains to be done.  It looks like there are three things:

- Mitchell made some suggestions for changes to the intro text in comment #27 and I posted some suggested new text in comment #29.  No one objected to that new text, so I just checked it in.

- We discussed the pros and cons of archiving the staff.html page and didn't come to a definite conclusion.  As mentioned in comment #32, the page is very out of date and it is odd to leave it as is, so I just archived it.  We can bring it back later when/if we decide to.

- In comment #28, Mitchell identified a need to have information on the Roles page about the final decision-maker role.  From a conversation earlier today, Mitchell suggested we adapt the benevolent dictator text from the mission.html page.  I'll post a draft of that change in a few minutes.

I think this captures everything.  After checking in the benevolent dictator text, I'd suggest closing this bug as fixed.

Comment 37

9 years ago
Created attachment 381638 [details]
Patch for Roles and Responsibilities page

Attached is a patch that includes a paragraph about Benevolent Dictators and some formatting tweaks to the rest of the page.  If this paragraph condenses the Benevolent Dictator role too much, we can set up a separate page that we can link to, just like we're handling the other roles.  If there are no objections to this, I'll post soon and close the bug.
Attachment #344319 - Attachment is obsolete: true
Attachment #344319 - Flags: review?(fantasai.bugs)

Comment 38

9 years ago
benevolent dictators part looks fine to me

Comment 39

9 years ago
I went ahead and checked in the changes to the Roles page, so I'm closing this as fixed.  If there are additional changes to make, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.