If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show link in Download Manager window does not work under Linux

RESOLVED DUPLICATE of bug 227502

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 227502
14 years ago
9 years ago

People

(Reporter: Bradley Chapman (not reading bugmail, still gone but not forever), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040209 Firebird/0.8.0+ (daihard: XFT+GTK2; optimized for P4/SSE-2)

The Show link attached to a donwload entry in the Download Manager that brings
up a folder window containing the file just downloaded does nothing on Linux.

Reproducible: Always
Steps to Reproduce:
1. Download a file on Linux.
2. Open the Download Manager.
3. Click the Show link.

Actual Results:  
Nothing.

Expected Results:  
A file manager of some sort should open, within the directory that the file was
downloaded to.

This could be fixed by adding a File Manager selection dialog to the Download
Manager section of Options->Downloads in Firefox which allows the user to select
the application used to display the file. Firefox could then call the program
with the directory path of the downloaded file and have them display the
directory (xffm and Konqueror, for example, allow you to call them on the
command-line with a directory path appended, and both will open in that directory).

I'm starting this bug at Normal, because it makes the Show link work on Linux.
This could also be an enhancement. This might also be related to bug 232138,
"Show Folder button does not work in Tools->Options->Downloads->Download
Folder", and it could ostensibly be fixed by this as well if Firefox gains the
ability to call external file manager applications.
I feel like such an idiot.

I just fixed my symlinks for my Firefox installation and now the Show link does
work, but in an unexpected way - it spawns a new browser window to display the
folder, instead of opening a new tab in the current window or opening a folder
view via an external application, like on the Windows platform. While this
functionality is nice, I still think the browser should use the window manager's
filemanager application, so this enhancement bug is still somewhat relevant.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 227502 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: aebrahim
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.