HTTPS doesn't work with subdomains

RESOLVED DUPLICATE of bug 127539

Status

()

Core
Security
RESOLVED DUPLICATE of bug 127539
14 years ago
14 years ago

People

(Reporter: Sebastian Menger, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: 

When typing in a https page which begins with a subdomain, mozilla does not 
recognize it. Seems as mozilla ist expecting a www

Reproducible: Always
Steps to Reproduce:
1.https://banking.diba.de or https://meine.deutsch-bank.de
2.
3.

Actual Results:  
Page could not be found

Expected Results:  
Internet Explorer

Comment 1

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040203
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Reporter, which browser did you use? Please copy & paste the result from typing
about: into the location bar.
Please one URL only for the URL-field
Also be sure you are using working links, deutsch-bank isn´t correct, company
name is Deutsche Bank, so deutsche-bank.de is worth a try!
Do you use a personal firewall, like ZoneAlarm?
Are all https://someurl not working, or are there some https:// working for you?


Working:
https://banking.diba.de/
https://meine.deutsche-bank.de

leading to:
https://meine.deutsche-bank.de/mod/WebObjects/dbpbc.woa

There are a lot of bugs for diba.de, have a look:
http://bugzilla.mozilla.org/buglist.cgi?query_format=&short_desc_type=allwordssubstr&short_desc=&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=diba.de&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=

Comment 2

14 years ago
re: deutsche-bank
http://bugzilla.mozilla.org/buglist.cgi?query_format=&short_desc_type=allwordssubstr&short_desc=&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=deutsche-bank.de&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
gives 11 bugs ending 2002, mostly cookies and Mozilla 1.2


Using a nightly from today, I couldn´t see a demo at
https://secure.db24.de/pbc/demokonto/index.html

It is called via Javascript, and opens a popup, but the popup doesn´t show anything.

Steps to reproduce:
https://meine.deutsche-bank.de

Look at the right for:
   Online-Banking & -Brokerage
   Online einfach mal auspro-
   bieren?

and click below:
   ->	zum Demokonto

zum Demokonto is a javascript link:
javascript:void
window.open('http://www.deutsche-bank.de/pbc/jumppages/jumpPage_To_dkt.html?link=ext;from-txm_login-C-demokonto-TX;to-dkt','','width=788,height=520');

the popup gives two errormessages in the JS console:
Error: uncaught exception: Permission denied to get property Window.focus
Error: uncaught exception: [Exception... "Invalid ClassID or ContractID" 
nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame ::
chrome://inspector/content/jsutil/system/file.js :: <TOP_LEVEL> :: line 119" 
data: no]

At least the second seems to be from DOM Inspector.
> Error: uncaught exception: Permission denied to get property Window.focus

You have Window.focus set to noAccess in your prefs.  Open up prefs.js and unset
that (don't try with about:config; it won't work).

Comment 4

14 years ago
wfm wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040203

tested on 2 systems, one with Win98SE, and the original one with Win98 SP1, with
a fresh created profile just for test to avoid dealing with pref Window.focus

Comment 5

14 years ago
There is a bug about banking.diba.de, which has already quite a lot of dupes.
Reporter, is there any similarity between bug 127539 and this one?

Comment 6

14 years ago
I´m resolving this bug as dupe, as it has the same URL as the other one.
The reporter didn´t comment, it is wfm, the dupe should be fixed by now,
according to last comments.

*** This bug has been marked as a duplicate of 127539 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.