Charset Handling- Parser does not use default charset value set by Default Charset Menu

VERIFIED FIXED in M5

Status

()

Core
HTML: Parser
P1
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

Trunk
All
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Tested Jan 12 Win32 build.

No encoding menu, so we cannot test the different encoding.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
Setting all current Open Critical and Major to M3

Comment 2

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
QA Contact: 3853 → 3851

Comment 3

19 years ago
Setting QA Contact to teruko.

Comment 4

19 years ago
Bob, is there a way to hack this without having encoding selection
on the menu.  If there is a way to do this testing right now lets just
release not that way.
(Assignee)

Comment 5

19 years ago
Hook up the Default charset menu w/ nsParser may need to change the
nsParser::Parse interface. I think we probably should do this post dog food. And
I need to talk to rickg about the interface change. There is a work around for
meta tag pages so we don't need this for browser. We do need this to test
Japanese mail on window but naoki is working on a hack in libmime to reduce the
need. If that hack is check in, I don't think we need this for M3.

Change this to M4.
(Assignee)

Comment 6

19 years ago
Hook up the Default charset menu w/ nsParser may need to change the
nsParser::Parse interface. I think we probably should do this post dog food. And
I need to talk to rickg about the interface change. There is a work around for
meta tag pages so we don't need this for browser. We do need this to test
Japanese mail on window but naoki is working on a hack in libmime to reduce the
need. If that hack is check in, I don't think we need this for M3.

Change this to M4.

Updated

19 years ago
Component: Viewer App → Internationalization

Comment 7

19 years ago
When activating a charset menu, depends on a context, more actions may be needed
than just notify the charset change to the parser.
For example, if a mail folder is selected, we need to notify the messenger to
change a charset attribute of the mail folder.
Should I create a new bug for this?

Comment 8

19 years ago
The messenger charset menu issue was separated as #3966.
(Assignee)

Updated

19 years ago
Summary: [I18n]No encoding menu. → Charset Handling- No encoding menu.
(Assignee)

Updated

19 years ago
Assignee: ftang → rickg
Status: ASSIGNED → NEW
Component: Internationalization → Parser
Summary: Charset Handling- No encoding menu. → Charset Handling- Parser does not use default charset value set by Default Charset Menu
(Assignee)

Comment 9

19 years ago
We have put in the Default Charset Menu for browser, hookup the JS w/
BrowserAppsCore and pass the info into nsWebShell. Now the problem is the Parser
( or the code which create the parser) does not get that information and pass it
to Parser. Reassign this to rickg since this need API change in parser. Change
the summary from "Charset Handling- No encoding menu." to "Charset Handling-
Parser does not use default charset value set by Default Charset Menu"

Updated

19 years ago
Assignee: rickg → ftang

Comment 10

19 years ago
Frank -- I'm giving this to you until we start calling:
nsParser::SetDefaultCharset().
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M4 → M5
(Assignee)

Updated

19 years ago
Hardware: PC → All
(Assignee)

Comment 11

19 years ago
Change to M5 from M4 since neeti and rickg have not implement the META tag
observer yet.
(Assignee)

Comment 12

19 years ago
change platform to all
(Assignee)

Comment 13

19 years ago
*** Bug 4869 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

18 years ago
encoding menu is done. We now pass the Parser the default charset from the
webshell.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

18 years ago
Character Default menu is working, so I mark this as verified.
You need to log in before you can comment on or make changes to this bug.