Mouse wheel scroll doesn't work in preferences/options dialog

VERIFIED DUPLICATE of bug 97283

Status

()

Firefox
Preferences
--
minor
VERIFIED DUPLICATE of bug 97283
14 years ago
12 years ago

People

(Reporter: Manfred Schubert, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Mouse wheel scrolling does not work in the preferences dialog.

Reproducible: Always
Steps to Reproduce:
1. Select FireFox->Preferences to open the preferences dialog
2. Click the "Advanced" icon
3. Expand all the sub-panes with their disclosure triangles, so that a vertical
scrollbar is shown
4. Try to use the mouse wheel to scroll the advanced preferences

Actual Results:  
Doesn't scroll with the mouse wheel.

Expected Results:  
Should scroll with the mouse wheel.
should work if you focus an element, this is a dupe of a dupe of a dupe :)
Whiteboard: DUPEME
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> should work if you focus an element, this is a dupe of a dupe of a dupe :)

I have seen that bug, but no, it doesn't work if I click or focus an element
within that dialog (being the Service URL field as the only on focusable).
That's why I thought this is different and filed it.

Comment 3

14 years ago
confirmed, will not scroll even after widgets manipulated.  Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040308 Firefox/0.8.0+
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> All/All (bug 247344 is linux, I can confirm Windows, this bug is Mac)

I CAN scroll using the mousewheel after I have unchecked and then checked one of
the checkboxes in the advanced pane.

Which dupe are you referring to mconnor? I have searched and cannot find any.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
OS: MacOS X → All
Hardware: Macintosh → All
*** Bug 247344 has been marked as a duplicate of this bug. ***
fwiw, linux gtk2 firefox 0.9 does wheel scroll when a widget in the pref pane
content is focused.
Summary: Mouse wheel doesn't work in preferences dialog → Mouse wheel scroll doesn't work in preferences/options dialog

Comment 7

14 years ago
(In reply to comment #4)
> -> All/All (bug 247344 is linux, I can confirm Windows, this bug is Mac)
> 
> I CAN scroll using the mousewheel after I have unchecked and then checked one of
> the checkboxes in the advanced pane.
> 
> Which dupe are you referring to mconnor? I have searched and cannot find any.
> 


I confirm this for linux. After unchecking an element, scroll wheel works. I'm
using the 2004-07-20 nightly.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
afaik, shouldn't scrollwheeling (is that a verb?) work upon mouseover, not
requiring explicit setting of focus (ie, not need to mouseclick or tab to set
the focus ring on a widget)? that seems to be the case in other apps I've used
on Mac, Linux and Windows...

Brian, you had a (tracking?) bug on this for seamonkey (I'll look for it), but
I'm not sure if it was resolved.
(Reporter)

Comment 9

14 years ago
Yes, the mouse wheel should work on mouse over without the need for key focus.
Key focus is for keys, not the mouse after all.

However, in this dialog *on Mac* the mouse wheel does not work even if the key
focus is set into the pane (being the Service URL as the only field that can get
key focus).

Comment 10

14 years ago
*** Bug 252787 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Fixing Bug 97283 will probably fix this
Depends on: 97283
I can reproduce the problem in firefox-2004-08-02-12-trunk Linux but not in
firefox-2004-08-07-12-trunk, so bug 97283 fixed this.

*** This bug has been marked as a duplicate of 97283 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 97283
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
v dup.
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.