Autocomplete should match all parts of strings, not just beginning

RESOLVED DUPLICATE of bug 186136

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 186136
14 years ago
14 years ago

People

(Reporter: Stefan Eskelid, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

As it is now, autocomplete always start from the beginning of the previously
typed words. That means that if you don't remember the start of an address, only
parts of it or the end ("I know it was something like '.../xul/rules.html'"),
you will not be able to utilize the autocomplete feature.

If you *only* have lets say 'www.mozilla.org' and 'www.bugzilla.org' stored and
you type 'zilla' in the location field nothing will show. It would be nice if
all typed words containing 'zilla' would be shown, as is done when using Find As
You Type.
The drop-down could display all results starting with the typed string and after
them the results containing the string.

Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Summary: Use same approach as in 'Find As You Type' for autocomplete → Autocomplete should match all parts of strings, not just beginning

Comment 1

14 years ago
sounds very similar to bug #186136

is the type of feature you are looking for?  if so please close this bug and
vote for that one.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 186136 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.