UI for browser.urlbar.autoFill / Pref for "best match as you type" / inline autocomplete is missing in Firefox

RESOLVED WONTFIX

Status

()

Firefox
Preferences
P2
enhancement
RESOLVED WONTFIX
15 years ago
8 years ago

People

(Reporter: Ahmet A. Akin, Unassigned)

Tracking

({conversion})

unspecified
Firefox 3 alpha7
conversion
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Workaround in comment #30)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021216 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021216 Phoenix/0.5

In mozilla , there is an option in 
Pref->Navigator->smartBrowsing->Location Bar autocomplete (Advanced)
there you have options about Location Bar autocomplete. And one "best match as
you type" is missing in phoenix.  


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Marking NEW to let the developers decide if they want to add this pref.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
(Reporter)

Comment 2

15 years ago
Sorry for the spam but mozilla's auto complete is much better. When you wanted
to enter "bu..." mozilla shows "bugzilla.mozilla.org" at top of the autocomplete
list but phoenix just shows the latest one at top , which is usually
meaningless. should i file a bug for that? 

Comment 3

15 years ago
The phoenix autocomplete is not the same widget as in Mozilla and will not have
preferences like Mozilla. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
*** Bug 197726 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 197726 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
> The phoenix autocomplete is not the same widget as in Mozilla
> and will not have preferences like Mozilla

How about implementing this highly useful feature *without* adding a pref for
disabling it?

Just for the record, about 9 out of 10 times, the very first entry is exactly
what I'm looking for. This is one of the reasons why I consider Mozilla +
"Autocomplete best match as you type" to be the best URL-bar Autocomplete
implementation in any current browser (including IE6 and Safari).

Prog.

Comment 7

14 years ago
*** Bug 208774 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
Asa, that it'll not have a pref doesn't mean it won't be implemented, does it?

Comment 9

14 years ago
Taking QA and mass verification of dupe, invalid and wontfix autocomplete bugs.
Sorry for the bugspam.
Status: RESOLVED → VERIFIED
QA Contact: asa → davidpjames
(Reporter)

Comment 10

14 years ago
Very sorry for the spam but the first given reason 
"The phoenix autocomplete is not the same widget as in Mozilla and will not have
preferences like Mozilla. " by Asa
is not a valid reason to make this bug invalid IMO!. i am requesting this bug to
open again because it is a very nice option. Please cant you consider?

Comment 11

14 years ago
I second Ahmet's comment.  I simply will not use any browser that does not have
"inline autocomplete" (as IE calls it) on the URL bar.  I'm sure others feel the
same.  This bug is "WONTFIX" which I assume means the feature is not going to be
added any time soon... I urge the powers that be to reconsider.

Comment 12

14 years ago
Firebird does have URL autocomplete, but it requires one more keypress
(down-arrow) compared to Mozilla. I too think that it's the wrong decision to
WONTFIX this bug, but this missing feature is actually one of the least
important reasons that keeps me in Seamonkey (the rest are here
http://snurl.com/seamonkey_is_better).

Prog.

Comment 13

14 years ago
Internet Explorer allows for Inline Autocomplete.  

Comment 14

14 years ago
My personal opinion is that this should be included in FB, but since Asa has
wontfixed this I'm loathe to reopen it without some cause. If someone were to
submit a patch to port this function over to FB then I would reopen this bug.

CCing some QAs
Summary: autocomplete "best match as you type" is missing in phoenix → "best match as you type"/inline autocomplete is missing in Firebird

Updated

14 years ago
Blocks: 203756

Comment 15

14 years ago
I have a patch for this in bug #203756.

I'm not exactly why someone put this bug blocks that bug, though.

Comment 16

14 years ago
Oh, don't I look silly. In the back of my mind I even knew about this other bug.

-->Reopening
noririty accidentally swapped the depends/blocks --> fixing
No longer blocks: 203756
Status: VERIFIED → REOPENED
Depends on: 203756
Resolution: WONTFIX → ---

Comment 17

14 years ago
This bug is now about adding a UI access point to browser.urlbar.autoFill and
whether or not to set it on by default. Bug 203756 is about adding the pref itself.

--> Over to preferences
Assignee: hewitt → blake
Status: REOPENED → NEW
Component: Autocomplete → Preferences
QA Contact: davidpjames → mpconnor

Comment 18

14 years ago
*** Bug 223645 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

14 years ago
Flags: blocking0.8?

Comment 19

14 years ago
Inline autocomplete isn't set by default in IE6 SP1.  I just think a GUI-visible
option to enable it would be appropriate.
as noted already in 203756, this has yet to have a decision by the component
owner (bryner) and will not qualify as a blocker.
Flags: blocking0.8? → blocking0.8-

Comment 21

14 years ago
*** Bug 229635 has been marked as a duplicate of this bug. ***
Adding conversion keyword based on previous comments/its prominence in IE...
Keywords: conversion
Summary: "best match as you type"/inline autocomplete is missing in Firebird → "best match as you type"/inline autocomplete is missing in Firefox

Comment 23

14 years ago
*** Bug 236141 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking0.9?
still not a blocker for the same reason as in 0.8, easy enough to fix once
depenency is fixed/resolved.  Plus, that bug is already at blocking0.9? status
Flags: blocking0.9? → blocking0.9-

Comment 25

13 years ago
(In reply to comment #19)
> Inline autocomplete isn't set by default in IE6 SP1.  I just think a GUI-visible
> option to enable it would be appropriate.

I second this. I just moved over from Mozilla to Firefox and I've found this
feature in particular 'missing' from Firefox.

Reve

Comment 26

13 years ago
Bug #203756 was fixed a few weeks ago. Now that the back end is available, isn't
it about time to decide on the GUI? 

IMHO, the most obvious location would be under Advanced -> Browsing, and this
option should be turned on by default (just like it is on Safari). There's more
to gain than to lose from this.

Prog.

Comment 27

13 years ago
Changing the summary to make it clearer that the only thing missing is a pref.
This functionality *is* available in Firefox, it's just not easy to turn on.

Prog.
Flags: blocking1.0?
Summary: "best match as you type"/inline autocomplete is missing in Firefox → Pref for "best match as you type"/inline autocomplete is missing in Firefox
Flags: blocking1.0? → blocking1.0-

Comment 28

13 years ago
So... when will the pref be added?  This is the only thing stopping me from
switching from Mozilla.  Picky, I know.
the pref exists, go to about:config and set browser.urlbar.autoFill to true.

Comment 30

13 years ago
(In reply to comment #29) 
> the pref exists, go to about:config and set browser.urlbar.autoFill to true. 
 
No it doesn't Mike, at least it's not yet readily accessible, even in 
about:config. To actually enable this pref one has to go to about:config, 
then: 
-right-click (anywhere) 
-select New -> Boolean from the context menu 
-fill in the dialogue box with browser.urlbar.autoFill 
-and then set the next dialogue box to true 
It is (In reply to comment #30)
> (In reply to comment #29) 
> > the pref exists, go to about:config and set browser.urlbar.autoFill to true. 
>  
> No it doesn't Mike, at least it's not yet readily accessible, even in 
> about:config. To actually enable this pref one has to go to about:config, 
> then: 
> -right-click (anywhere) 
> -select New -> Boolean from the context menu 
> -fill in the dialogue box with browser.urlbar.autoFill 
> -and then set the next dialogue box to true 

It is so easy, why isn't it the default in Firefox? Is there a reason for it?

Comment 32

13 years ago
Duping to the bug that has been fixed already.

*** This bug has been marked as a duplicate of 203756 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 33

13 years ago
Whoops.  That bug was only about getting browser.urlbar.autoFill to work in the
first place.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Pref for "best match as you type"/inline autocomplete is missing in Firefox → UI for browsr.urlbar.autoFill / Pref for "best match as you type" / inline autocomplete is missing in Firefox
Does anybody have something against making browser.urlbar.autoFill=true?
Hardware: PC → All
Summary: UI for browsr.urlbar.autoFill / Pref for "best match as you type" / inline autocomplete is missing in Firefox → UI for browser.urlbar.autoFill / Pref for "best match as you type" / inline autocomplete is missing in Firefox
I do.  Unless the "best match as you type" is accurate enough that I'll get my
desired URI more than 60% of the time, it'll be an annoyance.  Given that
autocomplete currently is at around 20-25% for me on that front, it'd be a huge
usability loss.

On: 
Small usability win (don't have to hit downarrow to complete)
Annoys the hell out of users who usually don't get the best match.

Off:
Small usability loss in the "most of the time its what I want" scenario (have to
hit Down to get that match)
Can be turned on by reasonably saavy users. (UI for this would lower the bar)

Comment 36

13 years ago
I thought it was great once it was fixed in Firefox.  But after using it for a
while, I realized that too often I wanted the root URL, not the subpage.  For
example, I would want to go to the bugzilla home page, but it would autofill
some previously visited bug URL.  That, however, is more likely a problem with
the autofill algorithm than with the property itself.  

I definitely see having a UI box for this a low priority, probably because I
will never use it again.

Comment 37

13 years ago
(In reply to comment #36)
> I thought it was great once it was fixed in Firefox.  But after using it for a
> while, I realized that too often I wanted the root URL, not the subpage.

Wouldn't that be http://bugzilla.mozilla.org/show_bug.cgi?id=240397 ?

Comment 38

13 years ago
how does it annoy anyone if it's on?  if it autofills the wrong URL, you just
keep typing.

Comment 39

13 years ago
(In reply to comment #38)
> how does it annoy anyone if it's on?  if it autofills the wrong URL, you just
> keep typing.

What good is autocomplete if I have to type the whole thing?  Yes, this not a
good pref to have until bug 240397 is fixed.
Depends on: 240397

Comment 40

13 years ago
(In reply to comment #39)
> (In reply to comment #38)
> > how does it annoy anyone if it's on?  if it autofills the wrong URL, you 
> > just keep typing.
> 
> What good is autocomplete if I have to type the whole thing?  Yes, this not a
> good pref to have until bug 240397 is fixed.

Somewhat of a shameless plug, but I think this bug is more relevant:

http://bugzilla.mozilla.org/show_bug.cgi?id=101642

While the bug above is for Mozilla, I think it applies equally to Firefox as
well.  I don't think favoring top-level URLs is the best solution, for many
personal webpages follows the form: www.hosting./~user/  In these cases,
prefering the top-level URL is not very helpful.

Comment 41

13 years ago
(In reply to comment #39)
> (In reply to comment #38)
> > how does it annoy anyone if it's on?  if it autofills the wrong URL, you 
> > just keep typing.
> 
> What good is autocomplete if I have to type the whole thing?  Yes, this not a
> good pref to have until bug 240397 is fixed.

it's still no more annoying than the current behavior.

how about bash-style autocomplete?  i'd love to see that.  i guess that should
probably be a new bug, though.  does anyone know if such a bug exists?

Comment 42

13 years ago
(In reply to comment #39)
> What good is autocomplete if I have to type the whole thing? 

You don't have to type a single keypress more than without it. In fact,
browser.urlbar.autoFill *saves* you typing a single keypress (one arrow-down)
for *every* URL. All gain, no pain.

Prog.

Comment 43

13 years ago
*** Bug 234290 has been marked as a duplicate of this bug. ***

Comment 44

13 years ago
*** Bug 258325 has been marked as a duplicate of this bug. ***

Comment 45

13 years ago
*** Bug 262059 has been marked as a duplicate of this bug. ***
*** Bug 269429 has been marked as a duplicate of this bug. ***

Comment 47

13 years ago
Okay, I think the argument of whether it should default to true or false is
irrelevant...

the point is... there should be a configuration option to turn it off and on as
a person sees fit.

Mike you don't like it, fine leave it off, but alot of people, as pointed out by
the NUMEROUS duplicate bugs, as well as comments about this in this bug itself,
show a legimiate number of requests to have an option.

I think it should be left off by default.... I agree with you on that point.

But it should be an option.

I went to about:config to do this manually
And when I right click, and go to new.... the context menu doesn't even come
up... so I can't even do this the pain in the ass way.

There is no legitimate reason for this to not be a UI Configurable option.  Your
argument is that it should not be on by default.  This is really immaterial, if
you give the user the option to turn it on and off.

I never even knew about about:config before reading this bug, so throwing your
hands up and saying "OMG PEOPLE CAN TURN IT ON IN ABOUT:CONFIG IF THEY WANT IT
THAT BAD"  is not even a plausable soloution to the problem.  Especially since
about:config --doesn't even work-- 

So long story short, there is quite a demand for this to be a UI option, I don't
think that demand should be continually ignored.  This has been Ignored for
almost 2 YEARS now.

If you'd like, I can have plenty more people submit replies to this to prove my
point.  Most people don't even know about bugzilla... just like the large
majority of people don't know about about:config, anyway... I'm done I believe....
*** Bug 275776 has been marked as a duplicate of this bug. ***

Comment 49

13 years ago
Hello all,

Now that Firefox has been so positively reviewed in the New York Times and its
use exploding among former Internet Explorer users, I think it would be a very
serious mistake not to allow an option for Autofill in the UI, regardless of the
default value.

I suspect many IE users who have turned on "inline autocomplete" will
immediately go back to Internet Explorer the very moment they find out they
cannot enable it in Firefox.

I am a one-time contributor to Bugzilla; I only add these comments because today
I downloaded Firefox, having read the NY Times editorial, and I was very
surprised that it did not have "inline autocomplete" (autofill).

Best regards,
Dan Nissenbaum

Comment 50

13 years ago
I fully agree with the previous comments by Matt & Dan.  This *needs* to be
done!  Whatever powers-that-be that are out there, please please please flag
this appropriately so that something happens.  I'm certainly not going back to
IE (rather I'll keep using regular Mozilla, which inexplicably has this feature
while Firefox does not), but others quite possibly will.  Perhaps this trivial
item has been underestimated... just take our word for it, there are people like
us out there that HAVE to have this feature readily available.

Comment 51

13 years ago
Guys, this feature is already available, it just takes a few more seconds to enable.
-> https://bugzilla.mozilla.org/show_bug.cgi?id=186136#c31

Another recommended read: http://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Prog.
Whiteboard: Workaround in comment #31

Comment 52

13 years ago
> -> https://bugzilla.mozilla.org/show_bug.cgi?id=186136#c31
Sure. But there are two points where I fully agree with the guys:
1) This is a bit complicated, which a "normal" IE user will never want to
"explore" how to do it (their will or their won't, you know ;)); therefore an
option among advanced where you can adjust it simply _must_ be added;
2) The default option must be to enable autocompletion.

I am a linux and netscape 4.0x to 7.1/mozilla/firefox user for about 6 years, I
am administering alinux mailing list in Hungary, and I know the "simple" user
who change from win to linux, or IE to Mozilla/Firefox. They are too lazy to
read manuals or even search the web.

Comment 53

13 years ago
Bugzilla Etiquette rule #1: No pointless comments. 

  "Unless you have something constructive and helpful to say, do not add a
comment to a bug. In bugs where there is a heated debate going on, you should be
even more inclined not to add a comment. Unless you have something new to
contribute, then the bug owner is aware of all the issues, and will make a
judgement as to what to do. If you agree the bug should be fixed, vote for it.
Additional "I see this too" or "It works for me" comments are unnecessary unless
they are on a different platform or a significantly different build."
Maybe a better bit from the etiquette files is not telling us what me _must_ do
in any situation.  Unless autocomplete gets much better, comment 35 still
applies, so the default value will remain off.

UI for this absolutely will have to wait for the redesigned prefwindow.  I'm not
sure even where this would fit into Ben's work, so arguing about it now is
pointless.

Updated

13 years ago
Whiteboard: Workaround in comment #31 → Workaround in comment #30

Comment 55

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a)
Gecko/20021216 Phoenix/0.5
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a)
Gecko/20021216 Phoenix/0.5
> 
> In mozilla , there is an option in 
> Pref->Navigator->smartBrowsing->Location Bar autocomplete (Advanced)
> there you have options about Location Bar autocomplete. And one "best match as
> you type" is missing in phoenix.  
> 
> 
> Reproducible: Always
> 
> Steps to Reproduce:


This is just one of the options that aren't the FireFox. I really like the
browser but the Options are a real disappointment.

Comment 56

12 years ago
*** Bug 286473 has been marked as a duplicate of this bug. ***

Comment 57

12 years ago
*** Bug 270628 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Blocks: 163993

Updated

12 years ago
No longer blocks: 163993

Updated

12 years ago
Assignee: firefox → nobody
Status: REOPENED → NEW
QA Contact: mconnor → preferences

Comment 58

12 years ago
Now that the Options dialog has been redone, I'd politely ask the developers to reconsider the issue. I've loved the change since setting the pref value and think the heuristic is pretty good. I'm not sure we want to clutter up the Options dialog, tho, so maybe someone could change the summary of this bug to

UI for enabling browser.urlbar.autoFill / "best match as you type" / inline autocomplete

or even (as I prefer)

Set as default browser.urlbar.autoFill / "best match as you type" / inline autocomplete to true
Keywords: uiwanted

Comment 59

11 years ago
*** Bug 333445 has been marked as a duplicate of this bug. ***
Flags: blocking0.9-
Flags: blocking0.8-
Flags: blocking-aviary1.0-

Comment 60

11 years ago
*** Bug 333722 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Depends on: 334863
There are two ways to expose this:

 - a pref buried in advanced > browsing
 - a context menu entry on the URL field

My personal preference is for the latter, since with the current level of reliability, this sounds like the sort of thing the user might want to flip on and flip off, and because then the UI is closely associated to the locus of the task itself. Also, means we avoid cluttering up the prefs further.

(removing uiwanted)
Keywords: uiwanted
Assignee: nobody → bugs.mano
Priority: -- → P2
Target Milestone: --- → Firefox 2 beta1
Status: NEW → ASSIGNED
Target Milestone: Firefox 2 beta1 → Firefox 3 alpha2
*** Bug 353015 has been marked as a duplicate of this bug. ***
Assignee: mano → nobody
Status: ASSIGNED → NEW

Comment 63

10 years ago
I'm for a context menu entry on the URL field. I think that's where konqueror also place this option.
Target Milestone: Firefox 3 alpha2 → Firefox 3 beta1

Comment 64

10 years ago
Is this still targeted for Firefox 3?
Flags: blocking-firefox3?
Not a blocker for Firefox 3, no.
Flags: blocking-firefox3? → blocking-firefox3-
Duplicate of this bug: 420829

Updated

9 years ago
Duplicate of this bug: 424170

Comment 68

9 years ago
I can't see bug 420829 and bug 424170 as being dupes of bug 186136.

They are about making the default action of hitting "enter"--after having typed something in the location bar, and with the awesome drop-down dropped down--be to go to the top entry in the drop-down.

Flipping on browser.urlbar.autofill doesn't give that behavior. I'm not too sure there's any necessary connection with autofill at all.

I'd suggest duping one to the other for now. There may be a good bug to dupe them both to, but I haven't noticed it. I guess the bug might be in autofill or autocomplete behavior, or more likely it's an awesome bar enhancement bug, but I'm pretty confidant it's not a preferences bug.
Thanks Michael Warner. I was just about to say that!

Frankly, I think this is an absolute must for Firefox 3, especially because of the enhanced Location Bar aka the AwesomeBar!

Also, the current default behaviour when you type a word and press enter is to do a Google I'm Feeling Lucky search. However, I now use the new AwesomeBar way more than I do Google I'm Feeling Lucky searches. I think when a user types a word and presses enter, Firefox should use the first result suggested by the AwesomeBar and not do a Google I'm Feeling Lucky search.

Comment 70

9 years ago
Ok, they're dups of bug 410837, not this bug.
As it stands, autofill is deprecated, and doesn't work except in match-beginning-of-URL cases.  There's accessibility and usability issues with the behaviour, which is why it's deprecated.  We're not going to add UI for this, though we may do something with bug 410837.
Status: NEW → RESOLVED
Last Resolved: 13 years ago8 years ago
Resolution: --- → WONTFIX

Comment 72

8 years ago
Isn't "match-beginning-of-URL" what SeaMonkey does? Because it works perfectly with browser.urlbar.autoFill there. In most cases, a single key-press followed by Enter is all that's required to get to the page I'm looking for (it's probably so accurate due the ordering the results by number of visits). Firefox, on the other hand, always requires an additional down-arrow.

Prog.
You need to log in before you can comment on or make changes to this bug.