crash the entire X system downloading ISO via HTTP

RESOLVED DUPLICATE of bug 213734

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 213734
15 years ago
15 years ago

People

(Reporter: giulivo navigante, Assigned: Blake Ross)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040215 Firefox/0.8

in the page at http://cruxppc.sunsite.dk/download.html if i try to download the
ISO image of CRUX PPC 1.3 via HTTP firefox and the entire X system CRASHES :)

Reproducible: Always
Steps to Reproduce:
1. open http://cruxppc.sunsite.dk/download.html
2. click on the HTTP link for download CRUX PPC 1.3 ISO
3.

Actual Results:  
firefox and X crashes

Expected Results:  
ask to me where i want save the ISO image

Comment 1

15 years ago
can you attach a stacktrace using GDB ? Run 'firefox -g' then in "GDB>", type
'run' and whe Firefox has crashed and you're in "GDB>", type 'backtrace'
Keywords: crash, stackwanted
(Reporter)

Comment 2

15 years ago
(In reply to comment #1)
> can you attach a stacktrace using GDB ? Run 'firefox -g' then in "GDB>", type
> 'run' and whe Firefox has crashed and you're in "GDB>", type 'backtrace'

unfortunately, when i type "run" in gdb, i've not the expected results... this
is what gdb says:

[START]

giulivo@gosk7 ~ $ firefox -g
/usr/lib/firefox/run-mozilla.sh -g /usr/lib/firefox/firefox-bin
MOZILLA_FIVE_HOME=/usr/lib/firefox
 
LD_LIBRARY_PATH=/usr/lib/firefox:/usr/lib/firefox/plugins:/usr/lib/mre/mre-1.6:/usr/garnome/lib:
DISPLAY=:0.0
DYLD_LIBRARY_PATH=/usr/lib/firefox:/usr/lib/mre/mre-1.6
     LIBRARY_PATH=/usr/lib/firefox:/usr/lib/firefox/components:/usr/lib/mre/mre-1.6
       SHLIB_PATH=/usr/lib/firefox:/usr/lib/mre/mre-1.6
          LIBPATH=/usr/lib/firefox:/usr/lib/mre/mre-1.6
       ADDON_PATH=/usr/lib/firefox
      MOZ_PROGRAM=/usr/lib/firefox/firefox-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in (/usr/garnome/bin:/bin:/usr/bin:/usr/X11R6/bin)
/usr/bin/gdb /usr/lib/firefox/firefox-bin -x /tmp/mozargs13459
GNU gdb 6.0
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)...
(gdb) run
Starting program: /usr/lib/firefox/firefox-bin
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIG32, Real-time event 32.
0x4073ef08 in sigsuspend () from /lib/libc.so.6
(gdb)

[END]

probably because on my system binaries and libraries are stripped out from debug
symbols?

anyway, i've compiled firefox from sources, if needed i can attach my layout
file... but i've also tested firefox on many other system/archs and have
discovered with vesa and ati video drivers, firefox DOES NOT CRASH ... i can see
undecifrable characters in the firefox page, but can press stop and it stop the
download ... with nvidia drivers, X crashes :(

is this useful?
thank you for your help

Comment 3

15 years ago
can you mention the output of about:buildconfig for both of the versions you use
(0.8 and the one you compiled) ?
I believe the crash is related to XFT (see bug 213734).
Blocks: 172768
(Reporter)

Comment 4

15 years ago
Created attachment 144796 [details]
buildconfig

Comment 5

15 years ago
can you try a nightly build or at least Mozilla 1.7b ?
(Reporter)

Comment 6

15 years ago
(In reply to comment #5)
> can you try a nightly build or at least Mozilla 1.7b ?

yep... i've tried with 26 march nightly release of firefox... it works well and
says to me "where i want to save the file"

really thank you for you work!! :)

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 213734 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.