Closed Bug 234593 Opened 17 years ago Closed 16 years ago

Growing table

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: u61093, Assigned: bernd_mozilla)

References

()

Details

(Keywords: testcase)

Attachments

(3 files, 1 obsolete file)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040212 Firebird/0.8.0+

Go to the URL and mouse over the "Document Literal" link that is next to the
text "Wiki:".  The center cell on the page grows larger and larger to the right
as you mouse over the link.

Reproducible: Always
Steps to Reproduce:
See details.
Actual Results:  
See details.

Expected Results:  
The size of the center cell should remain constant.
not specific to Firefox
Assignee: firefox → general
Component: General → Browser-General
Product: Firefox → Browser
QA Contact: general
Version: unspecified → Trunk
I'm not sure what "not specfic to firefox" means, but it doesn't happen on IE6.
 Perhaps the poster was referring to Mozilla, Firebird, or Phoenix?
Reproduced on build 2004030108
Mozilla/5.0 (Windows; U; Win98; en-US; rv:) Gecko/20040301

Confirming and moving to Layout: Tables

terris: Yes, Charles Fenwick was referring to Mozilla and Firefox (formerly
Firebird, and *sigh*, formerly Phoenix).  Because Firefox shares the same Gecko
layout engine as Mozilla, if you run into a layout bug in Firefox, chances are
it affects Mozilla as well.
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Tables
Ever confirmed: true
QA Contact: general → core.layout.tables
I can't find any "Document Literal" link on that page, and I can't make it to
grow the table, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040907
Firefox/0.9.1+

But I see a problem with the page. On first load or shift->reload I see that the
middle column is too wide, which is fixed on a regular reload.
This is a simplified testcase of the bug I described in comment 4.
You should see no horizontal scrollbar in this testcase (but there is), the
table should not be that wide.
I think the I described is more or less the same bug as bug 238856.
the fr.... xul frame returns the previously available width as mew
Attached patch patch (obsolete) — Splinter Review
Robert, should I add the same code the the XUL scroll frame? I don't know when
it is executed.
Blocks: 263594
Assignee: nobody → bernd_mozilla
Yes, add it to the XUL scroll frame. They should stay in sync at this point.
Blocks: 238856
Attachment #161579 - Attachment is obsolete: true
Attachment #161663 - Flags: superreview?(roc)
Attachment #161663 - Flags: review?(roc)
Blocks: 262657
Blocks: 240175
Comment on attachment 161663 [details] [diff] [review]
patch for both frame types

switching reviewer (Robert is busy)
Attachment #161663 - Flags: superreview?(roc)
Attachment #161663 - Flags: superreview?(dbaron)
Attachment #161663 - Flags: review?(roc)
Attachment #161663 - Flags: review?(dbaron)
Keywords: testcase
Is this really the right thing to do for 'auto' width?  Wouldn't this break
something like:

<table width="1" border><tr><td>
  <div style="overflow:hidden">Hello</div>
</td></tr></table>
No the patch does not alter the rendering in this case, you will not see the
"Hello". The rendering is identical to Opera but is different from IE.
Comment on attachment 161663 [details] [diff] [review]
patch for both frame types

r+sr=dbaron, but fix the odd indentation in the new code (one line
over-indented, although you could make both assignments into one, i.e.,
a=b=...)
Attachment #161663 - Flags: superreview?(dbaron)
Attachment #161663 - Flags: superreview+
Attachment #161663 - Flags: review?(dbaron)
Attachment #161663 - Flags: review+
fix checked in
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
*** Bug 238856 has been marked as a duplicate of this bug. ***
*** Bug 262657 has been marked as a duplicate of this bug. ***
*** Bug 263594 has been marked as a duplicate of this bug. ***
*** Bug 244117 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.