Color of text formatted as small caps does not invert when selected

RESOLVED DUPLICATE of bug 290920

Status

()

defect
RESOLVED DUPLICATE of bug 290920
16 years ago
15 years ago

People

(Reporter: sekundes, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8a3 -

Firefox Tracking Flags

(Not tracked)

Details

()

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040219 Firefox/0.8.0+

Mozilla 1.7a only. See testcase.

Reproducible: Always
Steps to Reproduce:
Summary: the color of text didn't invert while hightlighting the text → the color of text didn't invert while hightlighting the text with capitalized letter and small-capitalized letter
To be precise: the selection is white text on blue background until the
selection crosses the boundary between the "T" and "e" from either direction, at
which point it changes to black text on blue background. Not sure whether this
is Selection or Layout: Fonts & Text.
Summary: the color of text didn't invert while hightlighting the text with capitalized letter and small-capitalized letter → the color of text didn't invert while selecting the text with capitalized letter and small-capitalized letter
Reproduced on build 2004030108
Mozilla/5.0 (Windows; U; Win98; en-US; rv:) Gecko/20040301

Moved to Selection
Assignee: general → selection
Status: UNCONFIRMED → NEW
Component: Browser-General → Selection
Ever confirmed: true
Summary: the color of text didn't invert while selecting the text with capitalized letter and small-capitalized letter → Color of text formatted as small caps does not invert when selected
Flags: blocking1.7?
Blocks: 181336
This regressed sometime during the 1.7 cycle. It was working fine in 1.6.
dbaron, any ideas what could cause this?
Flags: blocking1.7? → blocking1.7-
Flags: blocking1.8a2?
Flags: blocking1.8a2? → blocking1.8a2-
Flags: blocking1.8a3?
Flags: blocking1.8a2-
Flags: blocking1.7-
Flags: blocking1.8a3? → blocking1.8a3-
*** Bug 260148 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 290920 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.