make go button look like other toolbar buttons

RESOLVED FIXED in Firefox 2 alpha1

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: miahz, Assigned: miahz)

Tracking

({fixed1.8.1, polish})

unspecified
Firefox 2 alpha1
fixed1.8.1, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

14 years ago
User-Agent:       
Build Identifier: 

bug 187096 suggests that the go button should "physically" be like other toolbar
buttons.  but until then, the current go button can be styled with CSS to look
like the other toolbar buttons in the default theme.

Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 1

14 years ago
Created attachment 142022 [details] [diff] [review]
patch to make go button look like others

this, along with the patch for bug 225088 (go button in icon/text modes),
should have the go button looking and behaving like a normal toolbar button.  a
slight hack was necessary since there's no large mode go icon.	so in large
mode, the button is vertically centered in the toolbar.  all other modes and
states appear as expected.

this also includes a fix for the right-click hover issue mentioned in bug
187096 comment #3
(Assignee)

Comment 2

14 years ago
setting this blocking1.0=?

patch needs to be updated since the new theme - the concept still applies.  i'll
cook one up as soon as i get this new install of 0.9 up and running.
Keywords: polish

Comment 3

14 years ago
Shouldn't this be marked as invalid now since a new theme is being used?

Comment 4

14 years ago
(In reply to comment #3)
> Shouldn't this be marked as invalid now since a new theme is being used?

read comment 2

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

14 years ago
Created attachment 161813 [details] [diff] [review]
patch: make go button look more like other buttons

Somewhere along the way the Go Button was changed from a "button" to a
"toolbarbutton" so that simplified things a bit - other than that, same effect
as previous patch.  This makes the button fill the height of the toolbar like
other normal buttons instead of being a fixed height.  This breaks convention
with IE's Go, but i think it's appropriate since our Go can be placed anywhere
- not just immediately following the address bar.  It also adjusts the label
spacing to that it stays centered and a little more balanced inside the button.
Attachment #142022 - Attachment is obsolete: true
(Assignee)

Comment 6

14 years ago
Created attachment 161814 [details]
screenshot: Go Button - before/after

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars

Updated

12 years ago
Attachment #161813 - Flags: review+
Assignee: nobody → miahzmiahz+bmo
OS: Windows 2000 → All
Hardware: PC → All
mozilla/browser/themes/winstripe/browser/browser.css; new revision: 1.25;
and on the 1.8 branch:
mozilla/browser/themes/winstripe/browser/browser.css; new revision: 1.17.2.12;
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2 alpha1
You need to log in before you can comment on or make changes to this bug.