keyword feature shouldn't trigger if "http://" was included

VERIFIED DUPLICATE of bug 263213

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 263213
14 years ago
12 years ago

People

(Reporter: Singer Wang, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I like the fact that if type a few words in teh address bar Firebat will google
for the words

howerver, I think that if you put in http://word or http://word:8080

it shouldn't google it cause you explicity use http://

this is espically annoying as I have the word jennings in my hosts file for a
certain IP address

I connect to tomcat on that machine with http://jennings:8080

but if the tomcat is down, then it googles the word jennings and takes me to a
page www.waylon.com



Reproducible: Always
Steps to Reproduce:
1. http://anyword
Actual Results:  
takes me to this page

http://www.superlinksoftware.com/cgi-bin/jugwiki.pl?AnyWord



Expected Results:  
since I explicity state http://anyword

it should tell me no such domain exists or whatever.. espically if I have
anyword mapped to a ip in my hosts file and go http://anyword:8080 and no server
is listening on 8080 (cuase it crashed)

Updated

14 years ago
Summary: auto google search for pages → keyword feature shouldn't trigger if "http://" was included
(Reporter)

Comment 1

14 years ago
can we add any https:// as well? in general 

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
REOPEN: incorrect dupe.
Status: RESOLVED → UNCONFIRMED
QA Contact: davidpjames → benc
Resolution: DUPLICATE → ---

Comment 4

14 years ago
I think that when Firefox cannot find the page, it does the google search...I
may be wrong though.

Comment 5

14 years ago
Adding myself to the CC for this bug

Comment 6

14 years ago
It's especially bad when the entry into the location bar is:

http://http//

The result is the Microsoft homepage.

This occurs primarily due to opening a badly formatted link, ie:

http://http//www.uppsala.dk/serieanalys

So the website is really the one at fault here, but the results are not good for
Firefox.

Comment 7

14 years ago
Sounds like a bug to me...Confirming!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

13 years ago
This bug is enjoying press coverage (http://www.theinquirer.net/?article=20046)
and might further enjoy a swift resolution...

Updated

13 years ago
Depends on: 95390
OS: Windows XP → All

Comment 9

13 years ago
This feature should *also* have a pref. to turn it on and off!  Mozilla has (or
had?) one... why not Firefox?

Perhaps that should be a different bug, but... ick.

Comment 10

13 years ago
You mean pref UI? The backend pref (keyword.enable?) should work in firefox.

Comment 11

13 years ago
(In reply to comment #10)
> You mean pref UI? The backend pref (keyword.enable?) should work in firefox.

The backend pref works but - why not something in the Preferences window?  I
would think that this would be something that people would want to change, and
the majority of Firefox/Mozilla users don't know about the backend system (and
wouldn't want to screw with it if they did).

It's a geek vs. Joe User question.

Comment 12

13 years ago
Try to type http://http://mozilla.org in the adress bar, and you are redirected
to microsoft.com!!
I don't think that you guys should let this bug pass the 1.1 release of Firefox.
Flags: blocking-aviary1.1+
blocking+/- flags should be set by drivers only. you may nominate for blocking+ with blocking? (after reviewing of the blockers lists to gauge relative importance, naturally)
Flags: blocking-aviary1.1+ → blocking-aviary1.1?

Comment 14

13 years ago
Entering just 'http' in the navigation bar, or http://http<anything> takes you
to Micro$soft's home page.   There can't be a worse, or more disgusting, bug!

It also appears that MS bribed Google to direct a search on 'http' to their home
page as well, presumably that's what get's triggered by the malformed URL bug.

This *really* needs fixing! 

Updated

13 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 15

13 years ago
This appears to be a dup of bug # 85999.

Comment 16

12 years ago
*** Bug 85999 has been marked as a duplicate of this bug. ***
*** Bug 313408 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 263213 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago12 years ago
Resolution: --- → DUPLICATE

Comment 19

12 years ago
V/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.