Ability to delete search plugins using UI

RESOLVED FIXED in Firefox 2 alpha2

Status

()

enhancement
P1
normal
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: gidsgoldberg, Assigned: Gavin)

Tracking

({fixed1.8.1})

unspecified
Firefox 2 alpha2
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [swag: 0d (work in bug 232272)])

Attachments

(1 attachment, 1 obsolete attachment)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The user shouldn't have to manually delete files to remove search plugins, just
as they shouldn't for extensions. There should be a context menu added to the
search plugins dropdown which offers a Delete option. 
I created this bug because Bug 214528 was marked fixed.


Reproducible: Always
Steps to Reproduce:
this is bug 232272
Yup, I'll bite, good call...

*** This bug has been marked as a duplicate of 232272 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
IMHO no, this bug could be fixed independent of that one. In fact IMHO that
other one might even be WONTFIX (it's suggesting way too much UI) whereas this
bug would just be very simple to fix (e.g. if it worked like we do for
autocomplete).

Reopening and marking as dependent to keep them related.
Status: RESOLVED → UNCONFIRMED
Depends on: 232272
Flags: blocking-aviary2.0?
Resolution: DUPLICATE → ---
This was definitely planned for 2.0, as part of the search interface changes.
Assignee: bugs → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: bugzilla → toolbars
Hardware: PC → All
Version: unspecified → Trunk
Hardware: All → PC
Version: Trunk → unspecified
Yes, but it is desperately needed now, in 1.5, even 1.0 shouldn't have been
shpipped with such a serious design flaw.
It's really hard to believe: Sure, you can add a search engine, but then you'll
have to live with it forever. That is unless you know that you can delete them
on file level and know where they are stored.
I essentially hacked the SearchPluginsHack extension into the source... I
think. This is my first attempt at a patch. I'm not sure if I did it right. I'm
not sure if I've followed exact coding standards or anything really either.
Just an amature MOZ hacker by night and student by day. Please don't kill me if
it sucks.

I know that bigger search enhancements are planned for 2.0, but I was hoping
this could get in for 1.5. Thought maybe I could at least get the ball rolling.
I know I've seen many people disappointed its not in the beta, as they consider
it a bug-fix and not an enhancement. Looking at the proposals in the
search-enhancement bug, I don't think this gets in the way. In fact, it adds a
right click popup for search engines, which seems to be part of the plan, and
doesn't interfere with adding DND or separators later.
oncommand="this.parentNode.parentNode.onEnginePopupCommand(event);"
Adds right click delete

Dang it. Forgot to add a context to the menuitems in the last one. Already I've
begun to err.
Attachment #198276 - Attachment is obsolete: true
Attachment #198277 - Attachment description: @@ -71,7 +71,8 @@ ref="NC:SearchEngineRoot" oncommand="this.parentNode.parentNode.onEnginePopupCommand(event);" Adds right click delete → Add right click delete functionality
Flags: blocking-aviary2? → blocking-aviary2+
Depends on: 317107
No longer depends on: 232272
Assignee: nobody → gavin.sharp
Hardware: PC → All
Target Milestone: --- → Firefox 2 alpha2
Status: NEW → ASSIGNED
Priority: -- → P2
Depends on: 232272
Whiteboard: [swag: 0d (work in bug 232272)]
Priority: P2 → P1
Component: Toolbars → Search
QA Contact: toolbars → search
Fixed in bug 232272.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.