[10.1] Camino crashes on launch (< 10.1.5)

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
15 years ago
15 years ago

People

(Reporter: jnoreiko, Assigned: stuart.morgan+bugzilla)

Tracking

({crash})

unspecified
Camino0.8
PowerPC
Mac OS X
crash

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7a) Gecko/20040113 Camino/0.7+

When I launch Camino (nightly build 28 Feb), the icon appears in the dock,
bounces once, then goes again. The app does not run.
I'm running OS X 10.1

Reproducible: Always
Steps to Reproduce:
1. open Camino

Actual Results:  
icon appears in dock then vanishes again

Expected Results:  
launched! ;)

I found this in the Console app:

dyld: /Applications/Camino (28 Feb).app/Contents/MacOS/Camino Undefined symbols:

/Applications/Camino (28 Feb).app/Contents/MacOS/Camino undefined reference to
___CFConstantStringClassReference expected to be defined in CoreFoundation

Comment 1

15 years ago
In the mozilla1.7a installation guide, 10.2 or more are clearly written as required.
http://www.mozilla.org/releases/mozilla1.7a/installation.html#mac_requirements

Also by Camino which is sharing many same codes as mozilla, I think that this is
applied.
(That is, 10.1 is not supporting the latest nightly build.)

If that is right and that will be told by somewhere, I will think that it is good.
yes, we should still work on 10.1.

on what date did this start happening? can someone run back through nightlies to
check?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Camino crashes on launch → [10.1] Camino crashes on launch
Target Milestone: --- → Camino0.8

Updated

15 years ago
Keywords: crash

Comment 3

15 years ago
At least when bug211462 fixed(Last modified: 2003-10-22 19:14 PST), I think that
it was working by 10.1.

There is one question.
When supporting 10.1, isn't it necessary to set 10.1 as a
MACOSX_DEPLOYMENT_TARGET variable in the environment of Xcode?

Since I do not have 10.1, I cannot check...
(Reporter)

Comment 4

15 years ago
> on what date did this start happening? can someone run back through nightlies to
> check?

My 13 Jan nightly runs on 10.1 (In reply to comment #2)
(Reporter)

Comment 5

15 years ago
I have checked the nightlies on 10.1 and I've found this:

27 jan - works
29 jan - (didn't test) 
31 jan - on launch, displays message "requires at minimum 10.1.5"
1 feb - (didn't test) 
2 feb - same message "requires at minimum 10.1.5"
3 feb - same message "requires at minimum 10.1.5"
6 feb - fails to launch, same as 28 feb

Will 10.1.5 be the minimum for 0.8?

Comment 6

15 years ago
(In reply to comment #5)
> 2 feb - same message "requires at minimum 10.1.5"
> 3 feb - same message "requires at minimum 10.1.5"
> 6 feb - fails to launch, same as 28 feb
> 
> Will 10.1.5 be the minimum for 0.8?

Yes.
http://lxr.mozilla.org/mozilla/source/camino/src/application/MainController.mm#119
bryner, looks like when we landed the new sdk stuff we broke 10.1 support.
didn't you test it? if you have a 10.1 box, can you look into it?
Joachim do you have the same problem with the Mozilla Suite ?
(Reporter)

Comment 9

15 years ago
I've not downloaded a version of Mozilla suite since 1.0. Is there a particular
version or nightly you would like me to try?
take the latest nigthly and try it on your 10.1 machine.

Comment 11

15 years ago
M.o's statement, "All official builds include the Talkback crash reporting
utility, unless otherwise noted," is not true. The Mac 1.7b build does not
include Talkback.
(Reporter)

Comment 12

15 years ago
I have just downloaded Mozilla suite's latest nightly build:

mozilla-mac-MachO.dmg.gz                        19-Mar-2004 12:17   14M 

It appears to run fine on my Mac.
Mike maybe we need to use the 10.1 SDK instead of the 10.2.8 sdk ? Could you 
find the time to set up and build with the 10.1 SDK, mail those 10.1 users so 
they can test it ? 
no, we can't use the 10.1 sdk, it requires an old version of gcc we don't want
to use. we just need to use the 10.2 sdk and be careful about the symbols we
use. something is calling this symbol, we need to find out what.

that's the trick to solving it.
(Assignee)

Comment 15

15 years ago
I've installed 10.1 on a spare partition to work on the 10.1 bugs.

The good news is, Camino still works fine on 10.1.5 (I'm using it right now).
The reported behavior only appears on the original 10.1 for me (and possibly
.1-.4; I didn't bother to test).  Joachim, can you confirm that you are running
something older than 10.1.5?

If this is in fact restricted to < 10.1.5, I think this is more "minor" than
"critical". Obviously, it would be better to show the message saying 10.1.5 is
neccessary, but "Doesn't launch on unsupported systems" isn't really the end of
the world if it's a pain to fix.
yeah, not a beta blocker if they're not running 10.1.5.
Severity: critical → minor
Summary: [10.1] Camino crashes on launch → [10.1] Camino crashes on launch (< 10.1.5)
(Reporter)

Comment 17

15 years ago
(In reply to comment #15)

> The good news is, Camino still works fine on 10.1.5 (I'm using it right now).
> The reported behavior only appears on the original 10.1 for me (and possibly
> .1-.4; I didn't bother to test).  Joachim, can you confirm that you are running
> something older than 10.1.5?

I'm using 10.1.? -- I don't know how to get more precise than that, but I know
it's earlier than 10.1.5 because Software Update keeps telling me to get it! ;)
open terminal aand type sw_vers.

this will show something like :
bleu:~/Documents/sources/cnam ludo$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.3.3
BuildVersion:   7F44
bleu:~/Documents/sources/cnam ludo$ 
(Reporter)

Comment 19

15 years ago
Thanks.
That produces: ProductVersion: 10.1

Comment 20

15 years ago
Stuart, since you have a 10.1 installation, can you step through the revisions
to determine which one fixes the crash? You can still download each updater from
Apple’s site (e.g., <http://docs.info.apple.com/article.html?artnum=120080>).
(Assignee)

Comment 21

15 years ago
I can, but I'd like to tackle the 10.1.5 bugs before worrying too much about
this one.  Re-wiping and upgrading sequentially will be somewhat tedious.  What
do we gain from pinpointing the version, by the way?

(Assignee)

Comment 22

15 years ago
Since this is essentially the next iteration of bug 159273, hopefully we can fix
both at the same time.  Perhaps we should mark it as a dup of this one (since
there's more info here)?

Comment 23

15 years ago
Re: comment 21, basically just a relnote. :)

Joachim, how about you? Since you’re running 10.1 now, how about installing each
minor System update (10.1.1, 10.1.2, etc.) and trying to launch Camino so we can
say which version is required?
(Assignee)

Comment 24

15 years ago
Note that we already know that 10.1.5 is required; all incremental testing will
tell us is which unsupported versions crash, and which unsupported versions give
a dialog saying that OS versions < 10.1.5 are unsupported.
(Reporter)

Comment 25

15 years ago
(In reply to comment #23) 
> Joachim, how about you? Since you’re running 10.1 now, how about installing each
> minor System update (10.1.1, 10.1.2, etc.) and trying to launch Camino so we can
> say which version is required?

I'm a bit confused, as I know for certain I've downloaded updates before with
Software Update, so why does it still say 10.1?
I can try, but how do I do incremental updates? Software Update suggests 10.1.5.
(Assignee)

Comment 26

15 years ago
Forgot to take this with the other 10.1 bugs
Assignee: pinkerton → stuart.morgan
Status: ASSIGNED → NEW
i don't think we can fix this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.