Closed Bug 236000 Opened 18 years ago Closed 17 years ago

Scroll bars for non-visible SELECT element visible

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: mozilla.org, Assigned: bugzilla)

Details

Attachments

(3 files)

User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When viewing a page with a SELECT element that is hidden on the page, the
SELECT's scroll bars appear on the page. I've only seen this happen on OS X, and
Mozilla does not exhibit this behavior on OS X. I wonder if this is some how
related to bug #234830?

Reproducible: Always
Steps to Reproduce:
1. Visit page with a SELECT element that is in a DIV element with visibility set
to hidden.
2.
3.

Actual Results:  
Scroll bars are visible.

Expected Results:  
Scroll bars should not be visible.
The two scroll bars in the middle of the page are from a hidden SELECT form
field.
This screen shot shows the hidden DIV from the previous attachment, just to
show the SELECT elements when rendered visible.
Attached file simple test case
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040221
Firefox/0.8.0+
It reproduced also by Camino.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7b) Gecko/20040228
Camino/0.7+
confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 187435 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.