Last Comment Bug 187435 - Elements (TEXTAREA, IFRAME, DIV, etc.) with visibility:hidden still show scrollbars
: Elements (TEXTAREA, IFRAME, DIV, etc.) with visibility:hidden still show scro...
Status: RESOLVED FIXED
[READ comment 69 before commenting; f...
: classic, pp, testcase
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal with 37 votes (vote)
: ---
Assigned To: Colin Barrett [:cbarrett]
: QA timeless
Mentors:
: 191265 215558 226318 234830 236000 237063 248598 249179 249186 252507 260753 280396 283661 288673 291333 292720 293127 294284 299033 301426 302018 302972 303911 306609 308342 309243 310232 310292 311789 313840 316508 317765 321747 322213 326406 326440 326844 328086 330090 330809 332609 332669 334212 339458 340614 343817 349199 349400 349772 352670 353134 354761 354990 356386 357285 360760 362608 363939 368749 374498 374916 377425 378952 378981 380652 380890 383703 386859 386946 390654 393521 397174 398341 403382 405294 406844 415064 499599 507752 (view as bug list)
Depends on: 209706 370439
Blocks: tibco 306609
  Show dependency treegraph
 
Reported: 2003-01-02 03:50 PST by kph
Modified: 2010-11-23 22:06 PST (History)
114 users (show)
pavlov: blocking1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
scrollbars for hidden block is visible (363 bytes, text/html)
2003-01-02 03:57 PST, Ruslan Ismailov
no flags Details
Revised testcase, removing absolute positioning not necessary to demonstrate problem (434 bytes, text/html)
2003-02-19 16:13 PST, Greg K.
no flags Details
scrollbars hidden div, in mac-firefox 1.0 (67.66 KB, application/pdf)
2005-02-02 16:08 PST, saschal
no flags Details
working patch (diff -w) (14.96 KB, patch)
2005-06-21 11:33 PDT, jhp (no longer active)
no flags Details | Diff | Review
patch (carbon & cocoa) (23.93 KB, patch)
2005-07-28 15:24 PDT, jhp (no longer active)
no flags Details | Diff | Review
recent continued scroll bar corruption in gmail (46.46 KB, image/jpeg)
2005-09-18 11:07 PDT, David Fedoruk
no flags Details
google scroll bar re-appears outside of gmail -- google home pages (150.10 KB, image/jpeg)
2005-11-19 18:28 PST, David Fedoruk
no flags Details
scrollbars apear innapropriately (visible instead of invisible) in blogspont.com (93.45 KB, image/jpeg)
2005-12-05 02:18 PST, David Fedoruk
no flags Details
Hidden scroll bar appear in the middle of blogspot edit sessions (43.94 KB, image/jpeg)
2006-01-14 20:07 PST, David Fedoruk
no flags Details
hidden scroll bars appear in blogspot edit session this time in Deer Park (69.39 KB, image/jpeg)
2006-01-14 23:48 PST, David Fedoruk
no flags Details
Z-index layering with normal visibility - scrollbar bleeds through (213.74 KB, image/png)
2006-02-13 10:08 PST, Shawn
no flags Details

Description kph 2003-01-02 03:50:32 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3b) Gecko/20030101
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3b) Gecko/20030101

The following code produces just scrollbars on a page which is otherwise blank.
It should be totally blank until the Layer is made visible. 

<html>
<head>
<title></title>
</head>
<body>
<div id="Layer1" style="position:absolute; left:99px; top:49px; width:239px;
height:24px; z-index:4; visibility: hidden">
  <form name="form1" >
    <textarea name="HelpText">Some text that is too big for the textarea and
should produce scrollbars when visible.</textarea>
  </form>
</div>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Ruslan Ismailov 2003-01-02 03:57:21 PST
Created attachment 110489 [details]
scrollbars for hidden block is visible
Comment 2 Ruslan Ismailov 2003-01-02 03:58:11 PST
I see blank page on WinXP. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.3b) Gecko/20021230.
Comment 3 Greg K. 2003-02-19 16:13:52 PST
Created attachment 114942 [details]
Revised testcase, removing absolute positioning not necessary to demonstrate problem
Comment 4 Greg K. 2003-02-19 16:16:25 PST
Confirmed using FizzillaMach/2003021903.
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2004-02-25 17:33:43 PST
This worksforme in a current trunk build.  Is this still an issue?
Comment 6 Greg K. 2004-02-26 13:05:04 PST
Problem still evident to me viewing attachment 114942 [details] using
FizzillaMach/2004-02-25-05-trunk and Camino/2004-02-25-08.

Aha, only evident using native form controls (i.e., Classic theme). Not evident
using Mozilla's Modern theme.
Comment 7 Boris Zbarsky [:bz] (Out June 25-July 6) 2004-02-26 13:25:15 PST
Sounds like a mac-only problem, then.  I'm not seeing this on Linux with any
theme (gtk1 build, though, so none of that native theming stuff).
Comment 8 Greg K. 2004-02-26 13:31:40 PST
Simon, Pink, any thoughts on this?
Comment 9 Simon Fraser 2004-02-26 13:50:35 PST
Native form control issue.
Comment 10 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2004-02-26 13:53:58 PST
I wonder whether the problem is the Mac native scrollbar frame not properly
checking its visibility, or the CSS visibility not being inherited properly into
the scrollbar. If the latter I'd expect to see it cross-platform...
Comment 11 Greg K. 2004-03-11 00:42:22 PST
*** Bug 237063 has been marked as a duplicate of this bug. ***
Comment 12 Hiro 2004-03-11 01:10:41 PST
*** Bug 236000 has been marked as a duplicate of this bug. ***
Comment 13 Greg K. 2004-03-11 01:32:51 PST
See also bug 234830.
Comment 14 Cris Mooney 2004-05-14 17:32:11 PDT
Extra confirmation, encountered recently: 

Gecko Mac OSx, contemporary versions tested: 
20040206 (FireFox) 
20030624 (Netscape) 
20040113 (Mozilla) 

Not a problem on Windows versions. 

My problem code (like 236000) for a select "multi" will hide the select box 
contents per the hidden div, but the scroll bar will always show. 

<DIV id="D1" style="visibility:hidden;"> 
<SELECT name="x" size="4" multiple> 
<OPTION value="1">test</OPTION> 
</SELECT> 
</DIV>
Comment 15 Stuart Morgan 2004-06-30 06:12:52 PDT
*** Bug 249186 has been marked as a duplicate of this bug. ***
Comment 16 Stuart Morgan 2004-07-01 21:49:58 PDT
*** Bug 249179 has been marked as a duplicate of this bug. ***
Comment 17 Stuart Morgan 2004-07-01 21:51:41 PDT
*** Bug 248598 has been marked as a duplicate of this bug. ***
Comment 18 Mike Pinkerton (not reading bugmail) 2004-07-22 06:04:07 PDT
*** Bug 252507 has been marked as a duplicate of this bug. ***
Comment 19 Ruud 2004-07-27 05:36:14 PDT
Not surprisingly, this bug also occurs in the latest built of Camino (2004072608). Considering it was 
already reported in January 2003, it looks as if it's not considered an important glitch. A pity, as it 
destroys the looks of our site in a few of the best browsers for OS X...

http://ip30.eti.uva.nl/bis/insecten.php
Comment 20 Ruud 2004-07-29 00:19:33 PDT
Additional comment: to circumvent this Mozilla/Firefox/Camino bug, instead of using visibilty: visible/
hidden, try using display: block/none. For us, this workaround solved the scrollbar bug.
Comment 21 Jon Stevens 2004-07-29 08:05:09 PDT
that workaround breaks in IE. so you end up having to use both methods to get
things to hide show properly.
Comment 22 Frankie 2004-08-25 04:25:40 PDT
*** Bug 226318 has been marked as a duplicate of this bug. ***
Comment 23 Hiro 2005-01-30 02:31:36 PST
*** Bug 280396 has been marked as a duplicate of this bug. ***
Comment 24 saschal 2005-02-02 16:08:07 PST
Created attachment 173226 [details]
scrollbars hidden div, in mac-firefox 1.0
Comment 25 L. H. 2005-02-27 01:05:34 PST
Bug 209706 looks like a dup and has a patch
Comment 26 dolphinling 2005-02-27 05:08:48 PST
*** Bug 283661 has been marked as a duplicate of this bug. ***
Comment 27 Hiro 2005-04-01 13:00:51 PST
*** Bug 288673 has been marked as a duplicate of this bug. ***
Comment 28 José Jeria 2005-04-24 05:28:36 PDT
*** Bug 291333 has been marked as a duplicate of this bug. ***
Comment 29 José Jeria 2005-05-03 05:53:08 PDT
*** Bug 292720 has been marked as a duplicate of this bug. ***
Comment 30 José Jeria 2005-05-06 02:29:19 PDT
*** Bug 293127 has been marked as a duplicate of this bug. ***
Comment 31 Mark Bingley 2005-05-06 02:45:52 PDT
(In reply to comment #21)
> that workaround breaks in IE. so you end up having to use both methods to get
> things to hide show properly.


I have created a workaround for this bug. It is as follows:

First sniff the brower/platform combination and create a variable that is set 
to true if the event occurs.

	var macFirefoxAlert = false;
	if ((is_fx) && (is_mac)){
		macFirefoxAlert = true;
	}

Then query this variable in your page that has the <div> tag element, and set 
it to change the overflow:auto to overflow:hidden as an onload event

<script language="javascript">
	if (macFirefoxAlert){
	document.getElementById('yourDivTagIdGoesHere').style.overflow 
= "hidden";
	}
</script>


Then call one of two functions when you open/close the <div> tag itself, and 
pass the name of the tag over, like this:

var macFirefoxScrollerIs = 'nothing';
function showMacFirefoxScroller(divId){
	if (macFirefoxAlert){
	document.getElementById(divId).style.overflow = "auto";
	macFirefoxScrollerIs = divId;
	}
}

function hideMacFirefoxScroller(){
	if (macFirefoxAlert){
		if (macFirefoxScrollerIs != "nothing"){
		document.getElementById(macFirefoxScrollerIs).style.overflow 
= "hidden";
		macFirefoxScrollerIs = 'nothing';
		}
	}
}

So, when your javascript shows your <div>, it should also call 
showMacFirefoxScroller('yourDivTagIdGoesHere')   and when it closes the <div> 
tag (rehides it again) it should also call  hideMacFirefoxScroller()

Hope you find this useful.
Mark
Comment 32 Simon Fraser 2005-06-21 08:58:51 PDT
*** Bug 191265 has been marked as a duplicate of this bug. ***
Comment 33 Simon Fraser 2005-06-21 08:59:02 PDT
*** Bug 234830 has been marked as a duplicate of this bug. ***
Comment 34 jhp (no longer active) 2005-06-21 11:33:35 PDT
Created attachment 186939 [details] [diff] [review]
working patch (diff -w)

This is a continuation of the work done in Bug 191265.	In that bug, I had the
code mostly working, except I would get extra scrollbars appearing in the upper
left.  I traced this to extra calls of |nsNativeScrollbar::Paint()|.  So I took
bryner's |mInPaint| idea, but applied it the other way:  we only want the
scrollbar to paint in |nsNativeScrollbar::Paint()| if the event has previously
gone through |nsNativeScrollbar::OnPaint()|.  That got rid of the extra
scrollbars I was seeing.

This patch also fixes events, so they don't go to the scrollbars before going
through the view manager.  But I'm not sure if I handled it correctly.	I added
a |handleMouseEvent()| method to |nsINativeScrollbar|.	Then in
nsNativeScrollbar.cpp, I just have that method call |DispatchMouseEvent()|. 
Not sure if that's the best way to do it.

Patch also adds the event handling code to nativescrollbar.xml, to make it
match scrollbar.xml better.  And finally, the painting code in
nsNativeScrollbarFrame.cpp handles invisible DIVs properly.

If someone copied here who has a Mac could also test this patch out, I'd
appreciate it.
Comment 35 jhp (no longer active) 2005-06-21 12:20:55 PDT
*** Bug 215558 has been marked as a duplicate of this bug. ***
Comment 36 Simon Fraser 2005-06-21 18:40:46 PDT
Comment on attachment 186939 [details] [diff] [review]
working patch (diff -w)

With this patch, I'm crashing when clicking on the XUL scrollbars in attachment
186755 [details] of bug 274036. It looks like it's recursing in the scrollbar event
handling code.
Comment 37 Simon Fraser 2005-06-21 19:01:37 PDT
It's unclear to me how we can fix Cocoa scrollbars in the same way here. They
live in the widet hierarchy, so can redraw as a result of Cocoa -display
messages, value changes etc. We can probably hide them to fix this bug, but it's
going to be hard to clip them (for example, the testcase in attachment 113711 [details]).
Comment 38 Simon Fraser 2005-06-21 22:14:06 PDT
Continuing the Cocoa scrollbar thought: I don't see how we correctly clip native
scrollbars (see attachment 113711 [details]) with our current widget hierarchy. The issue
is that Cocoa draws widgets back-to-front, so we redraw the parent widget (which
draws the text of the second <div> in the testcase), and then its children
(which draws the native scrollbars over the text).

The only ways I can see to make this work are:
1. don't use native scrollbars
2. don't leave the native scrollbars in the widget hierarchy, but shove them in
   only when we want to draw them (expensive?)
3. add an extra widget to render the contents of a widget-with-scrollbars, 
   which is a later subview than the scrollbars, so that it renders afterwards.
Comment 39 Mike Pinkerton (not reading bugmail) 2005-06-22 07:31:42 PDT
4. only do drawing when told by gecko. hyatt has a mechanism that they use in
webcore that doesn't draw native widgets immediately when the toolkit says, but
instead routes the draw request through the layout engine so that it gets
clipped/zordered/etc correctly. it's a pain in the ass, but it works.
Comment 40 Simon Fraser 2005-06-22 09:07:02 PDT
(In reply to comment #39)
> 4. only do drawing when told by gecko. hyatt has a mechanism that they use in
> webcore that doesn't draw native widgets immediately when the toolkit says, but
> instead routes the draw request through the layout engine so that it gets
> clipped/zordered/etc correctly. it's a pain in the ass, but it works.

That somewhat kinda like my #2.

I have something like this in my tree right now, but I'm not sure that the views
are being drawn in the right order.
Comment 41 Simon Fraser 2005-06-22 12:19:56 PDT
Webkit (in which this works) actually bypasses the default NSView update
machinery to get around this problem. It rips subviews out of a view before
display, then shoves them back in, while letting KHTML draw the subviews at the
correct time. It does this in a override of a private NSView method, and in such
a way that we can't easily do the same on both 10.2 and 10.3.
Comment 42 jhp (no longer active) 2005-06-24 09:13:47 PDT
(In reply to comment #36)
> It looks like it's recursing in the scrollbar event
> handling code.

Before, the events would come in from |nsWindow| into our
|DispatchMouseEvent()|, which would then pass the events on up the chain, where
they would eventually get dispatched to the rest of Gecko.  Since the events are
now coming in from |nsNativeScrollbarFrame| into |nsNativeScrollbar|, we should
just consume the events and not pass them on.

As for the Cocoa issues, bryner had attached some code in his patch to bug
191265.  Is any of that useful?

Comment 43 jhp (no longer active) 2005-07-28 15:24:32 PDT
Created attachment 190885 [details] [diff] [review]
patch (carbon & cocoa)

This is my previous patch plus bryner's Cocoa changes from bug 191265.	It
makes things better on Camino.	The testcase in this bug correctly shows no
scrollbars.  And the testcase in bug 191265 sometimes draws the scrollbars
below the text.  But there are some drawing issues:  when using the mouse to
scroll, sometimes only the scrollthumb draws (every other part of the scrollbar
becomes white).  Well, you guys know more about Cocoa then I do, so maybe you
can make something out of this.

I also found that if I comment out the [mView enablePainting:NO] line, then
Camino still correctly hides the invisible scrollbars, and the other scrollbars
display properly (no drawing issues).  Of course, we would still have the
problem of scrollbars overpainting DIVs, but I think the most common problem is
that of hidden scrollbars not staying hidden.
Comment 44 Simon Fraser 2005-08-02 09:46:26 PDT
*** Bug 301426 has been marked as a duplicate of this bug. ***
Comment 45 jhp (no longer active) 2005-08-03 09:15:27 PDT
*** Bug 299033 has been marked as a duplicate of this bug. ***
Comment 46 jhp (no longer active) 2005-08-03 09:15:44 PDT
*** Bug 302018 has been marked as a duplicate of this bug. ***
Comment 47 jhp (no longer active) 2005-08-03 09:16:25 PDT
Bug 299033 has a nice testcase, also.
Comment 48 jhp (no longer active) 2005-08-03 09:28:40 PDT
*** Bug 294284 has been marked as a duplicate of this bug. ***
Comment 49 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-08-03 22:34:34 PDT
*** Bug 302972 has been marked as a duplicate of this bug. ***
Comment 50 Adam Guthrie 2005-08-08 21:05:25 PDT
*** Bug 303911 has been marked as a duplicate of this bug. ***
Comment 51 David Fedoruk 2005-08-30 10:42:36 PDT
This is in relation to Bug 302972 which has been marked as a dugpe of this one.
I ccan now reproduce the scroll bar corruption. it occurs when you have used
spell check and returned to edit mode. Some corruption occurs each time. It will
get worse as the text forces scroll bars to appear and get worse if you spell
check multiple times in a longer document.
Comment 52 Uri Bernstein (Google) 2005-09-13 14:09:47 PDT
*** Bug 308342 has been marked as a duplicate of this bug. ***
Comment 53 Andy Rudmik 2005-09-13 14:20:42 PDT
We confirm that this bug has been fixed.
Comment 54 Simon Fraser 2005-09-13 14:44:36 PDT
(In reply to comment #53)
> We confirm that this bug has been fixed.

Please test on Firefox and Camino before marking Fixed.
Comment 55 David Fedoruk 2005-09-18 11:07:28 PDT
Created attachment 196571 [details]
recent continued scroll bar corruption in gmail
Comment 56 Mark Mentovai 2005-09-19 21:06:01 PDT
*** Bug 309243 has been marked as a duplicate of this bug. ***
Comment 57 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-09-27 18:34:27 PDT
*** Bug 310232 has been marked as a duplicate of this bug. ***
Comment 58 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-09-28 04:07:03 PDT
*** Bug 310292 has been marked as a duplicate of this bug. ***
Comment 59 Jasper 2005-10-10 14:09:27 PDT
*** Bug 311789 has been marked as a duplicate of this bug. ***
Comment 60 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-10-25 22:05:14 PDT
*** Bug 313840 has been marked as a duplicate of this bug. ***
Comment 61 José Jeria 2005-11-15 04:31:29 PST
*** Bug 316508 has been marked as a duplicate of this bug. ***
Comment 62 David Fedoruk 2005-11-19 18:28:18 PST
Created attachment 203684 [details]
google scroll bar re-appears outside of gmail -- google home pages

The last few builds have been completely clean, but this appeared today in the nightly 2005111804 (v1.0b1+ This time its not in gmail ... but google's new custom home pages and searches.

df
Comment 63 Erik Fabert 2005-11-25 06:43:26 PST
*** Bug 317765 has been marked as a duplicate of this bug. ***
Comment 64 David Fedoruk 2005-12-05 02:18:34 PST
Created attachment 205021 [details]
scrollbars apear innapropriately (visible instead of invisible) in blogspont.com

2005120304 (v1.0b1+) iBook 1Ghz 640MB Memory OSX 10.3.9,CamiOptions extension.  This happened as I switched editing view in Blogspot. This is the only time it has occured during the few hours I was working on blogSpot.

davidf
Comment 65 A. Rabus 2005-12-17 04:08:31 PST
scrollbars apear innapropriately:
I found a possible reason: 
Its a problem in the Gecko Engine.
Scrollbars of the last layer in the order they appear in the html are always displayed, even if the layer is invisible.
I had this problem in one file (php) an could solve it reproducable with reordering the layers in the html output.
Thsi appeard in Firefox 1.0.x also.
So its a problem with gecko and not camino, i presume.
Comment 66 José Jeria 2006-01-03 12:27:36 PST
*** Bug 322213 has been marked as a duplicate of this bug. ***
Comment 67 David Fedoruk 2006-01-14 20:07:14 PST
Created attachment 208527 [details]
Hidden scroll bar appear in the middle of blogspot edit sessions

2006011404 (v1.0b2+) 1 Ghz iBook, This seems to appear during complex editing sessions where I need to toggle between open application windows
Comment 68 David Fedoruk 2006-01-14 23:48:50 PST
Created attachment 208536 [details]
hidden scroll bars appear in blogspot edit session this time in Deer Park

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060114 Firefox/1.6a1 I attempted editing at blogspot again with a new nightly of Deer Park, the same scroll bar problems appeared in the same place in blog spot. This time I had only one Application window open
Comment 69 Samuel Sidler (old account; do not CC) 2006-01-14 23:54:19 PST
Please do not continually post screenshots and comments that the bug is still valid. This is a known bug and that's why it's open.

If you are not a developer working to fix this bug, please vote for this bug and do not post comments.
Comment 70 jhp (no longer active) 2006-02-08 09:59:43 PST
*** Bug 326406 has been marked as a duplicate of this bug. ***
Comment 71 José Jeria 2006-02-11 16:47:15 PST
*** Bug 326844 has been marked as a duplicate of this bug. ***
Comment 72 Shawn 2006-02-13 09:57:23 PST
Scrollbars of page elements draw above / over / on top of ALL other content
http://www.shawnchin.net/scrollbarTest/
Comment 73 Shawn 2006-02-13 10:08:10 PST
Created attachment 211738 [details]
Z-index layering with normal visibility - scrollbar bleeds through
Comment 74 Adam Guthrie 2006-02-21 13:06:52 PST
*** Bug 328086 has been marked as a duplicate of this bug. ***
Comment 75 Uri Bernstein (Google) 2006-03-11 03:07:07 PST
*** Bug 330090 has been marked as a duplicate of this bug. ***
Comment 76 Stuart Morgan 2006-03-17 07:42:52 PST
*** Bug 330809 has been marked as a duplicate of this bug. ***
Comment 77 Hiro 2006-04-03 23:16:16 PDT
*** Bug 332609 has been marked as a duplicate of this bug. ***
Comment 78 Ria Klaassen (not reading all bugmail) 2006-04-04 03:17:28 PDT
*** Bug 332669 has been marked as a duplicate of this bug. ***
Comment 79 Steven Peterson 2006-04-10 17:30:23 PDT
The simplest workaround for this bug is to set your overlying element to overflow:auto. This will keep scrollbars underneath it from bleeding through. If your element *contains* scrollbars, the easiest way to hide them is to set a class on the element when it's invisible, as such:

.hidden * {
   overflow:hidden;
}

Add this class when the element is hidden, and the scrollbars should go away. I also add this CSS class definition to attempt to be 100% certain that hidden scrolling elements are not displayed:

.hidden textarea, .hidden  select {
   overflow:hidden;
   display:none;
}

A little bit of browser sniffing is useful when applying this class, since this issue only affects Gecko on OSX.
Comment 80 zug_treno 2006-04-16 02:36:38 PDT
*** Bug 334212 has been marked as a duplicate of this bug. ***
Comment 81 jhp (no longer active) 2006-04-20 08:37:14 PDT
*** Bug 321747 has been marked as a duplicate of this bug. ***
Comment 82 jhp (no longer active) 2006-04-20 08:44:50 PDT
Josh, mento, any chance you guys could take a look at the last patch and lend a hand?  You know more about the widgets than I do, and I'm pretty lost in layout.

As I mentioned in comment #43, the patch is working well for hiding scrollbars from 'hidden' DIVs, which seems to be the most common problem.  The hard part is trying to get scrollbars to paint under DIVs.
Comment 83 José Jeria 2006-05-27 15:08:35 PDT
*** Bug 339458 has been marked as a duplicate of this bug. ***
Comment 84 Samuel Sidler (old account; do not CC) 2006-06-06 20:49:19 PDT
*** Bug 340614 has been marked as a duplicate of this bug. ***
Comment 85 Brian Polidoro 2006-07-06 20:29:29 PDT
*** Bug 343817 has been marked as a duplicate of this bug. ***
Comment 86 Adam Guthrie 2006-08-18 18:37:14 PDT
*** Bug 349199 has been marked as a duplicate of this bug. ***
Comment 87 Phil Ringnalda (:philor) 2006-08-20 15:44:33 PDT
*** Bug 349400 has been marked as a duplicate of this bug. ***
Comment 88 Stuart Morgan 2006-08-22 20:56:14 PDT
*** Bug 349772 has been marked as a duplicate of this bug. ***
Comment 89 Stuart Morgan 2006-09-16 12:56:31 PDT
*** Bug 352670 has been marked as a duplicate of this bug. ***
Comment 90 Stuart Morgan 2006-10-01 18:30:45 PDT
*** Bug 354990 has been marked as a duplicate of this bug. ***
Comment 91 Stuart Morgan 2006-10-12 07:59:48 PDT
*** Bug 356386 has been marked as a duplicate of this bug. ***
Comment 92 Phil Ringnalda (:philor) 2006-10-19 11:09:13 PDT
*** Bug 357285 has been marked as a duplicate of this bug. ***
Comment 93 Phil Ringnalda (:philor) 2006-11-14 20:41:15 PST
*** Bug 360760 has been marked as a duplicate of this bug. ***
Comment 94 Masayuki Nakano [:masayuki] (Mozilla Japan) 2006-11-15 13:05:33 PST
*** Bug 353134 has been marked as a duplicate of this bug. ***
Comment 95 hugues.lismonde@gmail.com 2006-11-19 06:39:50 PST
I don't know if it is related but added to this scrollbar bug, it seems that the select box does not report correct clientWidth. It does not include the width of the scrollbar (so when you try to overlay the control, the scollbar is visible and the overlay is too short to hide it).

Tested on firefox 2.0/os x 10.4.8
Comment 96 philippe (part-time) 2006-12-02 16:40:40 PST
*** Bug 362608 has been marked as a duplicate of this bug. ***
Comment 97 Stuart Morgan 2006-12-15 07:41:28 PST
*** Bug 326440 has been marked as a duplicate of this bug. ***
Comment 98 Stuart Morgan 2006-12-15 07:41:43 PST
*** Bug 363939 has been marked as a duplicate of this bug. ***
Comment 99 philippe (part-time) 2007-01-30 15:58:50 PST
*** Bug 368749 has been marked as a duplicate of this bug. ***
Comment 100 Shawn Houser 2007-02-22 09:15:32 PST
For clarity, this bug affects all elements w/scrollbars, visible or not.  Firefox on Mac simply can't display anything overlapping w/scrollbars without them bleeding through (barring occasional remedies like overflow settings that sometimes help).  For anyone trying to create web apps with multiple windows this make the Mac almost unusable w/Firefox.  Forcing all background windows off the screen, etc., is not viable for these types of apps, because it's perfectly valid for windows to overlap each other.  Google this issue and you'll find thousands of frustrated developers.  Just throwing my vote in to humbly beg for attention to this bug.  Thanks much for all you guys do.
Comment 101 Josh Aas 2007-02-22 11:06:26 PST
This should be fixed when bug 370439 lands.
Comment 102 Miles Lane 2007-02-22 11:24:15 PST
(In reply to comment #101)
> This should be fixed when bug 370439 lands.

Is that expected soon?
Comment 103 Samuel Sidler (old account; do not CC) 2007-03-19 11:29:47 PDT
*** Bug 374498 has been marked as a duplicate of this bug. ***
Comment 104 philippe (part-time) 2007-03-22 06:33:27 PDT
*** Bug 354761 has been marked as a duplicate of this bug. ***
Comment 105 philippe (part-time) 2007-03-22 19:22:38 PDT
*** Bug 374916 has been marked as a duplicate of this bug. ***
Comment 106 philippe (part-time) 2007-04-13 17:03:13 PDT
*** Bug 377425 has been marked as a duplicate of this bug. ***
Comment 107 philippe (part-time) 2007-04-26 16:38:00 PDT
*** Bug 378952 has been marked as a duplicate of this bug. ***
Comment 108 Rene Trost 2007-04-26 17:09:47 PDT
This bug affects most XHTTP web applications because all scrollbars (TEXTAREA, IFRAME, SELECT multiple, etc.) shine thru overlaying layers. Reminds me to the old IE <= 6 SELECT-BOX bug.
See OS X 10.4.9 - Gecko/20070309 Firefox/2.0.0.3 examples:
http://www.syncbyte.com/misc/opacitybug.html
http://www.syncbyte.com/misc/opacitybug.png

Hope this bug will be fixed soon
Comment 109 Colin Barrett [:cbarrett] 2007-04-26 21:19:39 PDT
fixed by 370439
Comment 110 Samuel Sidler (old account; do not CC) 2007-04-26 21:24:31 PDT
Per comment 109, this bug will be fixed in Firefox 3. You can download a trunk nightly to test the fix.
Comment 111 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-04-26 22:53:28 PDT
*** Bug 378981 has been marked as a duplicate of this bug. ***
Comment 112 Stuart Morgan 2007-05-16 09:48:26 PDT
*** Bug 380890 has been marked as a duplicate of this bug. ***
Comment 113 Chris 2007-05-22 10:37:36 PDT
The "scrollbar fix" has not been fixed for http://www.thorlabs.com/Navigation.cfm?pageRef=8.
Comment 114 Stuart Morgan 2007-05-22 11:10:08 PDT
Yes it has; you are using branch Camino, and this is a trunk-only fix. This fix won't appear in a released Camino version until Camino 2.0.
Comment 115 Chris 2007-05-22 12:16:16 PDT
(In reply to comment #114)
> Yes it has; you are using branch Camino, and this is a trunk-only fix. This fix
> won't appear in a released Camino version until Camino 2.0.
> 

Sorry I didn't understand that.  I just used the most recent night build to test it.  Thanks.
Comment 116 philippe (part-time) 2007-06-08 00:31:36 PDT
*** Bug 383703 has been marked as a duplicate of this bug. ***
Comment 117 Adam Guthrie 2007-07-05 11:34:56 PDT
*** Bug 386946 has been marked as a duplicate of this bug. ***
Comment 118 Adam Guthrie 2007-07-05 11:39:01 PDT
*** Bug 386859 has been marked as a duplicate of this bug. ***
Comment 119 Glen 2007-07-19 06:35:43 PDT
Does not seem to be working?

http://bustophersbarbistro.co.uk/restaurant

Tried in:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

Can't tell from here what version the Trunk is - maybe you want to put that up there this is not the latest version - not a developer so not downloaded nightly builds thankyou

Comment 120 Colin Barrett [:cbarrett] 2007-07-19 07:08:20 PDT
(In reply to comment #119)
> Does not seem to be working?
> 
> http://bustophersbarbistro.co.uk/restaurant
> 
> Tried in:
> 
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.5)
> Gecko/20070713 Firefox/2.0.0.5
> 
> Can't tell from here what version the Trunk is - maybe you want to put that up
> there this is not the latest version - not a developer so not downloaded
> nightly builds thankyou

This fix will be in Firefox 3. It won't be in any of the Firefox 2 releases, so you'll have to wait until Firefox 3 is out.
Comment 121 Adam Guthrie 2007-08-02 10:13:24 PDT
*** Bug 390654 has been marked as a duplicate of this bug. ***
Comment 122 philippe (part-time) 2007-08-24 18:50:42 PDT
*** Bug 393521 has been marked as a duplicate of this bug. ***
Comment 123 philippe (part-time) 2007-10-03 01:47:35 PDT
*** Bug 398341 has been marked as a duplicate of this bug. ***
Comment 124 philippe (part-time) 2007-11-06 16:15:04 PST
*** Bug 402786 has been marked as a duplicate of this bug. ***
Comment 125 Stuart Morgan 2007-11-11 08:11:37 PST
*** Bug 403382 has been marked as a duplicate of this bug. ***
Comment 126 philippe (part-time) 2007-11-25 05:06:12 PST
*** Bug 405294 has been marked as a duplicate of this bug. ***
Comment 127 philippe (part-time) 2007-12-04 19:03:42 PST
*** Bug 406844 has been marked as a duplicate of this bug. ***
Comment 128 José Jeria 2008-01-31 06:14:27 PST
*** Bug 415064 has been marked as a duplicate of this bug. ***
Comment 129 Smokey Ardisson (offline for a while; not following bugs - do not email) 2008-12-02 13:11:05 PST
*** Bug 306609 has been marked as a duplicate of this bug. ***
Comment 130 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-06-21 18:42:00 PDT
*** Bug 499599 has been marked as a duplicate of this bug. ***
Comment 131 Stuart Morgan 2009-07-31 17:50:34 PDT
*** Bug 507752 has been marked as a duplicate of this bug. ***
Comment 132 Markus Stange [:mstange] [away until June 27] 2009-08-02 21:26:20 PDT
*** Bug 397174 has been marked as a duplicate of this bug. ***
Comment 133 Kevin Brosnan 2009-09-15 09:06:02 PDT
*** Bug 380652 has been marked as a duplicate of this bug. ***
Comment 134 Wayne Mery (:wsmwk, NI for questions) 2009-12-07 05:13:10 PST
*** Bug 260753 has been marked as a duplicate of this bug. ***
Comment 136 Monte Hill 2010-09-25 11:24:52 PDT
Comment on attachment 173226 [details]
scrollbars hidden div, in mac-firefox 1.0

I'm not sure if this is the same thing but my scroll bar doesn't show up in Yahoo eMail's upper box, but it does in gmail and the lower Yahoo email box.

Note You need to log in before you can comment on or make changes to this bug.