first-letter should include initial punctuation

RESOLVED FIXED in Future

Status

()

Core
Layout: Text
P3
normal
RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: dbaron, Assigned: mats)

Tracking

(Depends on: 2 bugs, {css1, testcase})

Trunk
Future
css1, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-2.4], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
DESCRIPTION:  According to CSS2, section 5.12.2, "Punctuation (i.e, characters
defined in Unicode [UNICODE] in the "open" (Ps), "close" (Pe), and "other" (Po)
punctuation classes), that precedes the first letter should be included" in the
first-letter pseudo-element.  Currently this seems to be happening only for
quotation marks.  What really needs to happen is access of some Unicode
character database (which hopefully exists in some i18n code somewhere).

However, there are some problems with this.  In particular, if there is a
start-tag somewhere in the middle of the "first letter" (including the
punctuation), I'm not sure what to do, since I don't see a way to keep a tree
structure (which is clearly necessary).  I just suggested on www-style that in
such a case, the first-letter should not be drawn.  See
http://lists.w3.org/Archives/Public/www-style/2000Jan/0017.html for my post and
links to any replies.

STEPS TO REPRODUCE:
 * load attached test case

ACTUAL RESULTS:
 * In cases 1 and 5, only the first character is large and red.
 * In case 2, correctly, the first two characters are large and red.
 * In cases 3 and 4 I'm not seeing the initial characters because of bug [I
can't find the number.  I hope it's filed], and nothing is large and red.
 * In case 6, the first two characters are large and red.

EXPECTED RESULTS:
 * In cases 1-4, the first two characters should be large and red.
 * Case 5 is undefined, as I mentioned above.
 * In case 6, (I think!!) the first 4 characters should be large and red.

DOES NOT WORK CORRECTLY ON:
 * Linux, mozilla, 2000-01-10-08-M13

ADDITIONAL INFORMATION:
Alan Flavell pointed this bug out to me.
(Reporter)

Comment 1

18 years ago
Created attachment 4119 [details]
test case described in bug report

Updated

18 years ago
Assignee: troy → kipp

Comment 2

18 years ago
Block/inline issue so assigning to Kipp's bug list
(Reporter)

Comment 3

18 years ago
See Bert Bos's reply to my message:
http://lists.w3.org/Archives/Public/www-style/2000Jan/0019.html

Updated

18 years ago
Target Milestone: M15

Comment 4

18 years ago
mass-moving bugs to M15
Summary: first-letter should include initial punctuation → {css1} first-letter should include initial punctuation
See also this incomplete test page:
   http://www.bath.ac.uk/%7Epy8ieh/internet/eviltests/pseudoelements1.html
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...

Updated

18 years ago
Summary: {css1} first-letter should include initial punctuation → first-letter should include initial punctuation

Comment 7

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster

Comment 8

18 years ago
moving all buster m15 bugs to m16.
Target Milestone: M15 → M16

Comment 9

17 years ago
first-letter bug fixes will be post beta
Status: NEW → ASSIGNED
Target Milestone: M16 → M18

Comment 10

17 years ago
redistributing bugs across future milestones, sorry for the spam
Target Milestone: M18 → M19

Comment 11

17 years ago
This bug has been marked "future" because we have determined that it is not 
critical for netscape6.0. 
If you feel this is an error, or if it blocks your work in some way -- please 
attach your concern to the bug for reconsideration.
Target Milestone: M19 → Future
Summary: first-letter should include initial punctuation → first-letter should include initial punctuation [INLINE]
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
Keywords: mozilla1.0
QA Contact: petersen → ian
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Status: ASSIGNED → NEW
Whiteboard: [CSS1-2.4]

Comment 14

15 years ago
Confirmed using FizzillaCFM/2002070913. Cases 1, 3, 4, and 5 only apply the
first-letter style to the first, punctuation character. In case 2 it's applied
to both the inch mark and the capital T. In case 6 it's applied to the inch and
foot marks, but not the capital T. Setting All/All.
OS: Linux → All
Hardware: PC → All

Comment 15

15 years ago
Should this be marked as a duplicate of Bug 54467? It is the exact same bug, and
although was opened later, it has a patch attached (which appears to be stalled
awaiting benchmark tests).
(Reporter)

Comment 16

15 years ago
*** Bug 187000 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
Using FizzillaMach/2002122307, it appears bug 54467's fix has addressed some of
the tests in attachment 1 [details] [diff] [review], but not all. Specifically, examples 1 and 4 now work
correctly, but examples 3, 5, and 6 still don't.

Comment 18

15 years ago
Rather, make that attachment 4119 [details].)
->Fonts & Text, and cc'ing Shanjian, who created the patch for the related bug.
Component: Layout → Layout: Fonts and Text
(reassign)
Assignee: attinasi → font
(Assignee)

Updated

14 years ago
Depends on: 45091

Updated

14 years ago
Keywords: mozilla1.0
Summary: first-letter should include initial punctuation [INLINE] → first-letter should include initial punctuation

Comment 21

13 years ago
Isn't this bug related (or even overlapping) bug 52109, bug 92176 and bug 54467 ?

Updated

13 years ago
Depends on: 52109, 54467, 92176

Comment 22

13 years ago
the fix for bug 54467 had been broken between Mozilla 1.3.1 and 1.4.
it might be a regression by Bug 180266.
(Assignee)

Updated

13 years ago
Assignee: core.layout.fonts-and-text → mats.palmgren

Updated

12 years ago
No longer depends on: 52109
(Reporter)

Comment 23

12 years ago
There are some relevant patches on bug 45091 (and bug 328111).
Fixed by new text frame All the cases in the testcase currently work except for the undefined case 5. 
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 367177
Flags: in-testsuite?
Resolution: --- → FIXED

Updated

10 years ago
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.