::first-letter pseudo-element should consider both characters within letter combinations like the Dutch "ij"

NEW
Unassigned

Status

()

Core
Internationalization
--
minor
16 years ago
3 months ago

People

(Reporter: Shanjian Li, Unassigned)

Tracking

(4 keywords)

Trunk
Future
css1, css2, dev-doc-needed, helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This is a problem split from 54467. 
As CSS specs 5.12.2 metioned :
   "Some languages may have specific rules about how to treat certain letter 
combinations. In Dutch, for example, if the letter combination "ij" apprears at 
the beginning of a word, both letters should be considered within the 
:first-letter pseudo-element."
   Should we include those situations? I doubt if anyone will list a lot of such 
examples. Even to include above mentioned example is rather difficult, because 
we have to know what language it is. (Encoding normally is easier to get. )
(Reporter)

Comment 1

16 years ago
It is not clear either we want to implement this or not. But anyway, I don't see 
any solution in near future. 
Target Milestone: --- → Future
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
This bug belongs to Internationalization, like bug 54467.

i18n folks need to identify the combinations of letters that should be considered 
as a single letter, and the language in which they occur, then extend the patch 
crafted by Shanjian in bug 54467 keeping in mind that the :first-letter pseudo 
can in fact cover up to 3 characters (1 punctuation sign + 2 letters).

Comment 3

16 years ago
reassining to the correct core and core owner.
Assignee: karnaze → yokoyama
Component: Layout → Internationalization
QA Contact: petersen → teruko

Comment 4

16 years ago
-> shianjian
Assignee: yokoyama → shanjian
(Reporter)

Comment 5

16 years ago
accepting
Status: NEW → ASSIGNED
Whiteboard: [CSS1-2.4]

Updated

13 years ago
Keywords: css1, helpwanted
QA Contact: teruko → ian

Updated

13 years ago
Blocks: 23605

Comment 6

13 years ago
Apparently, \u0132 en \u0133 are the Unicode characters for the Dutch "ij".
Could this be resolved as WONTFIX now there are characters for this? (I will
bring this up at www-style.)
Assignee: shanjian → nobody
Status: ASSIGNED → NEW

Updated

13 years ago
Keywords: css2
Summary: Dutch "ij" in the :first-letter pseudo-element" should both in first letter style → Dutch "ij" in the ::first-letter pseudo-element should both in first letter style
Whiteboard: [CSS1-2.4]

Comment 7

13 years ago
In most cases ij or IJ isn't seen as one character in Dutch and in most
publications it isn't treated as such. I doubt whether the single character
unicode values for ij/IJ are ever used in Dutch publications at all.

Some Dutch references on the usage of ij can be found on:

http://taalunieversum.org/taal/advies/vraag/1194/
http://taalunieversum.org/taal/advies/vraag/1188/

Comment 8

13 years ago
Seeing popular use and the very limited support of the unicode signs it doesn't
make sense to not support it. Although it has been tried to get computers to see
it as one character before (Dutch DOS character set and keyboards had it as a
single sign), no one actually uses it. It is not even auto converted for in most
popular wordprocessors.
QA Contact: ian → i18n
Keywords: dev-doc-needed
Corrected the summary.
Also, that's already documented https://developer.mozilla.org/en-US/docs/Web/CSS/::first-letter.

Sebastian
Keywords: dev-doc-needed → dev-doc-complete
Summary: Dutch "ij" in the ::first-letter pseudo-element should both in first letter style → ::first-letter pseudo-element should consider both characters within letter combinations like the Dutch "ij"
Sebastian: doesn't this mean that this is a duplicate of another bug? (meaning it should be RESOLVED DUPLICATE or RESOLVED WORKFORME)
I couldn't find any other bug related to this. And it is also not implemented yet.
What is done is the documentation of the feature according to the specification (though no browser seems to support this yet). FWIW I added a test case in the URL field.

Maybe I was too hasty, as the browser compatibility table still needs to be updated once this bug is fixed. Should the keyword be changed back to dev-doc-needed?

Sebastian
Keywords: dev-doc-complete → dev-doc-needed
Yep, that we update Fx XY for devs and the compat table when this lands :-)
You need to log in before you can comment on or make changes to this bug.