<applet>, <embed>, <object> does not draw CSS borders when embedding plugin

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: cstehlin.ml, Unassigned)

Tracking

({testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

trying to set a border around an <embed> gives no result, and so on for any kind
of style.

Reproducible: Always
Steps to Reproduce:
see attached files : the grey zone should be surrounded by a border.
Posted file swf
Posted file test case
Useable test case
Attachment #142665 - Attachment is obsolete: true
Resummarizing to talk about the real problem.  See the comment at
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsObjectFrame.cpp&rev=1.442#937
Assignee: dbaron → nobody
Status: UNCONFIRMED → NEW
Component: Style System (CSS) → Layout
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: ian → core.layout
Hardware: PC → All
Summary: <embed> does not take CSS rules into account → <embed>, <object> does not draw CSS borders when embedding plugin
Keywords: testcase
QA Contact: core.layout → ian
*** Bug 264566 has been marked as a duplicate of this bug. ***
In this webpage, the border is drawn. But drawn in a wrong way:
http://blog.cs.cityu.edu.hk/users/50307104/fyp/livepad-0.1-about-window.xhtml
*** Bug 305213 has been marked as a duplicate of this bug. ***
Summary: <embed>, <object> does not draw CSS borders when embedding plugin → <applet>, <embed>, <object> does not draw CSS borders when embedding plugin
Found a dupe: Bug 311147
*** Bug 321682 has been marked as a duplicate of this bug. ***
*** Bug 311147 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 407534
Duplicate of this bug: 441522
QA Contact: ian → layout
This bug is long fixed?
Bug still occurs for me when using an embed tag inside an object tag.
Attachment #487108 - Attachment is obsolete: true
This is probably well known, anyway:

Borders are drawn in current trunk versions (for example Gecko/20110131 Firefox/4.0b11pre), but both borders and paddings are wrongly "subtracted" from the object size (as in the "border-box" box-sizing model), I created an attachment to show this.
All attached test cases work in Firefox 57 Nightly, so it was fixed sometime in the last 7 years.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.