Firefox does not save Bookmarks in the Main Folder by Default

VERIFIED DUPLICATE of bug 232467

Status

()

Firefox
Bookmarks & History
VERIFIED DUPLICATE of bug 232467
15 years ago
12 years ago

People

(Reporter: pagan716, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Firefox does not save Bookmarks by Default in the Main Bookmark Folder. By
Default it saves them in the Bookmarks Toolbar Folder ; If I change this the
default location for Bookmarks after the next restart of Firefox is again
Toolbar Folder. 
Firefox remembers to use custom created folders, the problem applies only to the
main folder. See also :

http://forums.mozillazine.org/viewtopic.php?p=408211#408211

Reproducible: Always
Steps to Reproduce:
1. Add to Bookmarks - current default save location Toolbar Folder
2. Create in Bookmarks 
3. Restart Firefox 
4. Add to Bookmarks - points to the Bookmarks Toolbar Folder again

Comment 1

15 years ago
Confirming this bug. Firefox will always use the last folder that a bookmark was
saved in as the default, unless Firefox has been restarted and the last folder
was the main Bookmarks folder, in which case, it will default to the folder last
saved in before that.

We should probably implement something like the following:

+ Within browing session
  - It defaults to the last folder that a bookmark was saved in.

+ Per restart of Firefox
  - Always default to main Bookmarks folder at start of session.

I think this is a pretty sensible behaviour.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Firefox does not save Bookmarks in the Main Folder by Default → Firefox does not save Bookmarks in the Main Folder by Default

Comment 2

15 years ago
what about bug 232467
yes, this is really a dupe (same behaviour, needs review/clarification)

*** This bug has been marked as a duplicate of 232467 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
v
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.