crash after a middle-click and accidentaly scrolling at the same time

RESOLVED DUPLICATE of bug 234966

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 234966
14 years ago
14 years ago

People

(Reporter: Ethan Hawthridge, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

There is that irritating bug that has't been coreccted from the first releases
of multi-tabbed Mozilla.
Well, I'm using a subproduct developed from greatM called Phoenix (hm,
Firebird-Firefox) since V.0.5 (based on 1.3a I think) all to nowadays Firefox,
still there he residues.
Many times when I'm opening a new tab with mouse middle-click I accidentaly
scroll down in the same tab where I take this action and inevitable happens ...
a Phoenix crashes down. Same thing happens if you first middle-click over the
link and then very quickly after that (300ms, accidentally) somewhere else on
the page when it's been opened that small navigator-cursor and page starts
autoscroll which again results with crash. And since M-engine must be properly
closed (You can't even restart windows when it's running!) next time i run it it
cleares (thankfully since 0.6 I think) all cache contents.
So could you also (if it's only a minor intervention) somehow enable to re-input
that cached materials into brovsers .MAP files i think instead of just deleting
it, and maybe in Mozilla V.2 even allow user to export cache if he wants that.


Reproducible: Always
Steps to Reproduce:
First of all I don't try that it just happens even with freshly started browser
if I'm lucky ;-(
1. Open enough tabs (and close even more of them cause Mozilla doesn't
unallocates/clears paged memory) and you don't leave them much 4...7
2. Try to open a link with a middle click
3. Accidentaly scroll with a middle button (you need a sensitive old mouse (at
least 1.5 yrs) not the one you must push while scrolling and listen these
annoying clicking)


Actual Results:  
Rosht-rosht and application is crashed with that idiotic Send an error report to
Msh..

Expected Results:  
Open a new tab and stay alive

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 234966 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.