Default outgoing SMTP server is not used (but the first on the list)

RESOLVED DUPLICATE of bug 223031

Status

MailNews Core
Networking: SMTP
RESOLVED DUPLICATE of bug 223031
14 years ago
9 years ago

People

(Reporter: Tapsa, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219

It is useless configure multiple outgoing SMTP servers (Edit->Mail&Newsgroup
account settings->Outgoing Server (SMTP)->Advanced) because eventhough you set
one as default server it does not make any difference because Mozilla Mail uses
the first on the list every time.

This bug has been there for a long time and it is annoying when plugging my
laptop into different networks - I always have to rewrite the server name.

Reproducible: Always
Steps to Reproduce:
1. Set multiple outgoing SMTP servers so that the first server address on the
list (the upmost one) is invalid
2. Send email and try to set other SMTP servers as the default server
(Edit->Mail&Newsgroup account settings->Outgoing Server (SMTP)->Advanced)
3. Every time Mozilla tries to send the email through the invalid server

Comment 1

14 years ago
The default outgoing server is used when the account is configured to use it.
Does Mail & Newsgroups Account Settings / Account / Server Settings / Advanced
show a specific server or "Always use default server"?

Comment 2

14 years ago
In the "Advanced Outgoing Sever (SMTP) Settings" dialogue box, NO matter which
SMTP server is set default, always the first/top SMTP server in the list is
used. Fail as a different ISP is used.

Comment 3

14 years ago
But as I wrote, the important thing is what's selected in "Mail & Newsgroups
Account Settings / Account / Server Settings / Advanced".

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 223031 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.