Last Comment Bug 236613 - Relicense Mozilla code to MPL/LGPL/GPL tri-license
: Relicense Mozilla code to MPL/LGPL/GPL tri-license
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Licensing (show other bugs)
: other
: All All
: P1 major (vote)
: ---
Assigned To: Frank Hecker
: Gervase Markham [:gerv]
:
Mentors:
: 250813 264877 (view as bug list)
Depends on: 257264 276042 408238
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-05 14:24 PST by Gervase Markham [:gerv]
Modified: 2009-03-04 10:03 PST (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Gervase Markham [:gerv] 2004-03-05 14:24:49 PST
This bug tracks the relicensing of Mozilla code to MPL/LGPL/GPL. There won't be
a separate bug for each checkin - all checkins will reference this bug, which is
here to say that gerv@mozilla.org is the person to talk to/complain to if there
are any issues at all with the relicensing.

Gerv
Comment 1 Dean Tessman 2004-04-17 15:08:05 PDT
* Alternatively, the contents of this file may be used under the terms of 
* either the GNU General Public License Version 2 or later (the "GPL"), or
* the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),

changed to:

* Alternatively, the contents of this file may be used under the terms of 
* either of the GNU General Public License Version 2 or later (the "GPL"),
* or the GNU Lesser General Public License Version 2.1 or later (the "LGPL"),

Adding the second "of", after "either" worsened the grammar.
Comment 2 Gervase Markham [:gerv] 2004-04-17 15:38:49 PDT
Fair point. I noticed that as I was hand-checking the diffs, but didn't think it
was worth fixing. I've now changed my mind, and fixed it - the rest will be
better. Thanks :-)

Gerv
Comment 3 tor 2004-04-19 08:45:38 PDT
Why did you change the wording of the licensing?  That's the sort of thing
legal people need to sign off on.
Comment 4 Gervase Markham [:gerv] 2004-04-19 09:50:37 PDT
The wording in question is part of the "blank" part of the MPL
multiple-licensing terms, and so there's no document stating what it should be.
Legally, both look like they mean the same to me; it's just one is better
grammar than the other.

Gerv
Comment 5 David Baron :dbaron: ⌚️UTC-10 2004-08-25 19:07:10 PDT
Today's checkin broke the DOM2TextConversionTest that's run on some tinderbox
builds because it changed the formatting around the license on some of the files
used in the test (in parser/htmlparser/tests/outsinks/).  I think I fixed it,
but tinderbox needs to cycle.
Comment 6 Steffen Wilberg 2004-10-19 04:05:09 PDT
*** Bug 264877 has been marked as a duplicate of this bug. ***
Comment 7 Alex Vincent [:WeirdAl] 2004-11-26 23:11:31 PST
Please note bug 271959. :)
Comment 8 Simon Montagu :smontagu 2004-12-09 00:53:51 PST
Please take more care not to modify generated files without modifying the
scripts that generate them. The last checkin to 
intl/unicharutil/tables/transliterate.properties even removes the lines

# THIS FILE IS GENERATED BY mozilla/intl/unicharutil/tools/gentransliterate.pl
# PLEASE DO NOT MODIFY THIS FILE BY HAND
Comment 9 Gervase Markham [:gerv] 2004-12-10 14:25:26 PST
smontagu: apologies. I will be more careful in future.

Gerv
Comment 10 Alex Vincent [:WeirdAl] 2005-07-15 11:38:56 PDT
Will there be similar relicensing done on the 1.7.x stable branch?
Comment 11 Gervase Markham [:gerv] 2005-07-15 12:05:50 PDT
No, it's not planned. When and if we finish the tip, we can look at the case for
it. Is there some particular reason you want it?

Gerv
Comment 12 Alex Vincent [:WeirdAl] 2005-07-15 12:13:35 PDT
Our (ManyOne) corporate product is based on Beonex and Mozilla 1.7.7, and
there's a pretty high chance we'll migrate to a pure Mozilla 1.7.9 or later once
I figure out the details needed to do that.  (That sounds easy, but there are
various issues I have to work out...)  We're doing a release RSN, and probably a
milestone update ASAP after that.
Comment 13 Gervase Markham [:gerv] 2005-07-15 12:24:20 PDT
Right... and what does that have to do with relicensing?

Gerv
Comment 14 Alex Vincent [:WeirdAl] 2005-07-15 12:30:20 PDT
*shrug*  If you don't think that merits relicensing, that's fine.  I just wanted
to make sure that the code we're releasing is properly licensed; I'll defer to
your decision on that.
Comment 15 Gervase Markham [:gerv] 2005-07-15 12:37:21 PDT
Alex: be more clear! :-)

You've said that you, like several other companies, are releasing a product from
the 1.7.x branch. You have not yet said how the relicensing affects that product
release in any way whatsoever. Do you want to release the product under the GPL,
for example?

Do note the _re_ in relicensing - the Mozilla code is correctly licensed now,
and will be after we've finished, and at all stages during the process.

Gerv
 
Comment 16 Reed Loden [:reed] (use needinfo?) 2006-02-13 13:33:31 PST
--> Licensing
Comment 17 Steffen Wilberg 2006-02-22 01:18:24 PST
*** Bug 250813 has been marked as a duplicate of this bug. ***
Comment 18 Steffen Wilberg 2006-03-31 00:47:11 PST
Uh, I guess you shouldn't replace "#filter substitution" by "'filter substitution" here: http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/app&command=DIFF_FRAMESET&file=application.ini&rev1=1.1&rev2=1.2&root=/cvsroot
Comment 19 Gervase Markham [:gerv] 2006-03-31 00:51:37 PST
Ah - is that a preprocessor command rather than a comment? Well, you can understand why I got confused :-) Thanks for the tip-off. I'll fix it.

Gerv
Comment 20 Gervase Markham [:gerv] 2006-03-31 00:53:16 PST
I've reverted that change. Thanks again :-)

Gerv
Comment 21 Samuel Sidler (old account; do not CC) 2007-12-13 12:51:49 PST
The changes to the following files are going to be backed out and re-landed in bug 408238. Commenting here so it will be clear for the person re-landing the changes.

From 2007-02-14 08:58:
  mozilla/embedding/browser/gtk/src/EmbedFilePicker.cpp 
  mozilla/embedding/browser/gtk/src/EmbedFilePicker.h 
  mozilla/embedding/browser/gtk/src/EmbedPasswordMgr.cpp 
Comment 22 Gervase Markham [:gerv] 2009-03-04 10:03:20 PST
Is this still open? Fixed :-)

Gerv

Note You need to log in before you can comment on or make changes to this bug.