A more useful set of context menu options for the toolbars

RESOLVED DUPLICATE of bug 880164

Status

()

Firefox
Toolbars and Customization
P3
enhancement
RESOLVED DUPLICATE of bug 880164
15 years ago
4 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Per the leading authority in customizable toolbars, context menus for
customizable items should read:

    Icons and Text
(*) Icons 
    Text
 ------------------
[x] Use Small Icons
 ------------------
    Remove Item
    Customize Toolbar...
Created attachment 143363 [details] [diff] [review]
partial work

this doesn't work properly yet, specifically:

- hitting "use small icons" twice in a row does not restore state
- remove item is not implemented yet
- customize... is mysteriously disabled sometimes.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Firefox1.0beta
Severity: normal → enhancement
Flags: blocking1.0+
Target Milestone: Firefox1.0beta → Firefox1.0
Flags: blocking-aviary1.0RC1+
Assignee: bugs → sspitzer
Status: ASSIGNED → NEW
Flags: blocking-aviary1.0RC1-
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0-
Flags: blocking-aviary1.0+
I whish those functions would be somewhere where they can be shared between
toolkit apps, instead of copied.
And the same for the menu items.

Updated

13 years ago
Assignee: sspitzer → nobody
QA Contact: bugzilla → toolbars
Target Milestone: Firefox1.0 → ---
Created attachment 270625 [details] [diff] [review]
works correctly, only tested on Mac, doesn't add Remove Item (yet)

this hits a weird crash, to be filed separately, in re-resolving style...
Assignee: nobody → mconnor
Status: NEW → ASSIGNED

Updated

11 years ago
Depends on: 386642
I tried to compile a debug build from cvs today on Mac OS but Firefox crashes before the profile manager comes up. I have to wait for a working version and will try it again within the next days.
Mike, after bug 386642 is fixed now I wanted to test your patch but it is bitrotted meanwhile. Can you supply an updated version?
Created attachment 337805 [details] [diff] [review]
unbitrotted

I don't know if I want Remove Item, tbh.  Let's do this for now and see how it feels.  Figured I should finally unbitrot this...
Attachment #143363 - Attachment is obsolete: true
Attachment #270625 - Attachment is obsolete: true
Attachment #337805 - Flags: ui-review?(beltzner)
Attachment #337805 - Flags: review?(gavin.sharp)
Beltzner, could you please have a look at mconnors patch?
Whiteboard: [needs ui-review beltzner]
Attachment #337805 - Flags: ui-review?(beltzner) → ui-review+

Updated

10 years ago
Whiteboard: [needs ui-review beltzner] → [needs review gavin]

Updated

9 years ago
Whiteboard: [needs review gavin] → [has patch][needs review gavin]
Flags: wanted-firefox3.6?
Version: unspecified → Trunk
Comment on attachment 337805 [details] [diff] [review]
unbitrotted

This bit rotted. Noticed a minor bug in onViewToolbarsPopupShowing:

+  if (!toolboxMode)
+    toolbox.getAttribute("defaultmode");

Also don't really like the code duplication, isn't there a way to avoid that?
Attachment #337805 - Flags: review?(gavin.sharp)

Updated

8 years ago
Assignee: mconnor → nobody
Flags: wanted-firefox3.6?
Whiteboard: [has patch][needs review gavin]
The Firefox 29 customization improvements (part of "Australis") added the move/remove context menu items.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 880164
You need to log in before you can comment on or make changes to this bug.