Download Manager defaults to "Desktop"

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
RESOLVED WONTFIX
14 years ago
9 years ago

People

(Reporter: Kevin Ar18, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+

The current behavior to default to the "desktop" for file downloads is
detrimental for a number of reasons.  I am proposing that we change this behavior.

Problem:
For power users, they will want to select their own location for downloads.  By
defaulting to the "desktop," you are never giving power users a chance to do
this.  Instead they have to wade through settings to get it to work, and some
may never get around to checking out the options section.  Also, for people
installing on multiple computers (or installing many times on the same
computer), the more you have to configure Firebird, the more trouble it is.
For new users, this is a problem because it disassociates the file download
process from the saving process.  The user never understands where his file
went.  As a result, he is confused as to what happend to his files.  This is a
very, very serious issue when migrating to Firebird!
For new users, this method will also clutter their desktops; there are quite a
few people that will either not know how to change this or will not bother
trying to.

Possible solutions (pros and cons):
1) One option is as follows: Whenever the first file is downloaded, ask the user
whether they want to always save their files to a certain location or whether
they would like to be prompted each time.
Pros: It would solve most of the issues for power users mentioned above (as well
as for the new users).
Cons: However, for somes users, they may click the wrong option and forever not
know how to fix it.
2) Set the default to "Ask me where to save every file," however include a
checkbox that says "Always save to this location" that the user could check if
they no longer wanted to be asked.
Pros: Same as #1, however this would also take care of the issue about the new
users accidentally clicking the wrong option the first time and be left with
something that he can never figure out how to change.  The user is less likely
to click the check box unless they know what they are doing.
Cons: Someone might accidentally click the checkbox and not know how to fix it.
 On the other hand, it must be noted that this method is something commonly done
in other programs (IE included).  Also, there's a possibility that people will
not understand what the checkbox option does, and will not try it.
3) Set the default to "Ask me where to save every file" and only allow this to
be changed by going into the options.
Pros: Same as #1, however it also prevents the chance of someone messing up like
in #1 and #2.
Cons: People, who, if told about the option, would use it, may never find out
about this feature because they don't look at the options panel.
4) Set the default to "Ask me where to save every file," however include a
button that would say something along the lines of: "Click Here to setup a
default download location (and never be prompted again for a download location)."
Pros: Would solve most of the useability problems mentioned in the other three.
Cons: It is a rather odd UI design, and might end up not being used because
people don't understand what it means.

Personally, I'm not 100% which solution is best (I would have to look into it
further), however, the fact is that defaulting to the "desktop" is not a good
idea for either power users or new users.  Thus, I think we need to consider how
to change this.

Reproducible: Always
Steps to Reproduce:
I don't think this is the problem you're making it out to be.  Options is very
visble from the Download Manager, so unless you always download tiny files, its
obvious where you click to change options.  Any power user worth the title will
look in the Options if they don't like a behaviour.  If "Downloads" isn't the
obvious place to look under Options... they have other problems.

And as for typical users not finding where their files went, if they don't
figure it out right away, they'll notice the files on their desktop once they
close their open windows.

If this was a big problem, we'd have ranting in the forums, and there would be
bugs on this by now complaining, its been a month since FF 0.8 came out and I
don't see anything in either case, so I think you're quite in the minority here.

Marking this WONTFIX, ben turned this on quite deliberately, and I think overall
its a good default setting, and barring some major problem/user backlash it will
stay.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
*** Bug 259025 has been marked as a duplicate of this bug. ***
I disagree: practically no other software stores data without asking first
where. Especially on Linux the default option of storing to the "Desktop" is
quite idiotic, especially if it is a distro or a window manager that does not
even have a "Desktop". 

Please don't mess up the standard way of applications interact with the user.
Again, especially on Linux this definitely messes up that standard way of
interaction. 

If this indeed does make sense for Windows users I would request that  bug
259025 not be marked a DUP for this, but instead track that bug for Linux users
only. 

If Ben "turned this on quite deliberately" I would really want to see a
justification for doing it here instead of a simple "it is just how it is". 
*** Bug 259025 has been marked as a duplicate of this bug. ***
*** Bug 287053 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit

Updated

9 years ago
Duplicate of this bug: 479000
You need to log in before you can comment on or make changes to this bug.