Closed Bug 237106 Opened 16 years ago Closed 16 years ago

stylesheets @import, background: url() not saved [File -- Save Page as... -- Web page, complete]

Categories

(Toolkit :: Downloads API, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: mithgol, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

[File -- Save Page as... -- Web page, complete] does not save:

1) Stylesheets imported in CSS [@import "...";]

2) Custom background images, attached by CSS [background: url(...);]

Locally saved webpage looks ugly when reopened from local drive.

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.alistapart.com/articles/customunderlines/
2. Launch menu item File -- Save Page as... -- Web page, complete
3. Close the browser
4. Open locally saved HTML, feel the difference

Actual Results:  
Page has gray backgound, its blocks are neither positioned, nor coloured.

Expected Results:  
The software should have saved the page, including CSS and images in XXX_files,
replacing URLs in @import and url(..) by their local components.

100% reproduced in Firebird 0.7, Firefox 0.8.

A major feature is broken (I'll set MAJOR severity).
Did you search bugzilla before filing the bug?

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.