"Try Again" on XUL error pages does not repost form data

RESOLVED FIXED in mozilla1.8beta2

Status

()

RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: jruderman, Assigned: Biesinger)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.8beta2
Points:
---
Bug Flags:
blocking1.8b -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040311
Firefox/0.8.0+ (mmoy-crc32)

I modified a bug while Bugzilla was down.  Clicking "try again" took me to
http://bugzilla.mozilla.org/process_bug.cgi, but it said "You apparently didn't
choose any bugs to modify."

I did not try to reproduce.
Keywords: helpwanted
(Reporter)

Comment 1

15 years ago
Happened again in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a)
Gecko/20040510 Firefox/0.8.0+

Comment 2

15 years ago
I seem to run into this problem very frequently when I play
kingdomofloathing.com.  I reproduce it every day.
Assignee: adamlock → cbiesinger
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta
biesi was thinking using location.reload() might work, but it seems to cause
other problems (and I'm still not sure it actually resend form POSTs).

Updated

14 years ago
Flags: blocking1.8b?

Updated

14 years ago
Flags: blocking1.8b? → blocking1.8b-
Posted patch use location.reload() (obsolete) — Splinter Review
this works for me. this patch includes the change from a link to a button for
"Try Again" (from bug 280190); I can undo that change if desired.
Attachment #174519 - Flags: review?(bzbarsky)
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: mozilla1.8beta1 → mozilla1.8beta2
Comment on attachment 174519 [details] [diff] [review]
use location.reload()

Hmm...	location.reload works because we don't stick the error page URI in
session history, I assume?  Document that here?

And leave the <p> around the <input>, please.

r+sr=bzbarsky with that.
Attachment #174519 - Flags: superreview+
Attachment #174519 - Flags: review?(bzbarsky)
Attachment #174519 - Flags: review+
Posted patch final patchSplinter Review
Attachment #174519 - Attachment is obsolete: true
Checking in docshell/resources/content/netError.js;
/cvsroot/mozilla/docshell/resources/content/netError.js,v  <--  netError.js
new revision: 1.6; previous revision: 1.5
done
Checking in docshell/resources/content/netError.xhtml;
/cvsroot/mozilla/docshell/resources/content/netError.xhtml,v  <--  netError.xhtml
new revision: 1.7; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 302991 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.