bugzilla_email_append.pl calls processmail which no longer exists

RESOLVED FIXED in Bugzilla 2.18

Status

()

defect
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: andemar, Assigned: justdave)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.6) Gecko/20040206 Firefox/0.8

After upgrading from 2.16 to 2.17.7 I noticed that the processmail script is
totally gone now.

Unfortunately it is still used by bugzilla_email_append.pl which fails now.

A copy of the script of 2.16 doesn't work anymore with the new db structure.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
bah, can't believe we missed that...  we *did* in theory fix stuff in contrib
that called it.  I know we got bug_email.pl :)
Assignee: preed → justdave
Status: UNCONFIRMED → NEW
Component: Email Notifications → Bugzilla-General
Ever confirmed: true
Summary: processmail gone in 2.17.7 → bugzilla_email_append.pl calls processmail which no longer exists
OK, on the premise that we should offer clean upgrades (even to people using
contrib) I'm gonna go on a limb and mark this for 2.18.
Status: NEW → ASSIGNED
Target Milestone: --- → Bugzilla 2.18
Thanks for the fast reply.

Maybe it would be a good idea to add a new processmail script just as a wrapper
for Bugzilla::BugMail::Send as a replacement for the old script.

This would ease the usage of other third party addons to bugzilla like
CVS/Bugzilla integrations
e.g. http://www.einval.com/~steve/software/cvs-bugzilla/

These scripts rely on the processmail script and otherwise would have to be
partially rewritten to work with the new BugMail module.
*** Bug 239446 has been marked as a duplicate of this bug. ***
Any easy workaround the processmail script issue?
*** Bug 239446 has been marked as a duplicate of this bug. ***
Posted patch Patch v1Splinter Review
PJ: Give this a shot and let me know if it works.  (untested, but it should
work)
I have been running the 2.17.6. The patch seems to be for 2.17.7. It looks like
it works from the command line (eg cat file | bugzilla_email_append.pl), but now
I can't (yet) figure out why it won't insert into a bug like it did before. So,
command line seems to do what it's suppose to; via email no.
Yes, the patch is against the CVS tip (newer than 2.17.7), but that shouldn't
affect this, because that file has barely been touched in ages, and the API for
Bugzilla::BugMail hasn't changed since processmail disappeared.

If it works from the command line, but not via email, then something is not
configured correctly in your email.  Do you get bounce notices when you attempt
to do email?  Are the permissions sufficient that sendmail and apache can both
access the data directory?

As root, you can try this:

cat file | su mail -s /bin/sh -c './bugzilla_email_append.pl'

Replace mail with the userid sendmail runs under.
If that works, that's no different than what happens when you send it email.
looks like when I got a copy of the 2.17.7 that the contrib dir perms were root
only and I copied that to the 2.17.6 contrib dir. Changed perms on contrib and
it works via email (postfix + procmail).

Thank you for the patch and the clues. I will try to get to 2.17.7 soon for testing.

PS not sure why the 2.17.6 did NOT like the $datadir in bugzilla_email_append.pl
- use Bugzilla::Config qw(:DEFAULT $datadir); - line. I seem to be able to get
around it, so don't worry. Error was ...""$datadir" is not exported by
the Bugzilla::Config module"... when run from command line.
ah, yes, $datadir was something new.  This patch didn't apply to the 2.17.6
version though?
I am not 100% sure that the 2.17.6 version of bugzilla_email_append.pl was pure.
It appeared to reject 1 of 2 chunks based on only one line difference. That was
a simply a missing "use Bugzilla::BugMail;".
OK, set this up on one of my boxes and tried it, it works on the tip.

Checking in contrib/bugzilla_email_append.pl;
/cvsroot/mozilla/webtools/bugzilla/contrib/bugzilla_email_append.pl,v  <-- 
bugzilla_email_append.pl
new revision: 1.8; previous revision: 1.7
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Flags: approval+
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.